Page 1 of 1

OpenEXR Comilation Error - Linux

Posted: Wed Nov 24, 2021 3:30 pm
by CodeHD

after some absence from here I'm using some holidays to refresh my setups, and also trying to get set up again with Linux - Manjaro right now to be precise.
I was using only Windows for the last few years, compiling LuxCore only on Windows also as a result of that.

After solving an initial missing symlink to libstdc++.a and libpython3.9.a, got to the point of compiling OpenEXR, failing there with a couple of errors.

I found the error messages relate to this post, which suggests that OpenEXR_2.4.1 (used by Lux) won't work with gcc_11.

Anyone come across this before, too? Is there anything I can can configure/set up/update myself to solve this?

Re: OpenEXR Comilation Error - Linux

Posted: Wed Nov 24, 2021 5:09 pm
by Dade
Just add a

Code: Select all

#include <limits>
to the file where you get the error.

Re: OpenEXR Comilation Error - Linux

Posted: Wed Nov 24, 2021 5:47 pm
by CodeHD
Hmm, just to be clear, do you mean in the OpenExr source files? the Error comes from an "ImfTiledMisc.cpp".

In any case, I have tried to do that, but it just keeps replacing the file in question with the original...
- I edited the file in LinuxCompile/distfiles/openexr-2.4.1.tar.gz
- I edited the file in /tmp/luxbuild/...
both return to original after the (failed) build. Where else could this be from? Console output suggests that the tar is uncompressed and hence should be the source.

Another thing: I just noticed some lines "sudo: apt: command not found" at the beginning. is this an indication that I will have trouble under a non-Debian distro anyways?

Re: OpenEXR Comilation Error - Linux

Posted: Wed Nov 24, 2021 9:28 pm
by CodeHD
ok I managed to override the replacement by utils/prepare and seems to have worked for compiling openexr.

After that, I needed to install also cmake and patchelf (maybe you want to add this to the LinuxCompile Readme? there is a list of requirements there that I did check before)

Afterwards it got quite far with the whole LuxCore compilation. Near the end it aborted. In CMakeError.log I find

Code: Select all

"undefinded reference to glXGetProcAddressEXT"
Any ideas about that one?

Re: OpenEXR Comilation Error - Linux

Posted: Thu Nov 25, 2021 4:39 pm
by CodeHD
Made some more progress today but still not building...

Yesterday's error was due to a missing glfw installation

Afterwards, I also got a build error with spdlog, which was fixed by using the latest spdlog headers from Github (1.8.0 -> 1.9.2)

Now I'm stuck with OpenImageIO resulting in errors, looks a little less obvious what would need to change, so I'll have to figure that out as well