Page 1 of 1

Make 2.3 builds against glibc 2.17

Posted: Mon Jan 13, 2020 11:47 am
by Yegor
Could you make 2.3 built against glibc 2.17? This is the industry standard library version at the moment and all of the big studios are prone to obey https://vfxplatform.com/. Or at least make a parallel builds for 2.17.
Even Blender itself started to stick to this standard.

Re: Make 2.3 builds against glibc 2.17

Posted: Mon Jan 13, 2020 12:24 pm
by Dade
The automatic builds are done on a Ubuntu 18.04 VM (so it should be glibc 2.27). What kind of problem do you have exactly ?

P.S. it should be pretty easy to build your own binaries if you need some specific version of the libraries used: https://github.com/LuxCoreRender/LinuxCompile

Re: Make 2.3 builds against glibc 2.17

Posted: Mon Jan 13, 2020 2:24 pm
by Yegor
Dade wrote:
Mon Jan 13, 2020 12:24 pm
The automatic builds are done on a Ubuntu 18.04 VM (so it should be glibc 2.27). What kind of problem do you have exactly ?

P.S. it should be pretty easy to build your own binaries if you need some specific version of the libraries used: https://github.com/LuxCoreRender/LinuxCompile
The problem here is that big studios are on "stable" os's like CentOS, which have old libs and could not be upgraded as they tied up to vfxplatform. So the download-and-take-a-look solution won't work for Luxcore in those studios (as mine is). I'll give it a shot and compile myself, though. 2.3 version is just awesome to have for caustics in my case.