Page 1 of 1

Camera exterior volume

Posted: Mon Jan 22, 2018 10:17 pm
by B.Y.O.B.
Hi,

it seems like the camera has no exterior volume property in LuxCore.
This leads to wrong renders if the camera is e.g. inside of a cube with a volume.
Can this feature be added?

Re: Camera exterior volume

Posted: Mon Jan 22, 2018 10:33 pm
by Dade
B.Y.O.B. wrote:
Mon Jan 22, 2018 10:17 pm
it seems like the camera has no exterior volume property in LuxCore.
This leads to wrong renders if the camera is e.g. inside of a cube with a volume.
Can this feature be added?
Are you looking for world volume (scene.world.volume.default):

Code: Select all

scene.volumes.vol_air.type = homogeneous
scene.volumes.vol_air.absorption = 0.0 0.0 0.0
scene.volumes.vol_air.scattering = 0.04 0.04 0.04
scene.volumes.vol_air.asymmetry = 0.0 0.0 0.0
scene.volumes.vol_air.multiscattering = 0
##
scene.world.volume.default = vol_air
https://github.com/LuxCoreRender/LuxCor ... ic.scn#L13

Re: Camera exterior volume

Posted: Mon Jan 22, 2018 10:54 pm
by B.Y.O.B.
I guess I am looking for that :)
Thanks.

edit: However, that would set this volume as default for all materials and lights, right?
What if I only want the camera to be in a volume, but not e.g. the sun?
I would have expected a "scene.camera.volume" setting.

Re: Camera exterior volume

Posted: Mon Jan 22, 2018 11:41 pm
by Dade
B.Y.O.B. wrote:
Mon Jan 22, 2018 10:54 pm
I guess I am looking for that :)
Thanks.

edit: However, that would set this volume as default for all materials and lights, right?
What if I only want the camera to be in a volume, but not e.g. the sun?
I would have expected a "scene.camera.volume" setting.
The default volume is used when the object lack of volume definitions. Just use an object with null material and an interior volume and place the camera inside the object.

Re: Camera exterior volume

Posted: Mon Jan 22, 2018 11:43 pm
by Dade
I am on a tablet at the moment, looking at your scene, have you assigned the monkey outside volume ?

Re: Camera exterior volume

Posted: Tue Jan 23, 2018 12:06 am
by B.Y.O.B.
Dade wrote:
Mon Jan 22, 2018 11:43 pm
I am on a tablet at the moment, looking at your scene, have you assigned the monkey outside volume ?
This was the problem, thanks, it works like expected now.