LuxCoreRender daily/automatic builds

News & Announcements regarding releases, features, exporters and project coordination.
MCurto
Posts: 30
Joined: Sun May 09, 2021 5:28 pm

Re: LuxCoreRender daily/automatic builds

Post by MCurto »

I'm sorry if I spread any misinformation, I did try yesterday and couldn't get it to work (same kind of error i would get in Mac before the 2.6.1 upgrade) retested again today and it does work with latest release on Fedora35. Most probably a user (my) error of some sort.Sry once more.
acasta69
Developer
Developer
Posts: 470
Joined: Tue Jan 09, 2018 3:45 pm
Location: Italy

Re: LuxCoreRender daily/automatic builds

Post by acasta69 »

Azure DevOps pipelines have discontinued the image "macOS-10.14", so MacOS daily builds are now failing.
At the moment this is not a problem: the latest changes are only typo corrections so that the "latest" image is up-to-date also for MacOS.
But can we switch to the image "macOS-10.15", or would that cause problems in the build?
I am a bit reluctant to just try it in order not to lose the available and working MacOS binaries.

U3dreal, could you please look into this, or let me know if I can just change to the newer image?
Support LuxCoreRender project with salts and bounties

Windows 10 64 bits, i7-4770 3.4 GHz, RAM 16 GB, GTX 970 4GB v445.87
S0rda
Posts: 94
Joined: Sun May 27, 2018 8:34 am

Re: LuxCoreRender daily/automatic builds

Post by S0rda »

Tried to get it to work with blender 3.0 and latest daily build, kernel compilation error.
kintuX
Posts: 768
Joined: Wed Jan 10, 2018 2:37 am

Re: LuxCoreRender daily/automatic builds

Post by kintuX »

What OS?

W10, Blender 3.01RC and Latest BlendLuxCore 2.61 (homebrew) works fine.
Only issues have lately started to appear w/ Blender 3.1 Alpha (corrupt geo).
S0rda
Posts: 94
Joined: Sun May 27, 2018 8:34 am

Re: LuxCoreRender daily/automatic builds

Post by S0rda »

Sorry, I didn't point it out right away. win10
S0rda
Posts: 94
Joined: Sun May 27, 2018 8:34 am

Re: LuxCoreRender daily/automatic builds

Post by S0rda »

kintuX wrote: Mon Jan 24, 2022 6:52 pm What OS?

W10, Blender 3.01RC and Latest BlendLuxCore 2.61 (homebrew) works fine.
Only issues have lately started to appear w/ Blender 3.1 Alpha (corrupt geo).
Blender 3.0.0, Lux - 2.61alpha0
kintuX
Posts: 768
Joined: Wed Jan 10, 2018 2:37 am

Re: LuxCoreRender daily/automatic builds

Post by kintuX »

S0rda wrote: Mon Jan 24, 2022 7:41 pm
kintuX wrote: Mon Jan 24, 2022 6:52 pm What OS?

W10, Blender 3.01RC and Latest BlendLuxCore 2.61 (homebrew) works fine.
Only issues have lately started to appear w/ Blender 3.1 Alpha (corrupt geo).
Blender 3.0.0, Lux - 2.61alpha0
A-ok, could you please make a thread and post specifics (console error report, steps to repro...) in User Support forums
this one is reserved for auto-building issues.

Thanks ;)
FloridaJo
Posts: 7
Joined: Tue Jul 09, 2019 11:37 am

Re: LuxCoreRender daily/automatic builds

Post by FloridaJo »

MCurto wrote: Sun Jan 09, 2022 11:13 pm I'm sorry if I spread any misinformation, I did try yesterday and couldn't get it to work (same kind of error i would get in Mac before the 2.6.1 upgrade) retested again today and it does work with latest release on Fedora35. Most probably a user (my) error of some sort.Sry once more.
I am experiencing the same thing for 2.6 on 2.93.4lts
marcatore
Donor
Donor
Posts: 461
Joined: Wed Jan 10, 2018 8:04 am

Re: LuxCoreRender daily/automatic builds

Post by marcatore »

Hi,
I'd like to test the latest daily build with the Blender 3.1 support but when I follow the link I see this
Image

and I can't see the zip files.
Something wrong by me or by the building system?
acasta69
Developer
Developer
Posts: 470
Joined: Tue Jan 09, 2018 3:45 pm
Location: Italy

Re: LuxCoreRender daily/automatic builds

Post by acasta69 »

Hi, yes, apparently there has been a problem in the automatic build for BlendLuxCore.
I have run the pipeline again, hopefully everything's ok again in some minutes.

EDIT: It failed again, I have now run everything from scratch, including LuxCore. It will take 1 hour or so, let's see...

EDIT 2: it looks all right now
Support LuxCoreRender project with salts and bounties

Windows 10 64 bits, i7-4770 3.4 GHz, RAM 16 GB, GTX 970 4GB v445.87
Post Reply