LuxCoreRender daily/automatic builds

News & Announcements regarding releases, features, exporters and project coordination.
JulianoLisboa
Posts: 146
Joined: Sat Feb 22, 2020 3:29 am

Re: LuxCoreRender daily/automatic builds

Post by JulianoLisboa »

Hi, when will we have a working build in Blender 3.0?
BlairKnox
Posts: 1
Joined: Thu Dec 30, 2021 2:40 pm

Re: LuxCoreRender daily/automatic builds

Post by BlairKnox »

Just checking. Does the BlendLuxCore latest build (pre-release) work for blender v3.0
User avatar
Dade
Developer
Developer
Posts: 5666
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: LuxCoreRender daily/automatic builds

Post by Dade »

BlairKnox wrote: Thu Dec 30, 2021 2:47 pm Just checking. Does the BlendLuxCore latest build (pre-release) work for blender v3.0
I think not yet.
Support LuxCoreRender project with salts and bounties
User avatar
Dade
Developer
Developer
Posts: 5666
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: LuxCoreRender daily/automatic builds

Post by Dade »

The next, under compilation, build should work fine with Blender v3.0. The source of the problem is a broken NumPy version used to compile Blender.

We have a workaround for that problem but it required to rollback a patch for a minor bug. It should effect only people exporting scene in text format for LuxCoreUI: viewtopic.php?f=4&t=3505

We will look for a different solution of the original problem too (one that doesn't trigger the broken Blender v3.0 NumPy).
Support LuxCoreRender project with salts and bounties
JulianoLisboa
Posts: 146
Joined: Sat Feb 22, 2020 3:29 am

Re: LuxCoreRender daily/automatic builds

Post by JulianoLisboa »

Dade wrote: Thu Jan 06, 2022 12:25 pm The next, under compilation, build should work fine with Blender v3.0. The source of the problem is a broken NumPy version used to compile Blender.

We have a workaround for that problem but it required to rollback a patch for a minor bug. It should effect only people exporting scene in text format for LuxCoreUI: viewtopic.php?f=4&t=3505

We will look for a different solution of the original problem too (one that doesn't trigger the broken Blender v3.0 NumPy).
Very good Dade, looking forward to it. Thanks
MCurto
Posts: 30
Joined: Sun May 09, 2021 5:28 pm

Re: LuxCoreRender daily/automatic builds

Post by MCurto »

I think there might be a slight problem with GitHub linux version for latest build 2.6.1, i've tried in Fedora/Blender 3.0 and doesn't seem to be working, funny thing is the one I compiled does work: :)

https://drive.google.com/file/d/1c64NPb ... sp=sharing
marcbartels
Posts: 2
Joined: Wed Apr 18, 2018 7:10 pm

Re: LuxCoreRender daily/automatic builds

Post by marcbartels »

MCurto wrote: Sat Jan 08, 2022 5:15 pm I think there might be a slight problem with GitHub linux version for latest build 2.6.1, i've tried in Fedora/Blender 3.0 and doesn't seem to be working, funny thing is the one I compiled does work: :)
I can confirm this is working, but the daily build is not.
Using Manjaro and Blender 3.0
User avatar
Dade
Developer
Developer
Posts: 5666
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: LuxCoreRender daily/automatic builds

Post by Dade »

Actually, LuxCore has always worked with Blender v3.0 on Linux, it was a Windows-only problem. I have downloaded the latest build and tried with Blender v3.0 on my Linux Ubuntu and it is working fine for me.

What kind of problem do you have ? A crash ? Is Blender v2.93+BlendLuxCore working ?
Support LuxCoreRender project with salts and bounties
User avatar
Dez!
Posts: 364
Joined: Sun Apr 08, 2018 1:09 am
Location: Ekaterinburg
Contact:

Re: LuxCoreRender daily/automatic builds

Post by Dez! »

I can confirm that ElementaryOS has been running smoothly around the clock. I've been using it in Blender 3 since January 4.
Linux Plasma | Ryzen 5, 32Gb, SSD M2, GT 590 RX | BenQ 27 | Wacom One | Microsoft Ergo | Tie Guan Yin tea
http://dezigner.tilda.ws/
marcbartels
Posts: 2
Joined: Wed Apr 18, 2018 7:10 pm

Re: LuxCoreRender daily/automatic builds

Post by marcbartels »

It is working correctly on Blender 2.93.

In Blender 3.0 on enabling the addon this error occurs:

Code: Select all

Making LuxCore denoiser executable
Traceback (most recent call last):
  File "/usr/share/blender/3.0/scripts/modules/addon_utils.py", line 351, in enable
    mod = __import__(module_name)
  File "/home/marc/.config/blender/3.0/scripts/addons/BlendLuxCore/__init__.py", line 66, in <module>
    raise Exception(msg + "\n\nImportError: %s" % error) from None
Exception: 

Could not import pyluxcore.

ImportError: /home/marc/.config/blender/3.0/scripts/addons/BlendLuxCore/bin/pyluxcore.so: undefined symbol: _PyTraceMalloc_NewReference
Post Reply