Under Linux Mint 21.2 in CPU mode, Luxcore does not render geometrie

Use this forum for general user support and related questions.
Forum rules
Please upload a testscene that allows developers to reproduce the problem, and attach some images.
Post Reply
LemyD
Posts: 4
Joined: Tue Sep 03, 2019 11:36 pm

Under Linux Mint 21.2 in CPU mode, Luxcore does not render geometrie

Post by LemyD »

Hello everybody,

I have an issue with Blender 3.6.2, Luxcore 2.7beta2 and Linux Mint 21.2. I hope someone can help me.
My Linux:
Screenshot from 2023-09-17 11-10-22.png
Linux Mint 21.2 in a AMD Ryzen 9 5900X
I am using 2 GPUs:
GPU: NVIDIA GeForce RTX 3060 Lite Hash Rate
GPU: NVIDIA 2d:00.0 NVIDIA Corporation Device 2786 (GeForce 4070 RTX)

When I render in viewport in GPU mode, the render is correct. Please see picture GPU Render.png.
GPU Render.png
When I render in CPU mode, the geometry is not rendered. Please see picture CPU Render.png
CPU Render.png

Does anyone know what causes this issue?
Thank you for your help.
User avatar
Odilkhan Yakubov
Posts: 211
Joined: Fri Jan 26, 2018 10:07 pm
Location: Tashkent, Uzbekistan

Re: Under Linux Mint 21.2 in CPU mode, Luxcore does not render geometrie

Post by Odilkhan Yakubov »

Hi.
1. Can you make screen from User pref > LuxCore > Film device
2. Can you paste log from Blender console?

P.s.: also open an issue on bug tracker: https://github.com/LuxCoreRender/BlendLuxCore/issues
___________________________________________________________________________
LuxCoreRender Developer for Blender
___________________________________________________________________________
LemyD
Posts: 4
Joined: Tue Sep 03, 2019 11:36 pm

Re: Under Linux Mint 21.2 in CPU mode, Luxcore does not render geometrie

Post by LemyD »

Hi,
Here is the screenshot:
Luxcore.png
And here is the output in the console:

Updating device list
Read blend: "/home/christian/Blender/Test_LuxCore.blend"
==================================================
[Engine/Viewport] New session
[Exporter] Creating session
[SDL][13.017] Define ImageMap: NamedObject
[SDL][13.017] Camera type: perspective
[SDL][13.017] Camera position: Point[2.04943, -10.9102, 1.90695]
[SDL][13.017] Camera target: Point[1.86957, -9.94205, 1.73276]
[SDL][13.017] Camera clipping plane disabled
140533143953160
140533143954312
[SDL][13.019] Material definition: 140533143953160
[SDL][13.019] Material definition: 140533143954312
[SDL][13.019] Scene objects count: 2
[SDL][13.019] Light definition: 140533143970824
[SDL][13.019] Light definition: 140533143969288
[SDL][13.019] Reading texture map: /home/christian/Blender/../../../mnt/Grafik/HDRI Haven/empty_warehouse_01_8k.hdr
[SDL][13.019] Mip map available: [8192x4096]
[SDL][13.019] Reading mip map level: 0
[LuxCore][13.605] Configuration:
[LuxCore][13.605] path.pathdepth.total = 7
[LuxCore][13.605] path.pathdepth.diffuse = 5
[LuxCore][13.605] path.pathdepth.glossy = 5
[LuxCore][13.605] path.pathdepth.specular = 6
[LuxCore][13.605] path.hybridbackforward.enable = 0
[LuxCore][13.605] path.hybridbackforward.partition = 0.5
[LuxCore][13.605] path.hybridbackforward.glossinessthreshold = 0.049
[LuxCore][13.605] rtpathcpu.zoomphase.size = 4
[LuxCore][13.605] rtpathcpu.zoomphase.weight = 0
[LuxCore][13.605] renderengine.type = "RTPATHCPU"
[LuxCore][13.605] sampler.type = "RTPATHCPUSAMPLER"
[LuxCore][13.605] film.width = 1065
[LuxCore][13.605] film.height = 430
[LuxCore][13.605] film.filter.type = "NONE"
[LuxCore][13.605] film.filter.width = 1.5
[LuxCore][13.605] lightstrategy.type = "LOG_POWER"
[LuxCore][13.605] scene.epsilon.min = 1e-05
[LuxCore][13.605] scene.epsilon.max = 0.1
[LuxCore][13.605] path.albedospecular.type = "REFLECT_TRANSMIT"
[LuxCore][13.605] path.albedospecular.glossinessthreshold = 0.05
[LuxCore][13.605] film.opencl.enable = 0
[LuxCore][13.605] path.forceblackbackground.enable = 0
[LuxCore][13.605] renderengine.seed = 1
[LuxCore][13.605] film.outputs.0.type = "RGB_IMAGEPIPELINE"
[LuxCore][13.605] film.outputs.0.index = 0
[LuxCore][13.605] film.outputs.0.filename = "RGB_IMAGEPIPELINE_0.png"
[LuxCore][13.605] film.imagepipelines.000.0.type = "NOP"
[LuxCore][13.605] film.imagepipelines.000.1.type = "TONEMAP_LINEAR"
[LuxCore][13.605] film.imagepipelines.000.1.scale = 1
[LuxCore][13.605] film.imagepipelines.000.radiancescales.0.enabled = 1
[LuxCore][13.605] film.imagepipelines.000.radiancescales.0.globalscale = 1
[LuxCore][13.605] film.imagepipelines.000.radiancescales.0.rgbscale = 1 1 1
[LuxCore][13.605] batch.haltspp = 0 0
[LuxCore][13.605] batch.halttime = 0
[LuxCore][13.605] File Name Resolver Configuration:
Export took 0.6 s
[LuxCore][13.605] Film resolution: 1065x430
[SDL][13.606] Film output definition: RGB_IMAGEPIPELINE [image.png]
[SDL][13.606] Image pipeline: film.imagepipelines.000
[SDL][13.606] Image pipeline step 0: NOP
[SDL][13.606] Image pipeline step 1: TONEMAP_LINEAR
[SDL][13.606] Film output definition: RGB_IMAGEPIPELINE [RGB_IMAGEPIPELINE_0.png]
[LuxRays][13.606] OpenCL support: enabled
[LuxRays][13.606] OpenCL Platform 0: NVIDIA CUDA
[LuxRays][13.606] CUDA support: enabled
[LuxRays][13.606] CUDA support: available
[LuxRays][13.606] CUDA driver version: 12.20
[LuxRays][13.606] CUDA device count: 2
[LuxRays][13.606] Optix support: available
[LuxRays][13.606] Device 0 name: Native
[LuxRays][13.606] Device 0 type: NATIVE_THREAD
[LuxRays][13.606] Device 0 compute units: 1
[LuxRays][13.606] Device 0 preferred float vector width: 4
[LuxRays][13.606] Device 0 max allocable memory: 17592186044415MBytes
[LuxRays][13.606] Device 0 max allocable memory block size: 17592186044415MBytes
[LuxRays][13.606] Device 0 has out of core memory support: 0
[LuxRays][13.606] Device 1 name: NVIDIA GeForce RTX 4070
[LuxRays][13.606] Device 1 type: OPENCL_GPU
[LuxRays][13.606] Device 1 compute units: 46
[LuxRays][13.606] Device 1 preferred float vector width: 1
[LuxRays][13.606] Device 1 max allocable memory: 12006MBytes
[LuxRays][13.606] Device 1 max allocable memory block size: 3001MBytes
[LuxRays][13.606] Device 1 has out of core memory support: 0
[LuxRays][13.606] Device 2 name: NVIDIA GeForce RTX 3060
[LuxRays][13.606] Device 2 type: OPENCL_GPU
[LuxRays][13.606] Device 2 compute units: 28
[LuxRays][13.606] Device 2 preferred float vector width: 1
[LuxRays][13.606] Device 2 max allocable memory: 12044MBytes
[LuxRays][13.606] Device 2 max allocable memory block size: 3011MBytes
[LuxRays][13.606] Device 2 has out of core memory support: 0
[LuxRays][13.606] Device 3 name: NVIDIA GeForce RTX 4070
[LuxRays][13.606] Device 3 type: CUDA_GPU
[LuxRays][13.606] Device 3 compute units: 1
[LuxRays][13.606] Device 3 preferred float vector width: 1
[LuxRays][13.606] Device 3 max allocable memory: 12006MBytes
[LuxRays][13.606] Device 3 max allocable memory block size: 17592186044415MBytes
[LuxRays][13.606] Device 3 has out of core memory support: 1
[LuxRays][13.606] Device 3 CUDA compute capability: 8.9
[LuxRays][13.606] Device 4 name: NVIDIA GeForce RTX 3060
[LuxRays][13.606] Device 4 type: CUDA_GPU
[LuxRays][13.606] Device 4 compute units: 1
[LuxRays][13.606] Device 4 preferred float vector width: 1
[LuxRays][13.606] Device 4 max allocable memory: 12044MBytes
[LuxRays][13.606] Device 4 max allocable memory block size: 17592186044415MBytes
[LuxRays][13.606] Device 4 has out of core memory support: 1
[LuxRays][13.606] Device 4 CUDA compute capability: 8.6
[LuxRays][13.606] Creating 24 intersection device(s)
[LuxRays][13.606] Allocating intersection device 0: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 1: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 2: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 3: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 4: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 5: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 6: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 7: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 8: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 9: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 10: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 11: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 12: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 13: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 14: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 15: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 16: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 17: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 18: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 19: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 20: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 21: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 22: Native (Type = NATIVE_THREAD)
[LuxRays][13.606] Allocating intersection device 23: Native (Type = NATIVE_THREAD)
[LuxCore][13.606] Configuring 24 CPU render threads
[LuxRays][13.606] Preprocessing DataSet
[LuxRays][13.607] Total vertex count: 28
[LuxRays][13.607] Total triangle count: 14
[LuxRays][13.607] Preprocessing DataSet done
[LuxRays][13.607] Adding DataSet accelerator: EMBREE
[LuxRays][13.607] Total vertex count: 28
[LuxRays][13.607] Total triangle count: 14
[LuxRays][13.607] EmbreeAccel build time: 0ms
[Engine/Viewport] Pausing session


Thank you.
Christian
User avatar
Odilkhan Yakubov
Posts: 211
Joined: Fri Jan 26, 2018 10:07 pm
Location: Tashkent, Uzbekistan

Re: Under Linux Mint 21.2 in CPU mode, Luxcore does not render geometrie

Post by Odilkhan Yakubov »

Are there have any errors on the console?
___________________________________________________________________________
LuxCoreRender Developer for Blender
___________________________________________________________________________
LemyD
Posts: 4
Joined: Tue Sep 03, 2019 11:36 pm

Re: Under Linux Mint 21.2 in CPU mode, Luxcore does not render geometrie

Post by LemyD »

Hi,
Sorry for my late Answer. No, there is no error.
Screenshot from 2023-09-20 11-22-27.png
Thx
Post Reply