Ignore intersecting geometry

Use this forum for general user support and related questions.
Forum rules
Please upload a testscene that allows developers to reproduce the problem, and attach some images.
Post Reply
chiraagm
Posts: 6
Joined: Tue May 11, 2021 8:34 am

Ignore intersecting geometry

Post by chiraagm »

Any help on this would be greatly appreciated.

I am attaching the image of the problem I am facing. It is not a problem with the render engine itself, but how it renders

Image

I am trying to get product viz for diamond jewelry, and a lot of the files submitted to us (by the customer) do not have diamond cuts below the diamonds (as can be seen in the image). This means that when rendering, the "metal" below the diamond shows through the diamond. Earlier when I had experimented with VRay, I was able to do a setting, which would allow for the metal to not be seen below the diamond (maybe something to do with transmission rays, not sure though). Or is there some setting which allows me to "prioritize" the diamond material over the metal's material.

Either way, is there a setting/workaround which would allow me to use the client's files as it is and not have the diamond "show through" the intersecting metal?

Thanks in advance!
User avatar
DionXein
Posts: 80
Joined: Mon Jun 01, 2020 10:22 am

Re: Ignore intersecting geometry

Post by DionXein »

chiraagm wrote: Mon Jun 20, 2022 10:15 am a lot of the files submitted to us (by the customer) do not have diamond cuts below the diamonds
It depends on software u using. If it's blender - in edit mode select all diamonds (or use select by material) and switch transform origin to Individual origins, scale down until intersections with metal gone. Also I recommend to check out last Dravia Studio tutorial about jewel production rendering.
tokiop
Posts: 41
Joined: Fri Apr 13, 2018 8:11 pm

Re: Ignore intersecting geometry

Post by tokiop »

Hi ! The "volume priority" or "volume precedence" feature might help you :
Volume Priority

Volumes have a priority setting, which is an integer number.
In regions where volumes overlap, the volume with highest priority is chosen and replaces all other volumes.
https://wiki.luxcorerender.org/LuxCoreR ... e_Priority
chiraagm
Posts: 6
Joined: Tue May 11, 2021 8:34 am

Re: Ignore intersecting geometry

Post by chiraagm »

DionXein wrote: Tue Jun 21, 2022 6:25 am
chiraagm wrote: Mon Jun 20, 2022 10:15 am a lot of the files submitted to us (by the customer) do not have diamond cuts below the diamonds
It depends on software u using. If it's blender - in edit mode select all diamonds (or use select by material) and switch transform origin to Individual origins, scale down until intersections with metal gone. Also I recommend to check out last Dravia Studio tutorial about jewel production rendering.

Thanks for your reply

I think the solution you have provided, works where the diamonds are intersecting with the claws/prongs. In my case the diamond cut (below the diamond) is not done in certain cases, so the solution to scale down does not work.

Will look at Dravia Studio's tutorials for help with the jewelry rendering. Thanks again!
Post Reply