Problem with volume and lights

Use this forum for general user support and related questions.
Forum rules
Please upload a testscene that allows developers to reproduce the problem, and attach some images.
Post Reply
Flink
Posts: 20
Joined: Fri Nov 23, 2018 8:38 am

Problem with volume and lights

Post by Flink »

Hi,

I'm working currently on an underwater scene and discovered some odd behavior of lights in volumes.
The Power of the lights is not as expected. I am not sure if it is some kind of bug or wrong settings.
Here is an example scene:
scene.png
I set world, camera and the volumes on the light sources but the area light seems off.
Both the mesh light and the area light in the example scene have the same size and power.
The scene is rendered with BiDir Engine.
render.png
Blender Version is 2.93.8 with LuxCore Version 2.6
Attachments
LightsVolumeExample.blend
(868.85 KiB) Downloaded 48 times
User avatar
Sharlybg
Donor
Donor
Posts: 3075
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Problem with volume and lights

Post by Sharlybg »

This look like a bug I have tried few things but it saty exactly the same.
Worse I have even found another strange behaviour:
Adding a point Light source to the scene will make it like a kind of
Black hole absorbing all rays in the scene:
bug volume and light.jpg
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA
kintuX
Posts: 770
Joined: Wed Jan 10, 2018 2:37 am

Re: Problem with volume and lights

Post by kintuX »

Works fine here.
LightsVolumeExample OK.blend.jpg
It's just that your "World needs to know its Volume" ;)
User avatar
Sharlybg
Donor
Donor
Posts: 3075
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Problem with volume and lights

Post by Sharlybg »

Great Kintux Just jump straight thinking this was already set
as the two other were working ;)
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA
Flink
Posts: 20
Joined: Fri Nov 23, 2018 8:38 am

Re: Problem with volume and lights

Post by Flink »

Thanks Kintux, that works great :D
But I don't understand, why it makes a difference.
The description of the world volume says:
"Default Volume (used on materials without attached volume)"

But i set the volume on the area light. So this should be used instead of the world volume :?:
Flink
Posts: 20
Joined: Fri Nov 23, 2018 8:38 am

Re: Problem with volume and lights

Post by Flink »

I did another test with some kind of a fish tank and have the next problem :roll:
render2.png
How do I set the volumes correctly in this case?
The outside of the tank is in contact with two volumes.
Attachments
LightsVolumeExample2.blend
(1.36 MiB) Downloaded 45 times
kintuX
Posts: 770
Joined: Wed Jan 10, 2018 2:37 am

Re: Problem with volume and lights

Post by kintuX »

Flink wrote: Wed Apr 06, 2022 7:52 pm I did another test with some kind of a fish tank and have the next problem :roll:

render2.png

How do I set the volumes correctly in this case?
The outside of the tank is in contact with two volumes.
To work like this?
LightsVolumeExample2(hack).png
Camera > Auto-Volume
MeshLight > World Volume
Point Light > HitPlane added


Disclaimer:
Based on your model,
what's "correctly set" here is arbitrary.
;)
Attachments
LightsVolumeExample2(hack)blend.blend
(1.37 MiB) Downloaded 38 times
Flink
Posts: 20
Joined: Fri Nov 23, 2018 8:38 am

Re: Problem with volume and lights

Post by Flink »

Thank you kintuX, really appreciate your help :)
That is the result I was looking for. But i don't understand why it is working like this.
Why does the meshlight need the world_volume aka. air when it is under water :?:
Is it just because of my ugly setup?

If we start with an empty scene. How would the correct way be to setup a submersed camera in a tank with some lights?
kintuX
Posts: 770
Joined: Wed Jan 10, 2018 2:37 am

Re: Problem with volume and lights

Post by kintuX »

Learn further, read & practice some more...
Test Underwater Paintings scene, check docs, tuts, explore forums... basically, construct knowledge with experience.
underwater paintings testscene.jpg
Example Scenes
Flink
Posts: 20
Joined: Fri Nov 23, 2018 8:38 am

Re: Problem with volume and lights

Post by Flink »

Hi kuntuX, once again thank you for your support :)
I did some more tests and got results I'm happy with.
It is just a rough layout of the scene with nearly no textures, but the lighting goes in the right direction.

Here is a denoised version of the rendering (low path depth). Any advises how to further improve the setup?
Underwater_base_denoised.png
Post Reply