Luxcore running on Blender 3.1

Use this forum for general user support and related questions.
Forum rules
Please upload a testscene that allows developers to reproduce the problem, and attach some images.
User avatar
Sharlybg
Donor
Donor
Posts: 3079
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Luxcore running on Blender 3.1

Post by Sharlybg »

:shock: You rock Neo ;)
Thanks you very much !
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA
JulianoLisboa
Posts: 146
Joined: Sat Feb 22, 2020 3:29 am

Re: Luxcore running on Blender 3.1

Post by JulianoLisboa »

Great job, Work fine for me in 3.1
MCurto
Posts: 31
Joined: Sun May 09, 2021 5:28 pm

Re: Luxcore running on Blender 3.1

Post by MCurto »

Hi,

unfortunately the latest release for Mac isn't working, I even deleted the cache from "luxecorerender.org" folder and the output is the same:
(Either for 3.0 or 3.1)

3.1:
Traceback (most recent call last):
File "/Applications/Blender_3_1.app/Contents/Resources/3.1/scripts/modules/addon_utils.py", line 351, in enable
mod = __import__(module_name)
File "/Users/miguel/Library/Application Support/Blender/3.1/scripts/addons/BlendLuxCore/__init__.py", line 66, in <module>
raise Exception(msg + "\n\nImportError: %s" % error) from None
Exception:

Could not import pyluxcore.

ImportError: cannot import name 'pyluxcore' from 'BlendLuxCore.bin' (/Users/miguel/Library/Application Support/Blender/3.1/scripts/addons/BlendLuxCore/bin/__init__.py)
3.0:
Traceback (most recent call last):
File "/Applications/Blender_3_0_1.app/Contents/Resources/3.0/scripts/modules/addon_utils.py", line 351, in enable
mod = __import__(module_name)
File "/Users/miguel/Library/Application Support/Blender/3.0/scripts/addons/BlendLuxCore/__init__.py", line 66, in <module>
raise Exception(msg + "\n\nImportError: %s" % error) from None
Exception:

Could not import pyluxcore.

ImportError: cannot import name 'pyluxcore' from 'BlendLuxCore.bin' (/Users/miguel/Library/Application Support/Blender/3.0/scripts/addons/BlendLuxCore/bin/__init__.py)
But I noticed a few days ago that the previous "latest build" had similar problems even for 3.0.
The one before (from a few weeks back) was working fine in 3.0 and did start in 3.1 but with same errors as mentioned before:

Default cube initial scene:
Screenshot 2022-03-15 at 10.47.18.jpg
User avatar
Sharlybg
Donor
Donor
Posts: 3079
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Luxcore running on Blender 3.1

Post by Sharlybg »

On Windows the clicking on the library asset bar Eye button give this error :
LOL Blender 3.1.jpg
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA
Post Reply