LuxCoreRender daily/automatic builds

News & Announcements regarding releases, features, exporters and project coordination.
User avatar
DionXein
Posts: 56
Joined: Mon Jun 01, 2020 10:22 am

Re: LuxCoreRender daily/automatic builds

Post by DionXein » Wed Apr 21, 2021 3:19 am

At v2.5 - if GPU contains RTX - is RTX\Optix automatically enabled in CUDA rendering? Because I can't see any checkbox today. (I read about changes, there is a note about force disabling Optix even if card support it)
Attachments
dd.jpg

acasta69
Developer
Posts: 428
Joined: Tue Jan 09, 2018 3:45 pm
Location: Italy

Re: LuxCoreRender daily/automatic builds

Post by acasta69 » Wed Apr 21, 2021 6:42 am

JulianoLisboa wrote:
Tue Apr 20, 2021 7:29 pm
It appears to me as a last update 11 days ago
The BlendLuxCore daily builds are now working again.

@B.Y.O.B. I have bumped the version number in BlendLuxCore to re-enable daily builds.
We were in a corner case for which I have no good solution yet: when the BlendLuxCore pipeline is triggered by a LuxCore daily build, and the latest BlendLuxCore commit is tagged for another release, no BlendLuxCore daily release is generated.
I'll try to fix this before next official release (I'm not sure if it's possible, however).
Support LuxCoreRender project with salts and bounties

Windows 10 64 bits, i7-4770 3.4 GHz, RAM 16 GB, GTX 970 4GB v445.87

User avatar
Dade
Developer
Posts: 5324
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: LuxCoreRender daily/automatic builds

Post by Dade » Wed Apr 21, 2021 10:28 am

DionXein wrote:
Wed Apr 21, 2021 3:19 am
is RTX\Optix automatically enabled in CUDA rendering?
Yes, it is enabled for all RTX GPUs and disabled on others (for instance GTX1080) because it is slower than our code in our tests.
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Posts: 4077
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCoreRender daily/automatic builds

Post by B.Y.O.B. » Wed Apr 21, 2021 12:55 pm

acasta69 wrote:
Wed Apr 21, 2021 6:42 am
@B.Y.O.B. I have bumped the version number in BlendLuxCore to re-enable daily builds.
We were in a corner case for which I have no good solution yet: when the BlendLuxCore pipeline is triggered by a LuxCore daily build, and the latest BlendLuxCore commit is tagged for another release, no BlendLuxCore daily release is generated.
I'll try to fix this before next official release (I'm not sure if it's possible, however).
Thanks.
Not sure if this is worth fixing, having to bump the version is not really a problem in my opinion.

epilectrolytics
Donor
Posts: 729
Joined: Thu Oct 04, 2018 6:06 am

Re: LuxCoreRender daily/automatic builds

Post by epilectrolytics » Wed Apr 21, 2021 1:00 pm

acasta69 wrote:
Wed Apr 21, 2021 6:42 am
The BlendLuxCore daily builds are now working again.
Somehow I cannot install the latest BlendLuxCore 2.6 alpha on Windows (screenshot below) or MacOS with Blender 2.92.
Screenshot (119).jpg
I have not Installed VS2019 because I saw it was reverted to VS2017.

mib2berlin
Posts: 49
Joined: Fri Apr 06, 2018 6:29 pm

Re: LuxCoreRender daily/automatic builds

Post by mib2berlin » Wed Apr 21, 2021 1:37 pm

Hi, I have the same as @epilectrolytics on Windows 10 and a different error on Linux.

Code: Select all

Making LuxCore denoiser executable
Traceback (most recent call last):
  File "/home/pepo/blender-2.92.0-linux64/2.92/scripts/modules/addon_utils.py", line 351, in enable
    mod = __import__(module_name)
  File "/home/pepo/.config/blender/2.92/scripts/addons/BlendLuxCore/__init__.py", line 63, in <module>
    raise Exception(msg + "\n\nImportError: %s" % error) from None
Exception: 

Could not import pyluxcore.

ImportError: libOpenImageDenoise.so.1: cannot open shared object file: No such file or directory
Cheers, mib

JulianoLisboa
Posts: 101
Joined: Sat Feb 22, 2020 3:29 am

Re: LuxCoreRender daily/automatic builds

Post by JulianoLisboa » Wed Apr 21, 2021 1:58 pm

I also can't install it on 2.83
2_83.jpg

acasta69
Developer
Posts: 428
Joined: Tue Jan 09, 2018 3:45 pm
Location: Italy

Re: LuxCoreRender daily/automatic builds

Post by acasta69 » Wed Apr 21, 2021 2:07 pm

I should have fixed this, some change was required because of upgraded libraries.
A new build should be ready in minutes.

I hope it works also on Linux, I have no way to check.
About MacOS I'm not able to help, sorry, but it's probably a different problem.
Support LuxCoreRender project with salts and bounties

Windows 10 64 bits, i7-4770 3.4 GHz, RAM 16 GB, GTX 970 4GB v445.87

epilectrolytics
Donor
Posts: 729
Joined: Thu Oct 04, 2018 6:06 am

Re: LuxCoreRender daily/automatic builds

Post by epilectrolytics » Wed Apr 21, 2021 2:44 pm

Now the Windows version works, thanks @acasta69 for the fix!
(MacOS 10.13 still defaults with error shown below:)
Screen Shot.png

mib2berlin
Posts: 49
Joined: Fri Apr 06, 2018 6:29 pm

Re: LuxCoreRender daily/automatic builds

Post by mib2berlin » Wed Apr 21, 2021 6:57 pm

acasta69 wrote:
Wed Apr 21, 2021 2:07 pm
I should have fixed this, some change was required because of upgraded libraries.
A new build should be ready in minutes.

I hope it works also on Linux, I have no way to check.
About MacOS I'm not able to help, sorry, but it's probably a different problem.
Thank you very much, your fix is working on Linux!

Cheers, mib

Post Reply