LuxCoreRender daily/automatic builds

News & Announcements regarding releases, features, exporters and project coordination.
juangea
Donor
Posts: 328
Joined: Thu Jan 02, 2020 6:23 pm

Re: LuxCoreRender daily/automatic builds

Post by juangea » Wed Jun 02, 2021 9:50 pm

Ok, thanks :)

User avatar
Dade
Developer
Posts: 5520
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: LuxCoreRender daily/automatic builds

Post by Dade » Thu Jun 03, 2021 9:42 am

Dade wrote:
Wed Jun 02, 2021 4:13 pm
juangea wrote:
Wed Jun 02, 2021 11:59 am
Are the Linux ones also with 3.9 or not yet?
Not yet.
New Linux builds are now on compatible with Blender v2.93.
Support LuxCoreRender project with salts and bounties

Carlosmpa
Posts: 3
Joined: Mon Jun 07, 2021 7:38 pm

Re: LuxCoreRender daily/automatic builds

Post by Carlosmpa » Wed Jun 09, 2021 7:13 pm

I must be doing something wrong on my side because I simply can't get Luxcore add-on to be enabled.
I deleted Blender 2.92, deleted all Luxcore install files. Downloaded Blender 2.93 and the latest BlendLuxCore build Today ( June9th).
I can install the plugin, but every time I try to enable it it shows the following error:
LuXCorre error.jpg

I had 2.5 working with no issues on Blender 2.92 with GPU support but.... well you know, there is a newer version so I upgraded...
I have tried to install the Master and replace the Bin files, did not work, Install the Latest build, will not enable.

I'm on a Mac Pro
OS 11.4 Intel Xeon E5. 64Gb Ram
Dual AMD FirePro D700

Any ideas on How I can get this working again?

User avatar
Dade
Developer
Posts: 5520
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: LuxCoreRender daily/automatic builds

Post by Dade » Wed Jun 09, 2021 10:53 pm

Carlosmpa wrote:
Wed Jun 09, 2021 7:13 pm
Any ideas on How I can get this working again?
Try to check if you have the mentioned missing file (i.e. "libtiff.5.dylib"). I don't have a a Mac but I downloaded the .zip and it looks like the motioned file is there.
Support LuxCoreRender project with salts and bounties

Carlosmpa
Posts: 3
Joined: Mon Jun 07, 2021 7:38 pm

Re: LuxCoreRender daily/automatic builds

Post by Carlosmpa » Thu Jun 10, 2021 6:21 pm

Thanks for the reply. I checked the installed folders and both of the files mentioned in the error are in the folder, so I'm not sure why the error says it can't be found.
LuxErr-2.jpg

Carlosmpa
Posts: 3
Joined: Mon Jun 07, 2021 7:38 pm

Re: LuxCoreRender daily/automatic builds

Post by Carlosmpa » Wed Jun 23, 2021 7:25 pm

So I found the solution to this and I thought I'd post in case anyone else runs into this same issue. it was a lot simpler than I thought.

The "scripts" folder was created with Read Only permissions. Once I changed the permissions for admins and system to be Read and Write then Luxcore installed successfully.

I found someone with a similar issue and the solution in this thread.
https://developer.blender.org/T77962

JulianoLisboa
Posts: 109
Joined: Sat Feb 22, 2020 3:29 am

Re: LuxCoreRender daily/automatic builds

Post by JulianoLisboa » Wed Jul 07, 2021 1:49 pm

Hello, in the new daily compilation this is giving this error when rendering via GPU. Even in the standard blender scene with a cube a light and a camera.

Unknown filter type in CompiledScene::AddImageMap(): 183620

User avatar
Dade
Developer
Posts: 5520
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: LuxCoreRender daily/automatic builds

Post by Dade » Wed Jul 07, 2021 2:11 pm

JulianoLisboa wrote:
Wed Jul 07, 2021 1:49 pm
Hello, in the new daily compilation this is giving this error when rendering via GPU. Even in the standard blender scene with a cube a light and a camera.

Unknown filter type in CompiledScene::AddImageMap(): 183620
I should have fixed this problem (the fix will be included in the next build).
Support LuxCoreRender project with salts and bounties

JulianoLisboa
Posts: 109
Joined: Sat Feb 22, 2020 3:29 am

Re: LuxCoreRender daily/automatic builds

Post by JulianoLisboa » Wed Jul 07, 2021 5:59 pm

Dade wrote:
Wed Jul 07, 2021 2:11 pm
JulianoLisboa wrote:
Wed Jul 07, 2021 1:49 pm
Hello, in the new daily compilation this is giving this error when rendering via GPU. Even in the standard blender scene with a cube a light and a camera.

Unknown filter type in CompiledScene::AddImageMap(): 183620
I should have fixed this problem (the fix will be included in the next build).
Thank you very much, you are always very helpful.

BlenderSushi
Posts: 1
Joined: Mon Aug 30, 2021 10:25 am

Re: LuxCoreRender daily/automatic builds

Post by BlenderSushi » Mon Aug 30, 2021 10:29 am

As for today, I can confirm it still does not work with macOS Monterey, M1 iMac, Blender 2.93. But 2.92 version works.
Attachments
Screen Shot 2021-08-30 at 8.24.28 pm.png

Post Reply