LuxCoreRender daily/automatic builds

News & Announcements regarding releases, features, exporters and project coordination.
User avatar
B.Y.O.B.
Developer
Posts: 4026
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCoreRender daily/automatic builds

Post by B.Y.O.B. » Tue Aug 04, 2020 7:19 pm

MetinSeven wrote:
Tue Aug 04, 2020 7:06 pm
The BlendLuxCore Preferences and the viewport render kernel precalculations only show CUDA, no OptiX. Is OptiX being used yet?
If you have the CUDA backend selected, there should be an OptiX option. If it's not there, you might not have a correct 2.5 installation? Try to delete the whole addon folder and do a fresh install of the daily build.

The user preferences should look like this:
Screenshot from 2020-08-04 21-18-13.png
MetinSeven wrote:
Tue Aug 04, 2020 7:06 pm
OptiX denoising is only available for the viewport. Will it also be available for the final rendering soon?
Yes, eventually.

User avatar
MetinSeven
Posts: 133
Joined: Sun Aug 18, 2019 10:19 am
Location: Netherlands
Contact:

Re: LuxCoreRender daily/automatic builds

Post by MetinSeven » Tue Aug 04, 2020 7:44 pm

Ah, thanks! I had overlooked the OptiX checkbox.
visualizer • illustrator • animator • 3D designer — metinseven.nl

Didymus70
Posts: 1
Joined: Wed Sep 02, 2020 3:13 pm

Re: LuxCoreRender daily/automatic builds

Post by Didymus70 » Wed Sep 02, 2020 3:26 pm

I have been attempting to search through this site to see if there is any news on when I can expect a release of a version that will be compatible with Blender 2.90 and have found nothing. Can someone let me know if this information has been released?

Harvester
Donor
Posts: 36
Joined: Thu Jan 25, 2018 8:06 pm

Re: LuxCoreRender daily/automatic builds

Post by Harvester » Wed Sep 02, 2020 4:05 pm

Have you tried to "install" LuxCore Render in Blender version 2.90.0? LuxCore Render 2.4 seems to work with Blender 2.90.0. Currently, the add-on states that this version of Blender (2.90.0) is not officially supported, so expect some potential issues which shall be reported to the developers.
Attachments
luxcore24_vs_blender290.jpg

acasta69
Developer
Posts: 389
Joined: Tue Jan 09, 2018 3:45 pm

Re: LuxCoreRender daily/automatic builds

Post by acasta69 » Thu Apr 08, 2021 1:44 pm

I just noticed that the automated build for Linux is not working since some days.
It stops when building OpenImageIO:

Code: Select all

]0;openimageio stage * Cleaning and unpacking openimageio
 * Compiling openimageio
 * Patching OpenImageIO
'/home/vsts/work/1/s/LinuxCompile/distfiles/oiio-1.8.13-plugin.cpp' -> 'src/libutil/plugin.cpp'
'/home/vsts/work/1/s/LinuxCompile/distfiles/oiio-1.8.13-filesystem.cpp' -> 'src/libutil/filesystem.cpp'
'/home/vsts/work/1/s/LinuxCompile/distfiles/oiio-1.8.13-compiler.cmake' -> 'src/cmake/compiler.cmake'
platform=linux64, hw=x86_64
OPENIMAGEIO_SITE = fv-az315-942
dist_dir = dist/linux64
INSTALL_PREFIX = /tmp/luxbuild/oiio-Release-1.8.13/dist/linux64
CMake Error: Unknown argument -g3
CMake Error: Run 'cmake --help' for all supported options.
Makefile:332: recipe for target 'cmakesetup' failed
make: *** [cmakesetup] Error 1
 !!! openimageio compilation failed
I can't understand what's going on, but I would think it might be related to the monthly update in Azure Ubuntu 18.04 image. E.g. cmake was upgraded to 3.20 from 3.19.x
Support LuxCoreRender project with salts and bounties

Windows 10 64 bits, i7-4770 3.4 GHz, RAM 16 GB, GTX 970 4GB v445.87

User avatar
Dade
Developer
Posts: 5089
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: LuxCoreRender daily/automatic builds

Post by Dade » Fri Apr 09, 2021 9:48 am

I should have fixed the problem (running the Azure pipeline).
Support LuxCoreRender project with salts and bounties

Post Reply