Page 5 of 12

Re: Windows Build FAILED

Posted: Sun Apr 26, 2020 7:16 pm
by B.Y.O.B.
Ah, didn't know it was deprecated. I'll use the replacement.

Re: Windows Build FAILED

Posted: Sun Apr 26, 2020 9:57 pm
by B.Y.O.B.
Ok, CUDA devices now show up in BlendLuxCore and the device string is now the correct length.

However, I'm getting the following error:

Code: Select all

[LuxRays][12.891] [BVHKernel] Compiling kernels
[LuxRays][12.891] [BVHKernel] CUDA program compilation error:
nvrtc: error: failed to open nvrtc-builtins64_101.dll.
  Make sure that nvrtc-builtins64_101.dll is installed correctly.
Traceback (most recent call last):
  File "C:\Users\Simon\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\BlendLuxCore_git\engine\base.py", line 83, in render_final
    final.render(self, depsgraph)
  File "C:\Users\Simon\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\BlendLuxCore_git\engine\final.py", line 49, in render
    _render_layer(engine, depsgraph, statistics, layer)
  File "C:\Users\Simon\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\BlendLuxCore_git\engine\final.py", line 73, in _render_layer
    engine.session.Start()
RuntimeError: BVHKernel CUDA program compilation error
Do I have to install anything besides the Nvidia driver to make it work on Windows 10?

Re: Windows Build FAILED

Posted: Sun Apr 26, 2020 11:18 pm
by Dade
B.Y.O.B. wrote:
Sun Apr 26, 2020 9:57 pm
Do I have to install anything besides the Nvidia driver to make it work on Windows 10?
The DLL is included in CUDA SDK however I was under the impression Acasta69 was including the DLL in our archive too :?:

Re: Windows Build FAILED

Posted: Sun Apr 26, 2020 11:46 pm
by B.Y.O.B.
Dade wrote:
Sun Apr 26, 2020 11:18 pm
B.Y.O.B. wrote:
Sun Apr 26, 2020 9:57 pm
Do I have to install anything besides the Nvidia driver to make it work on Windows 10?
The DLL is included in CUDA SDK however I was under the impression Acasta69 was including the DLL in our archive too :?:
I have these binaries in the addon's bin folder:

Re: Windows Build FAILED

Posted: Sun Apr 26, 2020 11:57 pm
by Dade
B.Y.O.B. wrote:
Sun Apr 26, 2020 11:46 pm
Dade wrote:
Sun Apr 26, 2020 11:18 pm
B.Y.O.B. wrote:
Sun Apr 26, 2020 9:57 pm
Do I have to install anything besides the Nvidia driver to make it work on Windows 10?
The DLL is included in CUDA SDK however I was under the impression Acasta69 was including the DLL in our archive too :?:
I have these binaries in the addon's bin folder:
I assume Nvidia driver doesn't look in that directory. The builtin dll is likely to be loaded by the driver.

Re: Windows Build FAILED

Posted: Mon Apr 27, 2020 7:22 am
by acasta69
Dade wrote:
Sun Apr 26, 2020 11:57 pm
I assume Nvidia driver doesn't look in that directory. The builtin dll is likely to be loaded by the driver.
On my desktop PC LuxcoreUI works correctly with the two DLLs in the same folder as the LuxcoreUI executable, and stops working when I remove them.
I assumed the same was true for pyluxcore, but it stopped with the "wrong length" error for the device selection string, and probably the DLLs are search for later.

At the moment I am on my laptop and situation is a bit different. This is what I get in Blender console when trying to render the default cube scene with PathOCL + CUDA:

Code: Select all

[LuxRays][1244.016] [Device Quadro M1000M CUDAIntersect] Sample buffer size: 311296Kbytes
Traceback (most recent call last):
  File "C:\Users\italcas1\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\BlendLuxCore\engine\base.py", line 83, in render_final
    final.render(self, depsgraph)
  File "C:\Users\italcas1\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\BlendLuxCore\engine\final.py", line 49, in render
    _render_layer(engine, depsgraph, statistics, layer)
  File "C:\Users\italcas1\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\BlendLuxCore\engine\final.py", line 73, in _render_layer
    engine.session.Start()
RuntimeError: CUDA driver API error CUDA_ERROR_OUT_OF_MEMORY (code: 2, file:D:\a\1\Luxcore\src\luxrays\devices\cudadevice.cpp, line: 440): out of memory

ERROR: CUDA driver API error CUDA_ERROR_OUT_OF_MEMORY (code: 2, file:D:\a\1\Luxcore\src\luxrays\devices\cudadevice.cpp, line: 440): out of memory

Error: CUDA driver API error CUDA_ERROR_OUT_OF_MEMORY (code: 2, file:D:\a\1\Luxcore\src\luxrays\devices\cudadevice.cpp, line: 440): out of memory
At that point the two DLLs should have already kicked in.

I'll do more tests as soon as possible, but I have two-three quite busy days ahead of me, sorry...

P.S. By the way, the cube scene works perfectly on the laptop if I select the openCL device.

Re: Windows Build FAILED

Posted: Mon Apr 27, 2020 7:42 am
by acasta69
Indeed, another quick test on the laptop showed that, if the DLLs are not present at all, the addon is not even loaded.
Restoring them in the addon bin directory made it work.

Re: Windows Build FAILED

Posted: Mon Apr 27, 2020 7:53 am
by johannes.wilde
[LuxRays][30.219] [BVHKernel] Compiling kernels
[LuxRays][30.219] [BVHKernel] CUDA program compilation error:
nvrtc: error: failed to open nvrtc-builtins64_101.dll.
Make sure that nvrtc-builtins64_101.dll is installed correctly.

This is what i get with BlendLuxCoreCuda for Win with the latest builds

Re: Windows Build FAILED

Posted: Mon Apr 27, 2020 8:10 am
by mischterlampe
Hi,

I use the Link from kintux a few days ago.
http://www.cngwireless.net/apps/Drivers ... etwork.exe
to download the nvidia cuda sdk and the the compiling worked.

But I think there is a newer SDK Version available. Dont know if that makes a different.


But I ran into the next problem.
I get this error:

self._width, self._height, combined.as_pointer(), False, True)
RuntimeError: clEnqueueWriteBuffer
ERROR: clEnqueueWriteBuffer
[LuxCore][1690.265] [GeForce RTX 2070 OpenCLIntersect] Memory used for hardware image pipeline: 1025390Kbytes

I have two rtx cards and when i select both for cuda rendering i get the error. Also if i choose the one where the monitor is connected.
If I choose only the second one I can render the image.
Viewport rendering works with both selected.

Re: Windows Build FAILED

Posted: Mon Apr 27, 2020 10:24 am
by Dade
acasta69 wrote:
Mon Apr 27, 2020 7:22 am
At the moment I am on my laptop and situation is a bit different. This is what I get in Blender console when trying to render the default cube scene with PathOCL + CUDA:

Code: Select all

[LuxRays][1244.016] [Device Quadro M1000M CUDAIntersect] Sample buffer size: 311296Kbytes
It may be this problem: https://stackoverflow.com/questions/138 ... mory-fails

311296Kbytes is a quite big chunk of memory and you may hit a this Windows specfic limit on the laptop :?: