Boost 1.72 error

Discussion related to the Engine functionality, implementations and API.
Post Reply
Fox
Posts: 404
Joined: Sat Mar 31, 2018 11:17 am

Boost 1.72 error

Post by Fox » Sat Jan 25, 2020 12:02 am

cmake 3.16.3
Boost 1.72
Win10 running the .\cmake-build-x64.bat
'_snprintf': is not a member of 'std'

Code: Select all

       "C:\Users\Human\Documents\cp\WindowsCompile\Build_CMake\LuxCore\LuxRays.sln" (default target) (1) ->
       "C:\Users\Human\Documents\cp\WindowsCompile\Build_CMake\LuxCore\src\luxcore\pyluxcore.vcxproj.metaproj" (default
        target) (18) ->
       "C:\Users\Human\Documents\cp\WindowsCompile\Build_CMake\LuxCore\src\luxcore\pyluxcore.vcxproj" (default target)
       (26) ->
       (ClCompile target) ->
         c:\users\human\documents\cp\windowscompiledeps\include\boost\boost\system\detail\system_category_win32.hpp(52)
       : error C2039: '_snprintf': is not a member of 'std' (compiling source file C:\Users\Human\Documents\cp\LuxCore\
       src\luxcore\pyluxcoreforblender.cpp) [C:\Users\Human\Documents\cp\WindowsCompile\Build_CMake\LuxCore\src\luxcore
       \pyluxcore.vcxproj]
         c:\users\human\documents\cp\windowscompiledeps\include\boost\boost\system\detail\system_category_win32.hpp(52)
       : error C2039: '_snprintf': is not a member of 'std' (compiling source file C:\Users\Human\Documents\cp\LuxCore\
       src\luxcore\pyluxcore.cpp) [C:\Users\Human\Documents\cp\WindowsCompile\Build_CMake\LuxCore\src\luxcore\pyluxcore
       .vcxproj]

User avatar
Dade
Developer
Posts: 3935
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Boost 1.72 error

Post by Dade » Sat Jan 25, 2020 10:26 am

You should use the Boost version provided with cmake-build-x64.bat: we don't support any other version.
Support LuxCoreRender project with salts and bounties

Fox
Posts: 404
Joined: Sat Mar 31, 2018 11:17 am

Re: Boost 1.72 error

Post by Fox » Sat Jan 25, 2020 12:26 pm

Dade wrote:
Sat Jan 25, 2020 10:26 am
You should use the Boost version provided with cmake-build-x64.bat: we don't support any other version.
Ok.

Post Reply