BlendLuxCore2.1 crashing

Use this forum for general user support and related questions.
Post Reply
User avatar
epilectrolytics
Donor
Donor
Posts: 404
Joined: Thu Oct 04, 2018 6:06 am

BlendLuxCore2.1 crashing

Post by epilectrolytics » Tue Jan 08, 2019 3:53 pm

My old causticcube file crashes Blender with BlendLuxCore 2.1 (release/beta4/beta3)
It is difficult to reproduce, blender crashes without windows notification and there's no crash.txt in the TEMP directory.
But on MacOSX I found crashlogs.

Code: Select all

Exception Type:        EXC_CRASH (SIGSEGV)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   blender [599]
Here's a folder including the textures because without I could not reproduce the crash.
https://www.dropbox.com/s/wvuo5zkf8fkj601/luxcrash.zip
Edit: file removed because the issue is solved: crash due to corrupted file
Last edited by epilectrolytics on Wed Jan 09, 2019 11:40 am, edited 1 time in total.
MBPro 15" 16GB i7-4850HQ GT750M, MacOS 10.13.6 & Win10Pro PC 16GB Ryzen 2700X, RTX 2070, GTX 1060

User avatar
B.Y.O.B.
Developer
Developer
Posts: 2683
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: BlendLuxCore2.1 crashing

Post by B.Y.O.B. » Tue Jan 08, 2019 4:16 pm

The textures are not packed and don't have relative paths, so I had to do File -> External Data -> Find Missing Files.

I pressed F12 afterwards, but it renders fine on my Linux.
Have you tried disabling the OpenCL imagepipeline in the camera settings?

Are you rendering on CPU or GPU?
Support LuxCoreRender project with salts and bounties

User avatar
epilectrolytics
Donor
Donor
Posts: 404
Joined: Thu Oct 04, 2018 6:06 am

Re: BlendLuxCore2.1 crashing

Post by epilectrolytics » Tue Jan 08, 2019 6:41 pm

The textures are messed up because I am constantly transferring files from Mac to PC and back again, with different texture paths on each system.
I was used to reassign the textures in the image nodes, now that I used your suggestion "Find Missing Files" instead it works better.

I'm rendering PathCPU.
The file was created last year with an alpha version of BlendLuxCore on my MacBook and worked well then.
Yesterday I opened it with 2.1 release on my PC and changed from BidirCPU to PathCPU and since then see it crashing sooner or later, even back on the Mac.

Now with reassigned textures and OpenCL imagepipeline disabled apparently it works well.

:?
MBPro 15" 16GB i7-4850HQ GT750M, MacOS 10.13.6 & Win10Pro PC 16GB Ryzen 2700X, RTX 2070, GTX 1060

User avatar
B.Y.O.B.
Developer
Developer
Posts: 2683
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: BlendLuxCore2.1 crashing

Post by B.Y.O.B. » Tue Jan 08, 2019 6:47 pm

epilectrolytics wrote:
Tue Jan 08, 2019 6:41 pm
and OpenCL imagepipeline disabled apparently it works well.
It might be a problem in your OpenCL installation.
Support LuxCoreRender project with salts and bounties

User avatar
epilectrolytics
Donor
Donor
Posts: 404
Joined: Thu Oct 04, 2018 6:06 am

Re: BlendLuxCore2.1 crashing

Post by epilectrolytics » Wed Jan 09, 2019 10:52 am

epilectrolytics wrote:
Tue Jan 08, 2019 6:41 pm
Now with reassigned textures and OpenCL imagepipeline disabled apparently it works well.
Nope, crashed later after 1-2 hours of rendering.
I've come to think the file may be corrupted.
I tested other versions of the scene and those render fine no matter what engine.
Also the official Lux benchmark, which is PathOpenCL, shows no problems.

I'm going to discard that file and move on, fingers crossed :)
MBPro 15" 16GB i7-4850HQ GT750M, MacOS 10.13.6 & Win10Pro PC 16GB Ryzen 2700X, RTX 2070, GTX 1060

User avatar
epilectrolytics
Donor
Donor
Posts: 404
Joined: Thu Oct 04, 2018 6:06 am

Re: BlendLuxCore2.1 crashing

Post by epilectrolytics » Wed Jan 09, 2019 11:16 am

Just got an idea from another thread:
It is possible that I opened and saved the file with the nightly build of Blender that I need for nVidia RTX support in Cycles.
There are changes in the material system there that might have messed up things.

I need to remind myself not to save anything with that version of Blender.
MBPro 15" 16GB i7-4850HQ GT750M, MacOS 10.13.6 & Win10Pro PC 16GB Ryzen 2700X, RTX 2070, GTX 1060

Post Reply