Artifacts running GPU

Use this forum for general user support and related questions.
Post Reply
stefdln
Posts: 29
Joined: Tue Oct 23, 2018 11:44 am
Location: FR

Artifacts running GPU

Post by stefdln » Sat Nov 03, 2018 4:03 pm

Hey everyone
I was just fiddling around showing stuff to someone and I noticed I'm getting really bad artifacts on that cylinder when running GPU mode. As you can see this does not show up when rendering with CPU only.
This is kind of annoying, is this a known terminator related issue ?
Thanks in advance
Cheers
Attachments
GPUtest.png
CPUtest.png

User avatar
B.Y.O.B.
Developer
Posts: 1718
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Artifacts running GPU

Post by B.Y.O.B. » Sat Nov 03, 2018 4:07 pm

Your scene might be very large or very small, or the object has some huge scale that was not applied.
The fastest way to solve this problem is to raise the min.epsilon value in the scene settings (press the "Advanced LuxCore Settings" button in the unit settings to see this option).
Attachments
2018-08-16_15-34-21.png
Support LuxCoreRender project with salts and bounties

stefdln
Posts: 29
Joined: Tue Oct 23, 2018 11:44 am
Location: FR

Re: Artifacts running GPU

Post by stefdln » Sat Nov 03, 2018 4:19 pm

0.0001 did not do the trick but 0.001 worked like a charm, thanks
Aso, I did not find anything about this setting on the wiki page, what's it for exactly ? How does it affect my render ?

User avatar
B.Y.O.B.
Developer
Posts: 1718
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Artifacts running GPU

Post by B.Y.O.B. » Sat Nov 03, 2018 7:33 pm

The problem is caused by the low precision of floating point numbers.
The min. epsilon is a small value that is added in some places to avoid this issue. For example, it is added to rays to offset them a bit from the hit surface, to avoid wrong self-shadowing.
See also viewtopic.php?f=2&t=560&hilit=epsilon&start=10#p5517
Support LuxCoreRender project with salts and bounties

lacilaci
Posts: 342
Joined: Fri May 04, 2018 5:16 am

Re: Artifacts running GPU

Post by lacilaci » Sun Nov 04, 2018 8:23 am

Well it still remains a question why it is acting differently on cpu than on gpu and if something can be done about it. I've seen changing min. epsilon value impacting volume rendering a lot and it took me quite a bit of time to figure out what's going on.

stefdln
Posts: 29
Joined: Tue Oct 23, 2018 11:44 am
Location: FR

Re: Artifacts running GPU

Post by stefdln » Sun Nov 04, 2018 1:26 pm

B.Y.O.B. wrote:
Sat Nov 03, 2018 7:33 pm
The problem is caused by the low precision of floating point numbers.
The min. epsilon is a small value that is added in some places to avoid this issue. For example, it is added to rays to offset them a bit from the hit surface, to avoid wrong self-shadowing.
See also viewtopic.php?f=2&t=560&hilit=epsilon&start=10#p5517
thanks for your explanation

Post Reply