I have a problem to install 2.1alpha4

Use this forum for general user support and related questions.
stefdln
Posts: 29
Joined: Tue Oct 23, 2018 11:44 am
Location: FR

Re: I have a problem to install 2.1alpha4

Post by stefdln » Tue Oct 23, 2018 11:51 am

Hey everyone
Had the same problem here, installed the Intel redistributable yesterday, everything was fine after restarting Blender.
This morning I had the same warning message as yours coming back.
I had to repair Intel's redistributable installation to have Luxcore working again.
Hope this helps

BigGoga
Posts: 9
Joined: Fri Jun 01, 2018 9:28 am
Location: BY

Re: I have a problem to install 2.1alpha4

Post by BigGoga » Tue Oct 23, 2018 12:34 pm

Dade wrote:
Tue Oct 23, 2018 11:48 am
BigGoga wrote:
Tue Oct 23, 2018 10:53 am
When I launch LuxCore UI there is no error.
This mean the problem is python related. Are you sure to use the official Blender 2.79b (Python v3.5) and not a daily build or v2.80 (Python v3.6) ?
I sent you a file with my system info. Private message

User avatar
Dade
Developer
Posts: 1465
Joined: Mon Dec 04, 2017 8:36 pm

Re: I have a problem to install 2.1alpha4

Post by Dade » Tue Oct 23, 2018 4:01 pm

BigGoga wrote:
Tue Oct 23, 2018 12:34 pm
I sent you a file with my system info. Private message
I'm running out of idea.

The system info reports a Blender "version: 2.79 (sub 0), branch: master, commit date: 2018-03-22 14:10", it may lack the "b" but I don't know if it is supposed to appear there or not. Anyway pyluxcore can be imported in plain v2.79 too (the only problem is that Blender had a catastrophic bug that was than fixed in "b" version).

Can you check if you have the following files in "C:\Users\pechenov\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\BlendLuxCore\bin" ?
files.jpg
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Posts: 1738
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: I have a problem to install 2.1alpha4

Post by B.Y.O.B. » Tue Oct 23, 2018 4:04 pm

Dade wrote:
Tue Oct 23, 2018 4:01 pm
The system info reports a Blender "version: 2.79 (sub 0), branch: master, commit date: 2018-03-22 14:10", it may lack the "b" but I don't know if it is supposed to appear there or not.
This is Blender 2.79b, the version number is misleading.

Code: Select all

>>> bpy.app.version_string
'2.79 (sub 0)'

>>> bpy.app.version
(2, 79, 0)
Support LuxCoreRender project with salts and bounties

BigGoga
Posts: 9
Joined: Fri Jun 01, 2018 9:28 am
Location: BY

Re: I have a problem to install 2.1alpha4

Post by BigGoga » Tue Oct 23, 2018 5:02 pm

Screen3.jpg
when i run pyluxcoretool.exe i see
Screen4.jpg

BigGoga
Posts: 9
Joined: Fri Jun 01, 2018 9:28 am
Location: BY

Re: I have a problem to install 2.1alpha4

Post by BigGoga » Tue Oct 23, 2018 6:03 pm

I have this error when I run the installation on my Linux desktop
Screen 2018-10-23 20-50-56_result.jpg
LInux Mint 19 x64
Last edited by BigGoga on Tue Oct 23, 2018 6:30 pm, edited 1 time in total.

User avatar
B.Y.O.B.
Developer
Posts: 1738
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: I have a problem to install 2.1alpha4

Post by B.Y.O.B. » Tue Oct 23, 2018 6:07 pm

numpy is bundled with Blender, so something is going wrong.
I remember someone having a similar problem.
You could try to rename your Blender addons folder (.config/Blender/2.79/scripts/addons if I'm not mistaken).
Or maybe your Python installation is somehow messed up?

You could also try "pip3 install numpy", but I doubt it will help since Blender shouldn't use the system Python in the first place.
Support LuxCoreRender project with salts and bounties

BigGoga
Posts: 9
Joined: Fri Jun 01, 2018 9:28 am
Location: BY

Re: I have a problem to install 2.1alpha4

Post by BigGoga » Tue Oct 23, 2018 7:32 pm

On another computer I do not run luxmark
Screen5.jpg

Post Reply