ImportError: libOpenCL.so.1 when activating add-on

Use this forum for general user support and related questions.
Post Reply
mick
Posts: 52
Joined: Mon May 21, 2018 7:57 pm

ImportError: libOpenCL.so.1 when activating add-on

Post by mick » Tue Jul 10, 2018 2:40 pm

After installing Ubuntu 18.04 I had to re-install quite everything. For cuda there are unresolvable conflicts for packages. So I had to use install cuda-9-0 with run script.

After installing the luxcore file, when I try the activate the add-on I get a traceback from BlendLuxCore/__init__.py:
ImportError: libOpenCL.so.1

This file is in /usr/local/cuda-9.0/lib64/libOpenCL.so.1
and
/usr/local/cuda is linked to /usr/local/cuda-9.0

Also tried:
ln -s /usr/local/cuda-9.0/lib64/libOpenCL.so.1 /home/mick/.local/lib/python2.7/site-packages/

Where does blender / BlendLuxCore look for it? Which python installation does it use?

Suggestion on how to resolve the issue?

Thanks

mick
Posts: 52
Joined: Mon May 21, 2018 7:57 pm

Re: ImportError: libOpenCL.so.1 when activating add-on

Post by mick » Tue Jul 10, 2018 5:30 pm

solved it with

Code: Select all

sudo apt install ocl-icd-opencl-dev
I feared that it would destroy my manual cuda installation. But it seems to work fine.

Post Reply