LuxCore doesn't delete Materials

Use this forum for general user support and related questions.
Post Reply
Burk
Posts: 27
Joined: Wed Jun 06, 2018 5:58 pm
Location: Hamburg, Germany

LuxCore doesn't delete Materials

Post by Burk » Sun Jun 17, 2018 10:04 am

Luxcore 2.0, Blender 2.79b

Materials whithout user are not deleted when I save the file and reenter later.

Solution: Switch the Render Engine to Cycles, save, open again and the materials whithout users are deleted

User avatar
B.Y.O.B.
Developer
Posts: 1728
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCore doesn't delete Materials

Post by B.Y.O.B. » Sun Jun 17, 2018 1:38 pm

I can not reproduce this.
Are the materials listed in the "Orphan Data" view of the outliner?
Support LuxCoreRender project with salts and bounties

Burk
Posts: 27
Joined: Wed Jun 06, 2018 5:58 pm
Location: Hamburg, Germany

Re: LuxCore doesn't delete Materials

Post by Burk » Sun Jun 17, 2018 3:50 pm

Thank you B.Y.O.B. for the hint with the orphan data view. With that I was able to clarify my problem:

I had appended an object multiple time accidentally. After deleting the unnecessary objects the respective materials where not deleted by save-close-open then file. It needs a second save-close-open to delete the materials because the first save-close-open cycle only deletes the objects. At that moment the materials had an owner: the deleted objects. After the second save-close-open the unnecessary materials where deleted.

User avatar
B.Y.O.B.
Developer
Posts: 1728
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCore doesn't delete Materials

Post by B.Y.O.B. » Sun Jun 17, 2018 3:55 pm

Ok, so it's not a bug in the addon, this is just normal Blender behaviour.
Support LuxCoreRender project with salts and bounties

Post Reply