Light

Use this forum for general user support and related questions.
Mark Oh
Posts: 20
Joined: Sun Jun 10, 2018 7:33 pm

Light

Post by Mark Oh » Fri Jun 15, 2018 9:17 pm

Hello

What is the reason that the light area and point do not want to shine at the same time.

Mark Oh
Posts: 20
Joined: Sun Jun 10, 2018 7:33 pm

Re: Light

Post by Mark Oh » Fri Jun 15, 2018 9:36 pm

Thank you I found in the wiki and turned off the automatic tone light. Tomorrow I will have a question about bump and normalmap.

User avatar
B.Y.O.B.
Developer
Posts: 1206
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Light

Post by B.Y.O.B. » Fri Jun 15, 2018 9:37 pm

More info please.
Show a render, your settings, and maybe upload a testscene that shows the problem.
Support LuxCoreRender project with salts and bounties

Mark Oh
Posts: 20
Joined: Sun Jun 10, 2018 7:33 pm

Re: Light

Post by Mark Oh » Sat Jun 16, 2018 8:27 am

Hello

After entering normal map or nod normal map - no change in structure.
https://drive.google.com/file/d/13P38bK ... sp=sharing
https://drive.google.com/file/d/1Yvj7nA ... sp=sharing

User avatar
B.Y.O.B.
Developer
Posts: 1206
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Light

Post by B.Y.O.B. » Sat Jun 16, 2018 8:41 am

You have to enable the "Normalmap" checkbox on the imagemap node with the normalmap (bottom left).

I would recommend to delete the two disconnected nodes because the normalmap node is only needed in very very rare cases and for advanced users.
The "Normalmap" checkbox on the imagemap node is a shortcut.
These two node setups are equivalent:
Attachments
scrn_2018-06-16_10-40-34.png
Support LuxCoreRender project with salts and bounties

Mark Oh
Posts: 20
Joined: Sun Jun 10, 2018 7:33 pm

Re: Light

Post by Mark Oh » Sat Jun 16, 2018 8:56 am

I did it - I do not see any difference
Attachments
skr2.png

User avatar
B.Y.O.B.
Developer
Posts: 1206
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Light

Post by B.Y.O.B. » Sat Jun 16, 2018 9:23 am

Normalmaps should always use gamma 1.0 (this is another thing that the "Normalmap" checkbox does for you automatically).
You should also leave the imagemap brightness at 1.

However this probably does not fix your problem.
Can you upload the scene?
Please pack all textures with File -> External Data -> Pack all into .blend
Support LuxCoreRender project with salts and bounties

Mark Oh
Posts: 20
Joined: Sun Jun 10, 2018 7:33 pm

Re: Light

Post by Mark Oh » Sat Jun 16, 2018 12:09 pm


User avatar
B.Y.O.B.
Developer
Posts: 1206
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Light

Post by B.Y.O.B. » Sat Jun 16, 2018 12:53 pm

You forgot to pack the textures.
At least the normalmap texture is not packed (some others are).
Support LuxCoreRender project with salts and bounties

Mark Oh
Posts: 20
Joined: Sun Jun 10, 2018 7:33 pm

Re: Light

Post by Mark Oh » Sat Jun 16, 2018 2:18 pm

Ok, because there is no need in cycles and I never did it.

Post Reply