LuxBlend 2.1 alpha 1 - can't enable addon

Use this forum for general user support and related questions.
Post Reply
lighting_freak
Posts: 72
Joined: Thu Jan 18, 2018 6:02 pm

LuxBlend 2.1 alpha 1 - can't enable addon

Post by lighting_freak » Wed Jun 13, 2018 2:50 pm

Hello,

I've tried to update to LucBlend 2.1 alpha 1.
Tested the Blender internal update procedure without any success.
Tested also to download and install (copy) from github the OCL and non-OCL version.
Also the required redistributables are installed as described in the related thread.

The error message in all cases is that:

Code: Select all

C:\Users\jantschek>C:\Users\jantschek\Desktop\blender.lnk
AL lib: (EE) ALCmmdevPlayback_resetProxy: Audio client returned buffer_len < per
iod*2; expect break up
found bundled python: C:\Program Files\Blender Foundation\Blender\2.79\python
Traceback (most recent call last):
  File "C:\Program Files\Blender Foundation\Blender\2.79\scripts\modules\addon_u
tils.py", line 331, in enable
    mod = __import__(module_name)
  File "C:\Users\jantschek\AppData\Roaming\Blender Foundation\Blender\2.79\scrip
ts\addons\BlendLuxCore\__init__.py", line 13, in <module>
    from .bin import pyluxcore
ImportError: DLL load failed: Das angegebene Modul wurde nicht gefunden.
I hope you could help me.
Thank you.

BR
OS - Windows 7 X64
CPU - Intel CORE i7
GPU1 - Variants of notebook card from nVidia
GPU2 - Variants of notebook onboard card from Intel
Lux - Latest possible relaease

sarmath
Posts: 20
Joined: Wed Feb 07, 2018 1:22 pm

Re: LuxBlend 2.1 alpha 1 - can't enable addon

Post by sarmath » Wed Jun 13, 2018 3:23 pm

Check this forum thread...i had the same problem....

viewtopic.php?f=4&t=404

Regards
Windows 10 i7 5820k GTX 1070ti 16 GB RAM

lighting_freak
Posts: 72
Joined: Thu Jan 18, 2018 6:02 pm

Re: LuxBlend 2.1 alpha 1 - can't enable addon

Post by lighting_freak » Wed Jun 13, 2018 8:57 pm

Hi,

I read that thread and I've installed the redistributables.
Also the required redistributables are installed as described in the related thread.
My issue seems to be somehow different.

BR
OS - Windows 7 X64
CPU - Intel CORE i7
GPU1 - Variants of notebook card from nVidia
GPU2 - Variants of notebook onboard card from Intel
Lux - Latest possible relaease

lighting_freak
Posts: 72
Joined: Thu Jan 18, 2018 6:02 pm

Re: LuxBlend 2.1 alpha 1 - can't enable addon

Post by lighting_freak » Tue Jun 19, 2018 4:52 pm

Hi,

I'm using the machine that shows this issue in remote desktop mode only.
Might that be somehow the root cause of this issue?

BR
OS - Windows 7 X64
CPU - Intel CORE i7
GPU1 - Variants of notebook card from nVidia
GPU2 - Variants of notebook onboard card from Intel
Lux - Latest possible relaease

User avatar
Dade
Developer
Posts: 1187
Joined: Mon Dec 04, 2017 8:36 pm

Re: LuxBlend 2.1 alpha 1 - can't enable addon

Post by Dade » Tue Jun 19, 2018 7:56 pm

lighting_freak wrote:
Tue Jun 19, 2018 4:52 pm
I'm using the machine that shows this issue in remote desktop mode only.
Might that be somehow the root cause of this issue?
OpenCL/OpenGL may have troubles working with remote desktop, does LuxMark work with remote desktop ? Have you tried to use the no-opencl version of BlendLuxCore ?
Support LuxCoreRender project with salts and bounties

lighting_freak
Posts: 72
Joined: Thu Jan 18, 2018 6:02 pm

Re: LuxBlend 2.1 alpha 1 - can't enable addon

Post by lighting_freak » Wed Jun 20, 2018 9:57 am

Hi,

Yes, I've tried the non-OCL version as well, without any success.
Tested also to download and install (copy) from github the OCL and non-OCL version.
Could you tell me a source of LuxMark please?

I would like to contiune testing as suggested.

Thank you.

BR
OS - Windows 7 X64
CPU - Intel CORE i7
GPU1 - Variants of notebook card from nVidia
GPU2 - Variants of notebook onboard card from Intel
Lux - Latest possible relaease

User avatar
Dade
Developer
Posts: 1187
Joined: Mon Dec 04, 2017 8:36 pm

Re: LuxBlend 2.1 alpha 1 - can't enable addon

Post by Dade » Wed Jun 20, 2018 10:31 am

lighting_freak wrote:
Wed Jun 20, 2018 9:57 am
Yes, I've tried the non-OCL version as well, without any success.
This seems to suggest that the problem is not related to OpenCL. Are you using some Blender international setting (like international fonts or any not US/Western related setting) ?
lighting_freak wrote:
Wed Jun 20, 2018 9:57 am
Could you tell me a source of LuxMark please?
http://wiki.luxcorerender.org/LuxMark#Binaries
Support LuxCoreRender project with salts and bounties

frank_yifei
Posts: 6
Joined: Fri Mar 09, 2018 1:46 pm

Re: LuxBlend 2.1 alpha 1 - can't enable addon

Post by frank_yifei » Sat Jun 30, 2018 12:45 pm

Check if you have microsoft visual c++ 2015 redistributables. it is required by python I think

FiatLux
Posts: 21
Joined: Sat Apr 21, 2018 8:41 pm

Re: LuxBlend 2.1 alpha 1 - can't enable addon

Post by FiatLux » Sat Jun 30, 2018 3:23 pm

U sure you've installed this?
Dade wrote:
Fri Jun 29, 2018 4:16 pm
NOTE: due to a bug (https://github.com/embree/embree/issues/195) in Embree v3.2.0, you need to install also the Intel C++ redistribuibile (https://software.intel.com/sites/defaul ... .3.210.zip) on Windows

Post Reply