Big Sur 11.3

Use this forum for general user support and related questions.
Forum rules
Please upload a testscene that allows developers to reproduce the problem, and attach some images.
Post Reply
Turbopump
Posts: 2
Joined: Tue Apr 27, 2021 6:16 pm

Big Sur 11.3

Post by Turbopump » Tue Apr 27, 2021 6:22 pm

Hello!
I am not an expert — been using Blender for less than two months — yet I never had problems using the luxcore blender plugin and get satisfactory results (it means that developers made it stupid proof!).

I’ve been using recently Blender 2.92 on my M1 Mac with Big Sur.

A few minutes ago I upgraded my Mac to Big Sur 11.3 and the luxcore plug-in stopped working, returning an OpenGL error.

My fault? Apple’s fault? Luxcore’s fault?

Thanks

Marco

Turbopump
Posts: 2
Joined: Tue Apr 27, 2021 6:16 pm

Re: Big Sur 11.3

Post by Turbopump » Tue Apr 27, 2021 11:26 pm

PS whatever the scene (even just a cube), after the upgrade to Big Sur I get:
Erro: | OpenCL driver API error (code: -30, file:/User/runner/work/1/s/src/luxrays/utils/ocl.cpp, line: 371): CL_INVALID_VALUE

right on the viewport (I could not copy and paste the error line, I had to type it).

esox_13
Posts: 1
Joined: Fri May 28, 2021 10:01 pm

Re: Big Sur 11.3

Post by esox_13 » Wed Jun 02, 2021 4:57 pm

I have the same issue after upgrading to 11.4

User avatar
TAO
Developer
Posts: 673
Joined: Sun Mar 24, 2019 4:49 pm
Location: France
Contact:

Re: Big Sur 11.3

Post by TAO » Wed Jun 02, 2021 5:30 pm

I think that because apple drops support for OpenCL and Cuda and replaced it with the Metal API.
Omid Ghotbi (TAO)
Latest build Download link👇👇
https://github.com/LuxCoreRender/MaxToLux/releases
Last update information
https://forums.luxcorerender.org/viewto ... 590#p30154

Post Reply