PyLuxCore Tool Error ( v2.4, all scenes)

Use this forum for general user support and related questions.
gecko
Posts: 31
Joined: Mon Jan 01, 2018 11:10 pm

PyLuxCore Tool Error ( v2.4, all scenes)

Post by gecko » Fri Aug 28, 2020 5:23 pm

Hoping I've just configured something poorly, but I just updated from LuxCoreRender 2.3 to 2.4 and completed my first scene in 2.4. It renders fine inside Blender (2.83), but when I exported it to do a full res network render the scene won't load properly in PyLuxCoreTool. I confirmed the same behavior with the default scene (ok, it's my slightly modified default scene, see below). Problem occurs on both a local node as well as network nodes in PyLuxCoreTool.

Here's the Node error:

Code: Select all

...
[Thread-5][2020-08-28 12:51:35,587] [SDL][57438.093] Texture definition: 2937060048344Color
[Thread-5][2020-08-28 12:51:35,587] [SDL][57438.093] Volume definition: 2933295757544
[Thread-5][2020-08-28 12:51:35,588] bad lexical cast: source type value could not be interpreted as target
Traceback (most recent call last):
  File "C:\Users\xxxx\AppData\Local\Temp\_MEI230882\pyluxcoretools.zip\pyluxcoretools\renderfarm\renderfarmnode.py", line 168, in __HandleConnection
    config = pyluxcore.RenderConfig(renderConfigFile)
RuntimeError: bad lexical cast: source type value could not be interpreted as target
[Thread-5][2020-08-28 12:51:35,645] Connection done: ('192.168.200.46', 61519)
And here's the Console error:

Code: Select all

[RenderFarmNodeThread-192.168.200.194:18018][2020-08-28 12:51:50,645] Sending seed: 5
[RenderFarmNodeThread-192.168.200.194:18018][2020-08-28 12:51:50,646] Waiting for node rendering start
[RenderFarmNodeThread-192.168.200.218:18018][2020-08-28 12:51:56,924] Unable to receive a line
Traceback (most recent call last):
  File "C:\Users\xxxx\AppData\Local\Temp\_MEI189762\pyluxcoretools.zip\pyluxcoretools\renderfarm\renderfarmjobsingleimage.py", line 423, in NodeThread
    result = socketutils.RecvLine(nodeSocket)
  File "C:\Users\xxxx\AppData\Local\Temp\_MEI189762\pyluxcoretools.zip\pyluxcoretools\utils\socket.py", line 44, in RecvLine
    raise RuntimeError("Unable to receive a line")
RuntimeError: Unable to receive a line
[RenderFarmNodeThread-192.168.200.218:18018][2020-08-28 12:51:56,928] Node thread done
Any ideas? I'm running a Win10 build in all cases. "Default" scene details are:
- UV image-mapped glossy texture on default cube.
- HDRI world light instead of a lamp to light the scene.
- Transparent default air volume
- BiDir engine with Metropolis sampler
- Camera tonemapping set to Camera Settings
- 16bit 4k image output size

User avatar
Dade
Developer
Posts: 4717
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: PyLuxCore Tool Error ( v2.4, all scenes)

Post by Dade » Fri Aug 28, 2020 6:18 pm

gecko wrote:
Fri Aug 28, 2020 5:23 pm
Any ideas?
It is a problem with localization output (i.e. for instance it is printing "." as ",") in your exported scene (https://github.com/LuxCoreRender/LuxCore/issues/390). I assume you are using a no-US locale. As workaround, just export the scene in binary format instead of text format.
Support LuxCoreRender project with salts and bounties

gecko
Posts: 31
Joined: Mon Jan 01, 2018 11:10 pm

Re: PyLuxCore Tool Error ( v2.4, all scenes)

Post by gecko » Fri Aug 28, 2020 7:40 pm

Hmm, localization does not appear to be the issue. First, I'm US-based and had US-English selected in Blender. Second, I was already exporting the binary (I've never managed to get text export to work). But just to make sure, I deleted all of the exported files, changed my Blender preferences to "Automatic" instead of English, and tried again with a clean binary export. I'm still getting the same error.

User avatar
Dade
Developer
Posts: 4717
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: PyLuxCore Tool Error ( v2.4, all scenes)

Post by Dade » Fri Aug 28, 2020 9:10 pm

gecko wrote:
Fri Aug 28, 2020 7:40 pm
Hmm, localization does not appear to be the issue. First, I'm US-based and had US-English selected in Blender. Second, I was already exporting the binary (I've never managed to get text export to work). But just to make sure, I deleted all of the exported files, changed my Blender preferences to "Automatic" instead of English, and tried again with a clean binary export. I'm still getting the same error.
Try to install a v2.5 automatic build (viewtopic.php?f=9&t=736) and post both the .blend file and the .bcf file so I can check what is going on.
Support LuxCoreRender project with salts and bounties

gecko
Posts: 31
Joined: Mon Jan 01, 2018 11:10 pm

Re: PyLuxCore Tool Error ( v2.4, all scenes)

Post by gecko » Sat Aug 29, 2020 12:49 am

Dade wrote:
Fri Aug 28, 2020 9:10 pm
Try to install a v2.5 automatic build (viewtopic.php?f=9&t=736) and post both the .blend file and the .bcf file so I can check what is going on.
Thanks for looking in to this. See files below (I did confirm exact same issue in the 2.5 automatic build when trying to load in pyluxcoretool).

.blend file: https://drive.google.com/file/d/1-BjdNT ... sp=sharing

.bcf file: https://drive.google.com/file/d/1kFrC0U ... sp=sharing

By the way, just out of curiosity... why is the bcf file for a simple cube so huge? I recently realized that half the time I spend getting an external render started is read/write time for the bcf (I keep all my project files on NAS, so the bottleneck becomes quite noticeable with my typical 2-3GB files!).

gecko
Posts: 31
Joined: Mon Jan 01, 2018 11:10 pm

Re: PyLuxCore Tool Error ( v2.4, all scenes)

Post by gecko » Wed Sep 02, 2020 2:12 am

Any other ideas here? It's killing me trying to render a production scene in Blender internal :/

Is it worth trying to port the scene back to Blender 2.82 and LuxCoreRender 2.3 (or trying to use LuxCore 2.3 in Blender 2.83?)? Sounds like it's asking for trouble, but I don't know what else to do if I can't even export my scene to render.

User avatar
Dade
Developer
Posts: 4717
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: PyLuxCore Tool Error ( v2.4, all scenes)

Post by Dade » Wed Sep 02, 2020 12:02 pm

You didn't packed any of the required images in your .blend file (you have many .png and a HDR referenced by the file):

err.jpg

I assume the .bcf file is so large because it includes them while your .blend file doesn't.

Can you use just the default scene ? Is your default scene broken ?
Support LuxCoreRender project with salts and bounties

gecko
Posts: 31
Joined: Mon Jan 01, 2018 11:10 pm

Re: PyLuxCore Tool Error ( v2.4, all scenes)

Post by gecko » Wed Sep 02, 2020 1:59 pm

I overwrite the Blender default scene so it's already set up for my normal workflow when I start a new project... but missing image files shouldn't prevent the bcf from loading and trying to render.

Anyway, here I've attempted to recreate the actual default scene as close as I can get it by memory. At least shouldn't be any missing dependencies. And indeed the .bcf is much smaller - I didn't realize the images were being embedded directly, thanks for the explanation.

.blend: https://drive.google.com/file/d/1hqYqQP ... sp=sharing

.bcf: https://drive.google.com/file/d/1kFrC0U ... sp=sharing

gecko
Posts: 31
Joined: Mon Jan 01, 2018 11:10 pm

Re: PyLuxCore Tool Error ( v2.4, all scenes)

Post by gecko » Mon Sep 07, 2020 1:11 am

Sorry to bump again, but this is really a mess for me not being able to export a scene for rendering. I've now tried on 3 different computers, 2 of these a fresh install of Blender 2.83 and BlendLuxCore 2.4 (or 2.5). Always on Win10. I can't load the resulting BCF in pyluxcoretool in any of these scenarios (export and load on same computer, export on one computer and load on another, etc). In all cases I can render inside Blender just fine.

I'd be happy to make a bug report if this is actually a bug (just need someone to confirm that I'm not crazy). Or if it's a Blender issue I'd be happy just to have a workaround.

User avatar
Dade
Developer
Posts: 4717
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: PyLuxCore Tool Error ( v2.4, all scenes)

Post by Dade » Mon Sep 07, 2020 11:25 am

Your .blend works fine here, where your PyLuxCore Tool come from ?
Support LuxCoreRender project with salts and bounties

Post Reply