Viewport render crash on GPU Cuda

Use this forum for general user support and related questions.
User avatar
Sharlybg
Donor
Posts: 2387
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Viewport render crash on GPU Cuda

Post by Sharlybg » Sat Sep 05, 2020 5:40 pm

Dade wrote:
Sat Sep 05, 2020 3:13 pm
Try to clear your kernel cache (and compile for about 5mins), it should be a directory like: C:\Users<user name>\AppData\Local\Temp\luxcorerender.org
I've a lot of instabillity with 2.5. I'm on CUDA optix . viewport crash a lot when switching from render preview to solid or wireframe. now i've a scen crashing automatically on GPU while rendering fine on CPU. I had cleared up the kernel cahe and redo the compiling phase but still the same issue.

here is the file :

https://we.tl/t-8RLNzPXbmb
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
Dade
Developer
Posts: 4734
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Viewport render crash on GPU Cuda

Post by Dade » Sun Sep 06, 2020 10:59 am

Sharlybg wrote:
Sat Sep 05, 2020 5:40 pm
Dade wrote:
Sat Sep 05, 2020 3:13 pm
Try to clear your kernel cache (and compile for about 5mins), it should be a directory like: C:\Users<user name>\AppData\Local\Temp\luxcorerender.org
I've a lot of instabillity with 2.5. I'm on CUDA optix . viewport crash a lot when switching from render preview to solid or wireframe. now i've a scen crashing automatically on GPU while rendering fine on CPU. I had cleared up the kernel cahe and redo the compiling phase but still the same issue.

here is the file :

https://we.tl/t-8RLNzPXbmb
Does it happen only the first time after you have delete the cached kernels (or installed a new version) ? I have the feeling it is related to long compilation time and BlendLuxCore applying the denoiser (before compilation time is over).
Support LuxCoreRender project with salts and bounties

User avatar
Sharlybg
Donor
Posts: 2387
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Viewport render crash on GPU Cuda

Post by Sharlybg » Sun Sep 06, 2020 11:37 am

No it happen as soon as i started to use 2.5 on multiple scene but mostly in viewport. So i tried your tip about cache suppression.this time this file wann't work on GPu. Strangelly for this scene it is almost the first time i added glossy coating on multiple shader like carpaint.
Want to try to check that.
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
Sharlybg
Donor
Posts: 2387
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Viewport render crash on GPU Cuda

Post by Sharlybg » Sun Sep 06, 2020 12:15 pm

Sharlybg wrote:
Sun Sep 06, 2020 11:37 am
No it happen as soon as i started to use 2.5 on multiple scene but mostly in viewport. So i tried your tip about cache suppression.this time this file wann't work on GPu. Strangelly for this scene it is almost the first time i added glossy coating on multiple shader like carpaint.
Want to try to check that.
No way .... tried everything still crash :mrgreen:
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
Sharlybg
Donor
Posts: 2387
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Viewport render crash on GPU Cuda

Post by Sharlybg » Sun Sep 06, 2020 12:45 pm

Does it happen only the first time after you have delete the cached kernels (or installed a new version) ? I have the feeling it is related to long compilation time and BlendLuxCore applying the denoiser (before compilation time is over).
How it is on your side , it crash ? :?:
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
B.Y.O.B.
Developer
Posts: 3811
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Viewport render crash on GPU Cuda

Post by B.Y.O.B. » Sun Sep 06, 2020 1:01 pm

I encountered dozens of crashes so far with v2.5 when ending a viewport render, both on Linux and Windows. I suspect they are related to the OptiX denoiser, without it there are almost no crashes, but I can't reproduce them reliably.

User avatar
Dade
Developer
Posts: 4734
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Viewport render crash on GPU Cuda

Post by Dade » Mon Sep 07, 2020 11:52 am

I can 100% reproduce the problem in any scene by:

1) enable view port rendering
2) resize the view port
3) disable view port rendering
4) crash
Support LuxCoreRender project with salts and bounties

User avatar
Dade
Developer
Posts: 4734
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Viewport render crash on GPU Cuda

Post by Dade » Mon Sep 07, 2020 12:11 pm

@B.Y.O.B, Blender/BlendLuxCore is doing something very strange:

- when I resize the view port, the current LuxCore RenderSession is stopped but not deleted.
- a new session is created after the view port resize and the new rendering is started;
- when you switch back to wire frame view port rendering, all pending RenderSession(s) will be deleted (and a crash will occur).

In theory this may even work but: every pending RenderSession will keep a full copy of the scene in ram. You can just keep resizing the view port and the memory usage will increase and increase :!:
Support LuxCoreRender project with salts and bounties

User avatar
Dade
Developer
Posts: 4734
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Viewport render crash on GPU Cuda

Post by Dade » Mon Sep 07, 2020 12:28 pm

Dade wrote:
Mon Sep 07, 2020 11:52 am
I can 100% reproduce the problem in any scene by:

1) enable view port rendering
2) resize the view port
3) disable view port rendering
4) crash
The crash doesn't happen if you disable Optix RTX and denoiser (i.e. in intersection and film devices) but the huge waste of memory is still there.

This looks like a Optix bug caused by the huge amount of contexts allocated and due to the RenderSession-not-delete problem.
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Posts: 3811
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Viewport render crash on GPU Cuda

Post by B.Y.O.B. » Mon Sep 07, 2020 12:35 pm

I'll need to investigate this resize behaviour.
However, I rarely resize the viewport, so I'm fairly sure that the crashes I encountered so far were not related to resizing. Still, the same underlying problem with OptiX context might be at work there.

Post Reply