GPU rendering slower than CPU rendering

Use this forum for general user support and related questions.
Forum rules
Please upload a testscene that allows developers to reproduce the problem, and attach some images.
User avatar
TAO
Developer
Posts: 163
Joined: Sun Mar 24, 2019 4:49 pm
Location: France
Contact:

Re: v2.3 Vs v2.4 performance

Post by TAO » Wed May 13, 2020 3:13 pm

My Ryzen has no OCL driver and will only work natively, so I cannot test the original configuration of the file.
About OCL on AMD, I used this library once and was able to use OpenCL on AMD Ryzen, not sure if it works with your machine but you can give it a chance. http://portablecl.org/
Omid Ghotbi (TAO)
Download link to last MaxToLux build.๐Ÿ‘‡๐Ÿ‘‡
viewtopic.php?f=5&t=1010&start=160#p22925

epilectrolytics
Donor
Posts: 708
Joined: Thu Oct 04, 2018 6:06 am

Re: v2.3 Vs v2.4 performance

Post by epilectrolytics » Wed May 13, 2020 3:32 pm

TAO wrote: โ†‘
Wed May 13, 2020 3:13 pm
About OCL on AMD, I used this library once and was able to use OpenCL on AMD Ryzen, not sure if it works with your machine but you can give it a chance. http://portablecl.org/
Thanks for the link, but I'm no developer and don't know how to install or build libraries :)
In general CPU native rendering should be faster and using OCL on CPUs should be avoided, or so it is told somewhere in the docs, don't know where right now.

Back to your GPU problem, it is not with Lux and not in the scene, then it might be something related to your system.
Does the GPU work as expected in Cycles and Luxmark?

User avatar
TAO
Developer
Posts: 163
Joined: Sun Mar 24, 2019 4:49 pm
Location: France
Contact:

Re: v2.3 Vs v2.4 performance

Post by TAO » Wed May 13, 2020 4:37 pm

I think thats gonna answer your question.
Annotation 2020-05-13 204952.jpg
Omid Ghotbi (TAO)
Download link to last MaxToLux build.๐Ÿ‘‡๐Ÿ‘‡
viewtopic.php?f=5&t=1010&start=160#p22925

epilectrolytics
Donor
Posts: 708
Joined: Thu Oct 04, 2018 6:06 am

Re: v2.3 Vs v2.4 performance

Post by epilectrolytics » Wed May 13, 2020 6:15 pm

This looks just alright, now that it is based on LuxCore 2.2 makes it very strange that you cannot achieve similar GPU performance with the very same v2.2 LuxCoreUI and your simple scene :?
Sorry to be of no help, but this problem needs smarter heads than mine to solve :oops:

acasta69
Developer
Posts: 361
Joined: Tue Jan 09, 2018 3:45 pm

Re: v2.3 Vs v2.4 performance

Post by acasta69 » Wed May 13, 2020 9:03 pm

I find the same very strange behaviour with TAO's scene, i.e. GPU is very slow, with LuxCoreUI 2.2 (but 2.4 is ok).
This line in the config file seems to be the source of the problem, at least on my laptop:

Code: Select all

opencl.gpu.workgroup.size = "0"
If I comment it, then GPU speed is again very high.
Support LuxCoreRender project with salts and bounties

Windows 10 64 bits, i7-4770 3.4 GHz, RAM 16 GB, GTX 970 4GB v445.87

User avatar
Dade
Developer
Posts: 4817
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: v2.3 Vs v2.4 performance

Post by Dade » Wed May 13, 2020 10:20 pm

acasta69 wrote: โ†‘
Wed May 13, 2020 9:03 pm
I find the same very strange behaviour with TAO's scene, i.e. GPU is very slow, with LuxCoreUI 2.2 (but 2.4 is ok).
This line in the config file seems to be the source of the problem, at least on my laptop:

Code: Select all

opencl.gpu.workgroup.size = "0"
If I comment it, then GPU speed is again very high.
"0" means use the work group size suggested by the driver (and often the drivers can be very wrong). The value should be 32 for NVIDIA and new AMD, 64 for some old AMD GPU.
Support LuxCoreRender project with salts and bounties

User avatar
TAO
Developer
Posts: 163
Joined: Sun Mar 24, 2019 4:49 pm
Location: France
Contact:

Re: GPU rendering slower than CPU rendering

Post by TAO » Wed May 13, 2020 11:35 pm

You are great Dade, Not Only that fixes the issue but fixing this also fixes 3dsmax behavior too, and now it's much faster.
Thank you all.
Is there any suggestion for CPU workgroup size ?
Annotation 2020-05-14 040410.jpeg
Omid Ghotbi (TAO)
Download link to last MaxToLux build.๐Ÿ‘‡๐Ÿ‘‡
viewtopic.php?f=5&t=1010&start=160#p22925

User avatar
B.Y.O.B.
Developer
Posts: 3872
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: GPU rendering slower than CPU rendering

Post by B.Y.O.B. » Thu May 14, 2020 12:10 am

Last time I checked, OpenCL CPU device was much slower than native C++, so I wouldn't use it at all (set opencl.cpu.use = 0).

User avatar
TAO
Developer
Posts: 163
Joined: Sun Mar 24, 2019 4:49 pm
Location: France
Contact:

Re: GPU rendering slower than CPU rendering

Post by TAO » Thu May 14, 2020 12:24 am

I used opencl.cpu.use = "0" but it's not work exept i add 0 for cpu to opencl.devices.select = "10".
Anyway, it's work much better now.
Thank you.
Omid Ghotbi (TAO)
Download link to last MaxToLux build.๐Ÿ‘‡๐Ÿ‘‡
viewtopic.php?f=5&t=1010&start=160#p22925

Post Reply