Installation problem

Use this forum for general user support and related questions.
Racleborg
Posts: 338
Joined: Sat Apr 07, 2018 10:31 am

Installation problem

Post by Racleborg » Sat Apr 07, 2018 10:36 am

Hi (So excited about this new version. Big thanks!)

I'm getting an error message when trying to activate in Blender 2.79b (attached)

Any help please.

Thanks again
Attachments
error.PNG

User avatar
Dade
Developer
Developer
Posts: 2493
Joined: Mon Dec 04, 2017 8:36 pm

Re: Installation problem

Post by Dade » Sat Apr 07, 2018 10:42 am

Racleborg wrote:
Sat Apr 07, 2018 10:36 am
I'm getting an error message when trying to activate in Blender 2.79b (attached)

Any help please.
Can you check if a "pyluxcore.pyd" file exists in your "Blender/2.79/scripts/addons/BlendLuxCore-master/bin" directory ?
Support LuxCoreRender project with salts and bounties

Racleborg
Posts: 338
Joined: Sat Apr 07, 2018 10:31 am

Re: Installation problem

Post by Racleborg » Sat Apr 07, 2018 10:49 am

Hi Dade

Thanks for responding

No, it's not there.

User avatar
Dade
Developer
Developer
Posts: 2493
Joined: Mon Dec 04, 2017 8:36 pm

Re: Installation problem

Post by Dade » Sat Apr 07, 2018 10:54 am

Racleborg wrote:
Sat Apr 07, 2018 10:49 am
No, it's not there.
Something has gone wrong during the installation. Did you installed .zip as described here (https://wiki.luxcorerender.org/BlendLux ... stallation) ?

The "-master" suffix in the name of the "BlendLuxCore-master" directory is a bit strange, are you trying to install BlendLuxCore from GitHub sources ?

Anyway, deleting the Blender/2.79/scripts/addons/BlendLuxCore-master" directory and following the https://wiki.luxcorerender.org/BlendLux ... stallation should be enough to solve your problem.
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Developer
Posts: 2651
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Installation problem

Post by B.Y.O.B. » Sat Apr 07, 2018 11:05 am

You can't simply download from github. You need to download a release from the release section or go to the download page on luxcorerender.org and get it from there.
Support LuxCoreRender project with salts and bounties

Racleborg
Posts: 338
Joined: Sat Apr 07, 2018 10:31 am

Re: Installation problem

Post by Racleborg » Sat Apr 07, 2018 11:09 am

Hi Dade

Yes, tried to install from github. Whilst doing it I uninstalled the original programme and probably screwed something up in the process!

I'll use your suggestion (in a few minutes) and report back.

Thanks

Racleborg
Posts: 338
Joined: Sat Apr 07, 2018 10:31 am

Re: Installation problem

Post by Racleborg » Sat Apr 07, 2018 11:33 am

That's it, downloading the beta from the proper download page instead of from Github

Thanks for helping me out.

Have a nice weekend. I know what I'll be doing with mine......!

igall
Posts: 2
Joined: Sun Apr 15, 2018 1:01 pm

Re: Installation problem

Post by igall » Thu Apr 26, 2018 2:28 pm

Hi,
On the same issue:
I have installed Blender 2.79 and BlendLuxCore on a new PC with Win10.
There was no problem to activate LuxCore after install.
But when I try to load a Blender scene and then activate LuxCore, I get the following error msg:
Image
pyluxcore.pyd seems on its place, in:
C:\Users\igall\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\BlendLuxCore\bin
What could go wrong?
Many thanks,
Igal

User avatar
Dade
Developer
Developer
Posts: 2493
Joined: Mon Dec 04, 2017 8:36 pm

Re: Installation problem

Post by Dade » Thu Apr 26, 2018 2:41 pm

igall wrote:
Thu Apr 26, 2018 2:28 pm
On the same issue:
I have installed Blender 2.79 and BlendLuxCore on a new PC with Win10.
There was no problem to activate LuxCore after install.
But when I try to load a Blender scene and then activate LuxCore, I get the following error msg:
Image
pyluxcore.pyd seems on its place, in:
C:\Users\igall\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\BlendLuxCore\bin
What could go wrong?
If you are using OpenCL version on a PC where OpenCL version is not available or other various related problems: you can find here (https://github.com/LuxCoreRender/BlendL ... issues/138) a long discussion about this problem an the possible causes. You can just follow my suggestions there to debug what is going wrong.
Support LuxCoreRender project with salts and bounties

User avatar
Dez!
Posts: 112
Joined: Sun Apr 08, 2018 1:09 am
Location: Ekaterinburg
Contact:

Re: Installation problem

Post by Dez! » Sat Apr 28, 2018 6:26 am

Error Ubuntu: libOpenCL.so.1

Image

Enter:

Code: Select all

sudo apt update
sudo apt install ocl-icd-opencl-dev
;)
Linux Gnome | Dell Inspiron 7000 | Wacom
http://dezigner.tilda.ws/

Post Reply