Full crash in this scene... and it's nearly empty... what's happening?

Use this forum for general user support and related questions.
Post Reply
juangea
Donor
Posts: 110
Joined: Thu Jan 02, 2020 6:23 pm

Full crash in this scene... and it's nearly empty... what's happening?

Post by juangea » Sun Jan 19, 2020 4:19 pm

Full crash in this scene... and it's nearly empty... what's happening?

The scene it's attached, it comes from a production scene that keeps crashing, and I don't understand the problem, so I cannot render the scene, which is a big problem, I have to deliver the render :)

I cleaned up the scene as much as I could... in fact there is not a single object there, just open the scene, hit F12 and... crash
Attachments
p4_base_luxrender_bug_2.blend
(617.81 KiB) Downloaded 11 times

neo2068
Developer
Posts: 164
Joined: Tue Dec 05, 2017 6:06 pm
Location: Germany

Re: Full crash in this scene... and it's nearly empty... what's happening?

Post by neo2068 » Sun Jan 19, 2020 7:21 pm

The scene crashes because you are using the environment light cache. If you disable it, it renders. I have to check, why the crash happens.
i7 5820K, 32 GB RAM, NVIDIA Geforce GTX 1080 + GTX 780, Windows 10 64bit, Blender 2.81a
Support LuxCoreRender project with salts and bounties

Racleborg
Posts: 600
Joined: Sat Apr 07, 2018 10:31 am
Location: UK

Re: Full crash in this scene... and it's nearly empty... what's happening?

Post by Racleborg » Sun Jan 19, 2020 7:24 pm

If just a default cube with Disney shader is added, then it works okay for me.

neo2068
Developer
Posts: 164
Joined: Tue Dec 05, 2017 6:06 pm
Location: Germany

Re: Full crash in this scene... and it's nearly empty... what's happening?

Post by neo2068 » Sun Jan 19, 2020 7:32 pm

Racleborg wrote:
Sun Jan 19, 2020 7:24 pm
If just a default cube with Disney shader is added, then it works okay for me.
Yes, the problem seems to be that the scene is completly empty and env. light cache is enabled. It tries to build the cache but it is emty. If you look into the console output there is warning.

Code: Select all

[LuxRays][62.781] Total triangle count: 0
[LuxRays][62.781] Empty BVH
[LuxCore][63.703] EnvLightVisibilityCache evaluating best radius
[LuxCore][63.844] EnvLightVisibilityCache best cache radius: 0.15
[LuxCore][63.844] SceneVisibility trace thread count: 12
[LuxCore][64.078] SceneVisibility total entries: 0
[LuxCore][64.078] EnvLightVisibilityCache building cache entries: 0
[LuxCore][64.078] WARNING: EnvLightVisibilityCache has an empty cache
[LuxCore][64.187] [PathOCLRenderEngine] OpenCL task count: 262144
[LuxCore][64.187] [PathOCLBaseRenderEngine] OpenCL max. page memory size: 8363020Kbytes
[LuxCore][64.187] Compile Geometry
[LuxCore][64.203] Scene geometry compilation time: 0ms
[LuxCore][64.203] Compile 1 Textures
[LuxCore][64.219] Textures compilation time: 0ms
[LuxCore][64.219] Compile 1 Materials
[LuxCore][64.219] Material compilation time: 0ms
[LuxCore][64.219] Compile Lights
Error   : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FFB64388300
Module  : F:\Users\Michael\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\BlendLuxCore\bin\pyluxcore.pyd
i7 5820K, 32 GB RAM, NVIDIA Geforce GTX 1080 + GTX 780, Windows 10 64bit, Blender 2.81a
Support LuxCoreRender project with salts and bounties

User avatar
Dade
Developer
Posts: 3948
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Full crash in this scene... and it's nearly empty... what's happening?

Post by Dade » Sun Jan 19, 2020 9:42 pm

This is very empty scene:

Code: Select all

[...]
[LuxRays][62.781] Total triangle count: 0
[...]
Support LuxCoreRender project with salts and bounties

juangea
Donor
Posts: 110
Joined: Thu Jan 02, 2020 6:23 pm

Re: Full crash in this scene... and it's nearly empty... what's happening?

Post by juangea » Sun Jan 19, 2020 9:58 pm

Ok, then that's not the crash I was tracing, because I had that crash with objects in the scene, I'll try to reproduce the crash again with some object and upload again tomorrow, thanks :)

Anyways, this crash should not be happening, right?

What is weird is that the crash only happens under OpenCL, not under CPU.

User avatar
B.Y.O.B.
Developer
Posts: 3387
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Full crash in this scene... and it's nearly empty... what's happening?

Post by B.Y.O.B. » Mon Jan 20, 2020 12:08 am

IMO the automated tests should contain corner case scenes like this empty one, with all caches enabled.

User avatar
lacilaci
Donor
Posts: 1856
Joined: Fri May 04, 2018 5:16 am

Re: Full crash in this scene... and it's nearly empty... what's happening?

Post by lacilaci » Mon Jan 20, 2020 8:40 am

juangea wrote:
Sun Jan 19, 2020 9:58 pm
Ok, then that's not the crash I was tracing, because I had that crash with objects in the scene, I'll try to reproduce the crash again with some object and upload again tomorrow, thanks :)

Anyways, this crash should not be happening, right?

What is weird is that the crash only happens under OpenCL, not under CPU.
By the way, do note, that even if it worked this env. cache can even hurt performance.
In a semi open, or mostly open scene like studio for a product and a hdri, etc...

So only use it in a case where you have opening in a room and need to get environment light in there... I personally don't ever use it cause it's a nest of problems, nothing else... It's basically a corner case when it does what it needs to....

juangea
Donor
Posts: 110
Joined: Thu Jan 02, 2020 6:23 pm

Re: Full crash in this scene... and it's nearly empty... what's happening?

Post by juangea » Mon Jan 20, 2020 9:17 am

Oh yes, the original scene was an interior scene, I see a proper decent speed up with it enabled, but I see also some crashes, so I’ll try to provide crashy blend files with it to nail down the problems :)

Post Reply