Optix error on old GTX card

Use this forum for general user support and related questions.
Forum rules
Please upload a testscene that allows developers to reproduce the problem, and attach some images.
Post Reply
mib2berlin
Posts: 41
Joined: Fri Apr 06, 2018 6:29 pm

Optix error on old GTX card

Post by mib2berlin » Tue Jul 28, 2020 2:27 pm

Hi, I get an Optix error on my GTX 760 card using latest Luxcore 2.5.

Code: Select all

[LuxRays][464.884] Device 2 name: GeForce GTX 760
[LuxRays][464.884] Device 2 type: CUDA_GPU
[LuxRays][464.884] Device 2 compute units: 192
[LuxRays][464.884] Device 2 preferred float vector width: 1
[LuxRays][464.885] Device 2 max allocable memory: 4034MBytes
[LuxRays][464.885] Device 2 max allocable memory block size: 17592186044415MBytes
[LuxRays][464.885] Device 2 has out of core memory support: 1
[LuxRays][464.885] Creating 5 intersection device(s)
[LuxRays][464.885] Allocating intersection device 0: GeForce GTX 760 (Type = CUDA_GPU)
[LuxRays][464.904] [Optix][4][KNOBS] All knobs on default.

[LuxRays][464.904] [Optix][2][ERROR] Error creating RTX context
Traceback (most recent call last):
  File "/home/pepo/buildbot/2.90/scripts/addons/BlendLuxCore/engine/base.py", line 86, in render_final
    final.render(self, depsgraph)
  File "/home/pepo/buildbot/2.90/scripts/addons/BlendLuxCore/engine/final.py", line 48, in render
    _render_layer(engine, depsgraph, statistics, layer)
  File "/home/pepo/buildbot/2.90/scripts/addons/BlendLuxCore/engine/final.py", line 60, in _render_layer
    engine.session = engine.exporter.create_session(depsgraph, engine=engine, view_layer=view_layer)
  File "/home/pepo/buildbot/2.90/scripts/addons/BlendLuxCore/export/__init__.py", line 215, in create_session
    pyluxcore.KernelCacheFill(config_props_copy)
RuntimeError: Optix error (code: 7051, file:/home/vsts/work/1/s/LinuxCompile/LuxCore/src/luxrays/devices/cudadevice.cpp, line: 155): OPTIX_ERROR_INVALID_DEVICE_CONTEXT

ERROR: Optix error (code: 7051, file:/home/vsts/work/1/s/LinuxCompile/LuxCore/src/luxrays/devices/cudadevice.cpp, line: 155): OPTIX_ERROR_INVALID_DEVICE_CONTEXT

Info: Compiling CUDA kernels (just once, takes a few minutes)
Error: Optix error (code: 7051, file:/home/vsts/work/1/s/LinuxCompile/LuxCore/src/luxrays/devices/cudadevice.cpp, line: 155): OPTIX_ERROR_INVALID_DEVICE_CONTEXT
I checked Cuda in LuxBlend.
The card is not supported in Cuda 11 as far as I know.
I think about to buy a new card anyway but want to know if it cant work, then I stay at Luxcore 2.4.

Thanks, mib

User avatar
Dade
Developer
Posts: 4816
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Optix error on old GTX card

Post by Dade » Tue Jul 28, 2020 3:00 pm

mib2berlin wrote:
Tue Jul 28, 2020 2:27 pm
The card is not supported in Cuda 11 as far as I know.
I think about to buy a new card anyway but want to know if it cant work, then I stay at Luxcore 2.4.
Yes, it is not supported by Optix but it will work with CUDA: I just need to add a check to disable Optix if the device is not supported.
Support LuxCoreRender project with salts and bounties

User avatar
Dade
Developer
Posts: 4816
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Optix error on old GTX card

Post by Dade » Tue Jul 28, 2020 3:37 pm

Dade wrote:
Tue Jul 28, 2020 3:00 pm
mib2berlin wrote:
Tue Jul 28, 2020 2:27 pm
The card is not supported in Cuda 11 as far as I know.
I think about to buy a new card anyway but want to know if it cant work, then I stay at Luxcore 2.4.
Yes, it is not supported by Optix but it will work with CUDA: I just need to add a check to disable Optix if the device is not supported.
The next build should work on CUDA devices not supported by Optix.
Support LuxCoreRender project with salts and bounties

mib2berlin
Posts: 41
Joined: Fri Apr 06, 2018 6:29 pm

Re: Optix error on old GTX card

Post by mib2berlin » Tue Jul 28, 2020 4:34 pm

Thank you very much.

Cheers, mib

mib2berlin
Posts: 41
Joined: Fri Apr 06, 2018 6:29 pm

Re: Optix error on old GTX card

Post by mib2berlin » Sat Aug 01, 2020 8:07 pm

Hi @Dade , got some time to test 2.5 again but error again but different to the first one.

Code: Select all

CUDA driver API error CUDA_ERROR_INVALID_PTX (code: 218, file:/home/vsts/work/1/s/LinuxCompile/LuxCore/src/luxrays/utils/cuda.cpp, line: 200):
a PTX JIT compilation failed
Cuda enabled, Optix disabled in user prefs, default scene.
May you can look in to if you find the time.

Cheers, mib

User avatar
Dade
Developer
Posts: 4816
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Optix error on old GTX card

Post by Dade » Sat Aug 01, 2020 8:59 pm

mib2berlin wrote:
Sat Aug 01, 2020 8:07 pm
Hi @Dade , got some time to test 2.5 again but error again but different to the first one.

Code: Select all

CUDA driver API error CUDA_ERROR_INVALID_PTX (code: 218, file:/home/vsts/work/1/s/LinuxCompile/LuxCore/src/luxrays/utils/cuda.cpp, line: 200):
a PTX JIT compilation failed
Cuda enabled, Optix disabled in user prefs, default scene.
May you can look in to if you find the time.
NVRTC (CUDA 10 run time compiler) is included with LuxCore and I guess you are running with a pre-CUDA 10 driver. It can not understand the code (i.e. PTX) compiled by LuxCore.

Just update your GPU driver and you should be fine.

P.S. the other options may be to replace the NVRTC DLLs included in LuxCore with a CUDA version compatible with your driver but it is more complex and it may be required only if your GPU is not supported anymore by NVIDIA.
Support LuxCoreRender project with salts and bounties

mib2berlin
Posts: 41
Joined: Fri Apr 06, 2018 6:29 pm

Re: Optix error on old GTX card

Post by mib2berlin » Sat Aug 01, 2020 9:08 pm

Sorry, forgot to add the driver version, it is 450.57.
The GTX 760 is 7 Years old, I have to buy a new one anyway, Cuda 11 does not support it anymore.

Cheers, mib

Post Reply