LuxCoreRender v2.1 released

News & Announcements regarding releases, features, exporters and project coordination.
User avatar
B.Y.O.B.
Developer
Posts: 1910
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCoreRender v2.1 released

Post by B.Y.O.B. » Sun Jan 13, 2019 1:47 am

Can you post a testscene that shows the problem?
Support LuxCoreRender project with salts and bounties

Stem
Posts: 8
Joined: Mon Mar 05, 2018 11:58 am

Re: LuxCoreRender v2.1 released

Post by Stem » Sun Jan 13, 2019 2:51 am

Hi,
Its a problem with missing materials.
If I import an object and any material zone's have not been given a Luxcore material, then I get the error/problem.
In previous builds, an imported object with missing Luxcore mats would render, and I would be given warnings about missing mats.

Do I need to post a test scene? You could import an object(.obj) and check.

User avatar
B.Y.O.B.
Developer
Posts: 1910
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCoreRender v2.1 released

Post by B.Y.O.B. » Sun Jan 13, 2019 10:28 am

Thanks for the report, I fixed the bug.
I think I'll wait a few days if any more bugs are found and repackage the BlendLuxCore release then (I don't think we need a v2.1.1 for only one bug, I can just move the v2.1 tag).
Support LuxCoreRender project with salts and bounties

Stem
Posts: 8
Joined: Mon Mar 05, 2018 11:58 am

Re: LuxCoreRender v2.1 released

Post by Stem » Sun Jan 13, 2019 12:11 pm

Hi,

Thanks for checking/fixing the bug.

Another issue, but it is unpredictable. When a render is in progress(just after starting), I can get an error showing(which stops the render) of:-
-------------
Report: Error
Writing to ID classes in this context is not allowed: Scene, Scene Datablock, error setting LuxcoreConfigPath.suggested_clamping value
-------------

The error can show, but when restarting the render(with no changes) it will render OK without the error.

Racleborg
Posts: 242
Joined: Sat Apr 07, 2018 10:31 am

Re: LuxCoreRender v2.1 released

Post by Racleborg » Mon Jan 14, 2019 1:07 pm

Writing to ID classes in this context is not allowed: Scene, Scene Datablock, error setting LuxcoreConfigPath.suggested_clamping value
I've seen this happen a couple of times in the past. But when restarting the render the message has gone. I had presumed that, in my case, the error was a user error as opposed a software one.

Post Reply