Viewport render crash on GPU Cuda

Use this forum for general user support and related questions.
sarmath
Posts: 97
Joined: Wed Feb 07, 2018 1:22 pm

Viewport render crash on GPU Cuda

Post by sarmath » Tue Jun 30, 2020 12:10 pm

Hi.

So every time I am switching to viewport render on gpu I have a crash. Blender version 2.83 on Windows 10. Luxcore version 2.4 beta1.

This is console output:

[LuxCore][21.875] Film hardware image pipeline
[LuxCore][21.969] Film hardware device used: GeForce GTX 1070 Ti OpenCLIntersect (Type: OPENCL_GPU)
[LuxCore][21.969] Device OpenCL version: OpenCL 1.2 CUDA
[LuxRays][21.969] [Device GeForce GTX 1070 Ti OpenCLIntersect] IMAGEPIPELINE buffer size: 11092Kbytes
[LuxRays][21.969] [Device GeForce GTX 1070 Ti OpenCLIntersect] Merge buffer size: 14790Kbytes
[LuxRays][21.969] [MergeSampleBuffersOCL] Compiler options: -D LUXRAYS_OPENCL_KERNEL -D SLG_OPENCL_KERNEL -D LUXRAYS_OPENCL_DEVICE -D LUXRAYS_OS_WINDOWS
[LuxRays][21.969] [MergeSampleBuffersOCL] Compiling kernels
[LuxRays][21.969] [MergeSampleBuffersOCL] Program cached
[LuxCore][21.969] [MergeSampleBuffersOCL] Compiling Film_MergeBufferInitialize Kernel
[LuxCore][21.969] [MergeSampleBuffersOCL] Compiling Film_MergeRADIANCE_PER_PIXEL_NORMALIZED Kernel
[LuxCore][21.969] [MergeSampleBuffersOCL] Compiling Film_MergeRADIANCE_PER_SCREEN_NORMALIZED Kernel
[LuxCore][21.969] [MergeSampleBuffersOCL] Compiling Film_MergeBufferFinalize Kernel
[LuxCore][21.969] [MergeSampleBuffersOCL] Kernels compilation time: 0ms
[LuxRays][22.015] [LinearToneMap] Compiler options: -D LUXRAYS_OPENCL_KERNEL -D SLG_OPENCL_KERNEL -D LUXRAYS_OPENCL_DEVICE -D LUXRAYS_OS_WINDOWS
[LuxRays][22.015] [LinearToneMap] Compiling kernels
[LuxRays][22.015] [LinearToneMap] Program cached
[LuxCore][22.015] [AutoLinearToneMap] Compiling LinearToneMap_Apply Kernel
[LuxCore][22.015] [LinearToneMap] Kernels compilation time: 0ms
Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FFD85579397
Module : C:\Users\sarma\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\BlendLuxCore\bin\pyluxcore.pyd
Windows 10 Pro Ryzen 9 3900x 2xGTX 1070ti 32 GB RAM

User avatar
Dade
Developer
Posts: 4489
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Viewport render crash on GPU Cuda

Post by Dade » Tue Jun 30, 2020 12:30 pm

Is it related to the use of 2xGPUs ? Does it happen with only one ?
Support LuxCoreRender project with salts and bounties

sarmath
Posts: 97
Joined: Wed Feb 07, 2018 1:22 pm

Re: Viewport render crash on GPU Cuda

Post by sarmath » Tue Jun 30, 2020 1:30 pm

Dade wrote:
Tue Jun 30, 2020 12:30 pm
Is it related to the use of 2xGPUs ? Does it happen with only one ?
I can confirm that with one Gpu active there is no crash.
Windows 10 Pro Ryzen 9 3900x 2xGTX 1070ti 32 GB RAM

User avatar
Dade
Developer
Posts: 4489
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Viewport render crash on GPU Cuda

Post by Dade » Tue Jun 30, 2020 2:24 pm

sarmath wrote:
Tue Jun 30, 2020 1:30 pm
Dade wrote:
Tue Jun 30, 2020 12:30 pm
Is it related to the use of 2xGPUs ? Does it happen with only one ?
I can confirm that with one Gpu active there is no crash.
Mmmm, ok, this is a good hint of where the problem is, I will check.
Support LuxCoreRender project with salts and bounties

User avatar
Theo_Gottwald
Posts: 76
Joined: Fri Apr 24, 2020 12:01 pm

Re: Viewport render crash on GPU Cuda

Post by Theo_Gottwald » Tue Jun 30, 2020 8:08 pm

I have also 2 GPUs (GTX 1080).

As long as the problem is there you can just (while the blender instance has crashed)
open an new blender (empty) set it to Luxrender and it will work fine immediately.
Register @Dreamstime and sell your Renderings to the world.

User avatar
Dade
Developer
Posts: 4489
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Viewport render crash on GPU Cuda

Post by Dade » Wed Jul 01, 2020 9:08 am

I should have fixed this problem.
Support LuxCoreRender project with salts and bounties

sarmath
Posts: 97
Joined: Wed Feb 07, 2018 1:22 pm

Re: Viewport render crash on GPU Cuda

Post by sarmath » Wed Jul 01, 2020 12:39 pm

Dade wrote:
Wed Jul 01, 2020 9:08 am
I should have fixed this problem.
Hi. Still get crashes but less often:

Exporter] Update because of: CAMERA | REQUIRES_SCENE_EDIT
[SDL][61.000] Camera type: perspective
[SDL][61.000] Camera position: Point[0.535614, -1.17925, 0.29899]
[SDL][61.000] Camera target: Point[0.0290837, -0.317189, 0.315511]
[SDL][61.000] Camera clipping plane disabled
[Exporter] Update because of: CAMERA | REQUIRES_SCENE_EDIT
[SDL][61.062] Camera type: perspective
[SDL][61.062] Camera position: Point[0.539634, -1.1774, 0.298545]
[SDL][61.062] Camera target: Point[0.0293316, -0.317569, 0.315426]
[SDL][61.062] Camera clipping plane disabled
[Engine] del: stopping session
[LuxCore][62.859] [GeForce GTX 1070 Ti OpenCLIntersect] Memory used for hardware image pipeline: 25883Kbytes
Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FFDFA2E5F58
Module : C:\Windows\SYSTEM32\ntdll.dll

and another one:

LuxCore][22.484] CUDA devices used:
[LuxCore][22.484] [GeForce GTX 1070 Ti CUDAIntersect]
[LuxCore][22.484] [GeForce GTX 1070 Ti CUDAIntersect]
[LuxCore][22.484] OpenCL devices used:
[LuxCore][22.484] Native devices used: 0
[LuxCore][22.484] Configuring 2 OpenCL render threads
[LuxCore][22.484] Configuring 0 native render threads
[LuxRays][22.500] Preprocessing DataSet
[LuxRays][22.500] Total vertex count: 2852282
[LuxRays][22.500] Total triangle count: 4382284
[LuxRays][22.500] Preprocessing DataSet done
[LuxRays][22.500] Adding DataSet accelerator: MBVH
[LuxRays][22.500] Total vertex count: 2852282
[LuxRays][22.500] Total triangle count: 4382284
[LuxRays][22.500] Building Multilevel Bounding Volume Hierarchy: 85 leafs
[LuxRays][22.500] BVH Dataset preprocessing time: 0ms
[LuxRays][22.500] BVH builder: EMBREE_BINNED_SAH
Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FFDFA2E5F38
Module : C:\Windows\SYSTEM32\ntdll.dll
Windows 10 Pro Ryzen 9 3900x 2xGTX 1070ti 32 GB RAM

User avatar
Dade
Developer
Posts: 4489
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Viewport render crash on GPU Cuda

Post by Dade » Thu Jul 02, 2020 10:11 am

It is working fine here, are you sure to have correctly updated the BlendLuxCore ?

If you:

1) open Blender;
2) set LuxCore render;
3) set GPU rendering;
4) enable viewport rendering;
5) grab the cube and move it around.

Does it crash ?
Support LuxCoreRender project with salts and bounties

filip
Posts: 20
Joined: Sat Sep 14, 2019 9:53 am

Re: Viewport render crash on GPU Cuda

Post by filip » Thu Jul 02, 2020 11:02 am

Hi,

Just came to the forums to report some crashes/weird stuff and saw this thread. I think it might be related.

Using CUDA as well, but I think the behavior is the same with OpenCL. I also have two cards, an RTX 2070 Super and a GTX 1060. The 2070 is the main card, that is the one which I have the monitor connected to.
So, in the scene I uploaded, if I disable Light Tracing the viewport render is split in half, with half of it looking more noisy than the other. See the attached picture.
Sometimes disabling it causes Blender to crash.
Even if I disable Light Tracing with the viewport render off and then start the viewport render, it will crash or have this weird half image issue.
Rendering normally seems to work fine, it's just the viewport render that has problems I think.

However, if I disable the 1060 from the device list, this problem seems to disappear. And in fact, the viewport render is more responsive as well, I think, with the 1060 disabled.

I just downloaded the last 2.4 build and it's the same.

Thank you.
Attachments
candle2_up.zip
(998.26 KiB) Downloaded 11 times
Untitled-1.png

sarmath
Posts: 97
Joined: Wed Feb 07, 2018 1:22 pm

Re: Viewport render crash on GPU Cuda

Post by sarmath » Thu Jul 02, 2020 11:48 am

Dade wrote:
Thu Jul 02, 2020 10:11 am
It is working fine here, are you sure to have correctly updated the BlendLuxCore ?

If you:

1) open Blender;
2) set LuxCore render;
3) set GPU rendering;
4) enable viewport rendering;
5) grab the cube and move it around.

Does it crash ?
Just tested with todays dailybuild. Its not crashing with cube only. But its crashing with more complicated scenes like hallbench just after kernel compilation. The CannelleEtFromage scene crashes when you start panning and moving camera for a while.
Opencl and Cuda.

Hallbench scene:
Opencl just after kernel compilation:

[LuxRays][177.718] [LinearToneMap] Compiling kernels
[LuxRays][177.734] [LinearToneMap] Program cached
[LuxCore][177.734] [AutoLinearToneMap] Compiling LinearToneMap_Apply Kernel
[LuxCore][177.734] [LinearToneMap] Kernels compilation time: 16ms
[LuxRays][177.734] [VignettingPlugin] Compiler options: -D LUXRAYS_OPENCL_KERNEL -D SLG_OPENCL_KERNEL -D LUXRAYS_OPENCL_DEVICE -D LUXRAYS_OS_WINDOWS
[LuxRays][177.734] [VignettingPlugin] Compiling kernels
[LuxRays][177.734] [VignettingPlugin] Program cached
[LuxCore][177.734] [VignettingPlugin] Compiling VignettingPlugin_Apply Kernel
[LuxCore][177.734] [VignettingPlugin] Kernels compilation time: 0ms
Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FFDAE88923E
Module : C:\Users\sarma\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\BlendLuxCore\bin\pyluxcore.pyd

And Cuda :

[LuxRays][32.625] [Device GeForce GTX 1070 Ti CUDAIntersect] PathInfo buffer size: 6048Kbytes
[LuxRays][32.625] [Device GeForce GTX 1070 Ti CUDAIntersect] DirectLightVolumeInfo buffer size: 2464Kbytes
[LuxRays][32.625] [Device GeForce GTX 1070 Ti CUDAIntersect] Pixel Filter Distribution buffer size: 33Kbytes
[LuxCore][32.625] [PathOCLBaseRenderThread::1] Compiling kernels
[LuxRays][32.625] [PathOCL kernel] Compiler options: -D LUXRAYS_OPENCL_KERNEL -D SLG_OPENCL_KERNEL -D RENDER_ENGINE_RTPATHOCL -D PARAM_RAY_EPSILON_MIN=1e-05f -D PARAM_RAY_EPSILON_MAX=0.1f -D LUXRAYS_CUDA_DEVICE -D LUXRAYS_OS_WINDOWS --use_fast_math
[LuxRays][32.625] [PathOCL kernel] Compiling kernels
[LuxRays][32.656] [PathOCL kernel] Program cached
[LuxCore][32.656] [PathOCLBaseRenderThread::1] Compiling Film_Clear Kernel
[LuxCore][32.656] [PathOCLBaseRenderThread::1] Compiling InitSeed Kernel
[LuxCore][32.656] [PathOCLBaseRenderThread::1] Compiling Init Kernel
[LuxCore][32.656] [PathOCLBaseRenderThread::1] Compiling AdvancePaths_MK_RT_NEXT_VERTEX Kernel
[LuxCore][32.656] [PathOCLBaseRenderThread::1] Compiling AdvancePaths_MK_HIT_NOTHING Kernel
[LuxCore][32.672] [PathOCLBaseRenderThread::1] Compiling AdvancePaths_MK_HIT_OBJECT Kernel
[LuxCore][32.672] [PathOCLBaseRenderThread::1] Compiling AdvancePaths_MK_RT_DL Kernel
[LuxCore][32.672] [PathOCLBaseRenderThread::1] Compiling AdvancePaths_MK_DL_ILLUMINATE Kernel
[LuxCore][32.672] [PathOCLBaseRenderThread::1] Compiling AdvancePaths_MK_DL_SAMPLE_BSDF Kernel
[LuxCore][32.672] [PathOCLBaseRenderThread::1] Compiling AdvancePaths_MK_GENERATE_NEXT_VERTEX_RAY Kernel
[LuxCore][32.672] [PathOCLBaseRenderThread::1] Compiling AdvancePaths_MK_SPLAT_SAMPLE Kernel
[LuxCore][32.672] [PathOCLBaseRenderThread::1] Compiling AdvancePaths_MK_NEXT_SAMPLE Kernel
[LuxCore][32.672] [PathOCLBaseRenderThread::1] Compiling AdvancePaths_MK_GENERATE_CAMERA_RAY Kernel
[LuxCore][32.672] [PathOCLBaseRenderThread::1] AdvancePaths_MK_* workgroup size: 32
[LuxCore][32.672] [PathOCLBaseRenderThread::1] Kernels compilation time: 47ms
[LuxCore][32.672] Starting 0 native render threads
Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FFDADB19397
Module : C:\Users\sarma\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\BlendLuxCore\bin\pyluxcore.pyd
Windows 10 Pro Ryzen 9 3900x 2xGTX 1070ti 32 GB RAM

Post Reply