Lights in 2.3 (2.4)

Use this forum for general user support and related questions.
Post Reply
filip
Posts: 11
Joined: Sat Sep 14, 2019 9:53 am

Lights in 2.3 (2.4)

Post by filip » Thu May 21, 2020 3:03 pm

Hi,

I had this scene rendered in 2.2 and I tried to render it in 2.3 and 2.4 but I can't get it to look the same.
The attached image is how it looked in 2.2

I tried both Blender 2.81 (in which I originally made the scene) and 2.82
It seems like the the "laser" and the mesh light have no effect on the lighting?

I tried various options, light tracing etc, but didn't seem to make any difference. Tried both CPU and OpenCL (on RTX 2070 Super)
Couldn't really get the CUDA version to work. 2.4 keeps locking-up both in CUDA and OpenCL for me.

Thank you.
Attachments
flask7_3.png
upload.blend
(2.96 MiB) Downloaded 6 times

User avatar
B.Y.O.B.
Developer
Posts: 3555
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Lights in 2.3 (2.4)

Post by B.Y.O.B. » Thu May 21, 2020 3:12 pm

In the bottom of the render settings, there's a panel called "LuxCore Tools". In there is a converter button for v2.2 or older scenes.
About the locking up: There should be a message that it is compiling kernels, is that the case? Have you tried just waiting 20 min or so? Unfortunately OpenCL compilers are very slow.

filip
Posts: 11
Joined: Sat Sep 14, 2019 9:53 am

Re: Lights in 2.3 (2.4)

Post by filip » Thu May 21, 2020 3:18 pm

Awesome, that works! Thanks! I can get it to work with the CPU.

However, as in 2.2 I can't get the same caustics result on the GPU (with Path instead of BiDir). At some point I think I read that in 2.3 both will produce the same or similar results? Or have I misunderstood.

User avatar
B.Y.O.B.
Developer
Posts: 3555
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Lights in 2.3 (2.4)

Post by B.Y.O.B. » Thu May 21, 2020 3:19 pm

Can you upload the converted scene with the non-working caustics?

filip
Posts: 11
Joined: Sat Sep 14, 2019 9:53 am

Re: Lights in 2.3 (2.4)

Post by filip » Thu May 21, 2020 3:35 pm

Here it is.
On Path, on both CPU or GPU those 2 "rings" under the flask that show up on BiDir are missing.
Weirdly, the left side ring shows up in viewport preview when using OpenCL, but not the right one. In final render neither shows up.

Edit: Even more weirdly, in 2.4 the right ring shows up, but not the left one. And it's not showing with BiDir either.

Btw, I did wait some more when 2.4 locked-up and it did start again. Thanks for that as well. I'll experiment some more and see if it still locks up.
Attachments
upload2.blend
(2.97 MiB) Downloaded 8 times

User avatar
Dade
Developer
Posts: 4255
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Lights in 2.3 (2.4)

Post by Dade » Thu May 21, 2020 4:35 pm

It may be a mater of max. path depth, the default is different between BiDir and Path+Light tracing (and view port preview).
Support LuxCoreRender project with salts and bounties

filip
Posts: 11
Joined: Sat Sep 14, 2019 9:53 am

Re: Lights in 2.3 (2.4)

Post by filip » Fri May 22, 2020 11:17 am

OK, so I managed to get the same result in 2.4 with BiDir if I rotate the mesh light 180 degrees.

On path I can only get the left ring showing. I tried changing the "Total Path Depth" but it didn't seem to have any effects.

Also switching from BiDir to Path affects the lighting on the gold material on the black "stick". On BiDir it's nice and bright, on Path it's darker.

Post Reply