Something is off with translucency in OpenCL

Use this forum for general user support and related questions.
Forum rules
Please upload a testscene that allows developers to reproduce the problem, and attach some images.
Post Reply
juangea
Donor
Posts: 194
Joined: Thu Jan 02, 2020 6:23 pm

Something is off with translucency in OpenCL

Post by juangea » Wed Jan 15, 2020 10:44 am

HI there.

So I'm trying to create some curtains, this is the material:
mat_curtains.JPG
CPU Render:
curtains_cpu.JPG
OpenCL Render:
curtains_opencl.JPG
Exact same material, exact same object, exact everything.

@dade @B.Y.O.B. Any ideas of what is happening? something is not working or is broken with OpenCL right now.

User avatar
Dade
Developer
Posts: 4813
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Something is off with translucency in OpenCL

Post by Dade » Wed Jan 15, 2020 11:00 am

Mixing a solid material (like Disney) with a transparent one (like glossy translucent) can be a recipe for a lot of troubles: does it happen if you use the glossy translucent material alone ?
Support LuxCoreRender project with salts and bounties

juangea
Donor
Posts: 194
Joined: Thu Jan 02, 2020 6:23 pm

Re: Something is off with translucency in OpenCL

Post by juangea » Wed Jan 15, 2020 11:33 am

Yes, it seems the problem is the mix of translucent and disney, there is a difference in brightness when you mix that, I have not tested with velvet or matte, will do.

How can I achieve a translucent curtain feeling without breaking laws of physics? hahaha

User avatar
Dade
Developer
Posts: 4813
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Something is off with translucency in OpenCL

Post by Dade » Wed Jan 15, 2020 11:37 am

Have you tried to use Disney with just some transparency (or opacity, I don't remember how it is called in BlendLuxCore, it is a generic material setting available for all LuxCore materials) ? It would, by far, the fastest solution to render.
Support LuxCoreRender project with salts and bounties

juangea
Donor
Posts: 194
Joined: Thu Jan 02, 2020 6:23 pm

Re: Something is off with translucency in OpenCL

Post by juangea » Wed Jan 15, 2020 11:40 am

It's what I'm doing right now, but it looses the effect of the ligth scattering that make you perceive the window border, but in a blurred/diffuminated way, like in some real curtains, with transparency in the end we get the hard border of the window, so the effect is not the same :)

juangea
Donor
Posts: 194
Joined: Thu Jan 02, 2020 6:23 pm

Re: Something is off with translucency in OpenCL

Post by juangea » Wed Jan 15, 2020 12:02 pm

Confirmed, Disney + Translucency does somethign weird in OpenCL

OpenCL:
openCL.png
CPU:
cpu.png
Shader:
shader.png
Blend file:

http://pasteall.org/blend/index.php?id=52783

User avatar
Dade
Developer
Posts: 4813
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Something is off with translucency in OpenCL

Post by Dade » Wed Jan 15, 2020 4:44 pm

I should have fixed the problem: it was a bug in OpenCL code when mixing transparent and not transparent materials.
Support LuxCoreRender project with salts and bounties

juangea
Donor
Posts: 194
Joined: Thu Jan 02, 2020 6:23 pm

Re: Something is off with translucency in OpenCL

Post by juangea » Wed Jan 15, 2020 4:59 pm

Awesome! Thanks @Dade :)

Post Reply