Compile on MacOS 10.13

Discussion related to the LuxCore functionality, implementations and API.
User avatar
Dade
Developer
Posts: 4250
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Compile on MacOS

Post by Dade » Tue Dec 03, 2019 11:09 pm

u3dreal wrote:
Tue Dec 03, 2019 10:51 pm
I'll compile it manually to see whats is missing ... freetype is installed via brew
But is it in the list of linked libraries (if it is not directly included in OpenImageIO) ?
Support LuxCoreRender project with salts and bounties

User avatar
u3dreal
Developer
Posts: 396
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS

Post by u3dreal » Tue Dec 03, 2019 11:28 pm

freetype is set to find silently .. :) well see i just compile oiio
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

User avatar
u3dreal
Developer
Posts: 396
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS

Post by u3dreal » Tue Dec 03, 2019 11:37 pm

oiio compiled fine with all the flags from the "build_deps" script ... finding freetype of course during configure ... now let's seee :shock:
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

User avatar
u3dreal
Developer
Posts: 396
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS

Post by u3dreal » Tue Dec 03, 2019 11:42 pm

This drives me crazy ... another thing missing from oiio looks like dlib ... installed it let's see ..

edit it's libgif :(

why is it disabled in the build_deps script ? :shock:

Code: Select all

Undefined symbols for architecture x86_64:
  "_DGifCloseFile", referenced from:
      OpenImageIO_v1_8::GIFInput::seek
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

User avatar
u3dreal
Developer
Posts: 396
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS

Post by u3dreal » Wed Dec 04, 2019 1:03 pm

OK problem was that osx does not permit static linking of external sources mainly into oiio.

Building dynamicaly works. :D
Running 2.3git ;)

I guess for the release we'll have to copy some more .dylibs
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

User avatar
u3dreal
Developer
Posts: 396
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS

Post by u3dreal » Wed Dec 04, 2019 11:52 pm

OK i got something running here . Could someone plz point me to the buildphase where the binaries get patch with @rpath ?

I want to add OpenImageIO and OpenImageDenoiser too. fixing them afterwards with install_name_tool is horrible ... or i don't know what i'm doing.
At least not very perdictable :) thanks is advance.

In fact pyluxcore.so and BlendLuxCore seems to work on my other mac where no homebrew is installed. denoise is a bit of a problem. Can't get it to work sp far.
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

User avatar
Dade
Developer
Posts: 4250
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Compile on MacOS

Post by Dade » Thu Dec 05, 2019 12:50 am

Do you need to set the rpath of pyluxcore.so (https://github.com/LuxCoreRender/LuxCor ... eLists.txt) ? Or luxcoreui executable (https://github.com/LuxCoreRender/LuxCor ... eLists.txt) ? Or ?
Support LuxCoreRender project with salts and bounties

User avatar
Dade
Developer
Posts: 4250
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Compile on MacOS

Post by Dade » Thu Dec 05, 2019 12:51 am

u3dreal wrote:
Wed Dec 04, 2019 11:52 pm
denoise is a bit of a problem. Can't get it to work sp far.
The binaries are directly from Intel (https://github.com/OpenImageDenoise/oidn/releases), it is strange, does the denoise command work ?
Support LuxCoreRender project with salts and bounties

User avatar
u3dreal
Developer
Posts: 396
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS

Post by u3dreal » Thu Dec 05, 2019 1:03 am

It works on the build machine but not the the other mac. But when i manually do

Code: Select all

install_name_tool -change bal/bla/bla/libOpenImageDenoiser.0.dylib @rpath/libOpenImageDenoiser.0.dylib denoise
denoise does not find the lib not even on the build mac.

I found the if Apple section ... how might the iodn lib be namend ?? ahh OIDN_LIBRARY ... and ?? libOpenImageIO ? OIIO_LIBRARY ?

Sorry this is all the so new but i thing i got the symbols thing.
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

User avatar
u3dreal
Developer
Posts: 396
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS

Post by u3dreal » Thu Dec 05, 2019 1:58 am

OK now i'm confused ... does pyluxcore need to be linked against OpenImageDenoise ??? I guess not since it works without :?
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

Post Reply