2.5a and pointer a material

Use this forum for general user support and related questions.
Forum rules
Please upload a testscene that allows developers to reproduce the problem, and attach some images.
Post Reply
marcatore
Donor
Posts: 446
Joined: Wed Jan 10, 2018 8:04 am

2.5a and pointer a material

Post by marcatore » Mon Aug 10, 2020 12:53 pm

Hi,
it seems that the pointer of a material didn't work.
The mesh with the pointer is rendered black.

I've attached a simple scene where you can see the problem.
pointer_test.zip
(117.45 KiB) Downloaded 42 times

User avatar
Dade
Developer
Posts: 4817
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: 2.5a and pointer a material

Post by Dade » Mon Aug 10, 2020 1:02 pm

I assume "pointer" is some Blender related material alias stuff. B.Y.O.B. is out of the town for some days: it may be a good idea to open issue on GitHub.
Support LuxCoreRender project with salts and bounties

marcatore
Donor
Posts: 446
Joined: Wed Jan 10, 2018 8:04 am

Re: 2.5a and pointer a material

Post by marcatore » Mon Aug 10, 2020 2:48 pm

yes..it's the pointer node in Blender.
I've opened an issue on github.

CodeHD
Posts: 397
Joined: Tue Dec 11, 2018 12:38 pm
Location: Germany

Re: 2.5a and pointer a material

Post by CodeHD » Mon Aug 10, 2020 7:48 pm

Here is an idea for a workaround if you need it:
pointermat.png
I had a look at the code to try and find out what happens, but didn't yet fully get to the bottom of it. A third material is exported with the correct settings as per the pointed material, but no name string (only the random number) as well as not used on an object. Instead the material is exported as matte with 0 brightness.

[All places in BlendLuxCore I could find where such a definition is made are not called. Does LuxCore have a matte-black fallback somewhere?] EDIT: Nevermind, I found this fallback in BlendLuxCore.

User avatar
B.Y.O.B.
Developer
Posts: 3872
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: 2.5a and pointer a material

Post by B.Y.O.B. » Thu Aug 13, 2020 12:54 pm

I'm not sure why you would need such a node setup, but I have pushed a change that makes this possible.

marcatore
Donor
Posts: 446
Joined: Wed Jan 10, 2018 8:04 am

Re: 2.5a and pointer a material

Post by marcatore » Fri Aug 14, 2020 10:10 am

B.Y.O.B. wrote:
Thu Aug 13, 2020 12:54 pm
I'm not sure why you would need such a node setup, but I have pushed a change that makes this possible.
Actually you're right.. it was just for "scene materials organization". I had a material named "A" that had a initial setup and then I'd like to test how it should be using the material "B"...
I should make the same simply assign directly the material "B"...

Sorry for this...anyway..if it's "fixed".... good to know for the next silly material setups :)

User avatar
B.Y.O.B.
Developer
Posts: 3872
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: 2.5a and pointer a material

Post by B.Y.O.B. » Thu Sep 24, 2020 1:24 pm

I have reverted the "fix" to this as it was causing other problems (viewtopic.php?f=4&t=2611&start=10#p25569).
The node setup causing problems (pointer straight into material output) is nonsensical anyway, so I will just leave it as non-working like before.

Post Reply