LuxCoreRender daily/automatic builds

News & Announcements regarding releases, features, exporters and project coordination.
Fox
Posts: 316
Joined: Sat Mar 31, 2018 11:17 am

Re: LuxCoreRender daily/automatic builds

Post by Fox » Sat Sep 07, 2019 3:42 pm

Odilkhan Yakubov wrote:
Sat Sep 07, 2019 2:58 am
Is it supported by my system or not? As said before, my CPU is legacy. Exactly, Core2Quad Q6600
My previous CPU from same time or so, the core 2 duo e4500 (Q3'07) was not supported in most of the software that i use. I had to upgrade in mid 2016.

Odilkhan Yakubov
Posts: 59
Joined: Fri Jan 26, 2018 10:07 pm
Location: Tashkent, Uzbekistan

Re: LuxCoreRender daily/automatic builds

Post by Odilkhan Yakubov » Mon Sep 09, 2019 1:32 pm

Yes, thats it! BUT, i using Cycles too with this config.
Allah bless us!

User avatar
B.Y.O.B.
Developer
Developer
Posts: 2997
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCoreRender daily/automatic builds

Post by B.Y.O.B. » Tue Sep 10, 2019 2:52 pm

Thanks to acasta69, daily builds of BlendLuxCore are now available as well.
I have updated the first post.
Support LuxCoreRender project with salts and bounties

Asticles
Donor
Donor
Posts: 151
Joined: Thu Jan 11, 2018 8:52 am

Re: LuxCoreRender daily/automatic builds

Post by Asticles » Wed Sep 11, 2019 5:15 pm

Amazing! thanks!
Salvador Ureña

Racleborg
Posts: 472
Joined: Sat Apr 07, 2018 10:31 am
Location: UK

Re: LuxCoreRender daily/automatic builds

Post by Racleborg » Fri Sep 13, 2019 11:16 am

Great. Thank you :)

User avatar
Dade
Developer
Developer
Posts: 3277
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: LuxCoreRender daily/automatic builds

Post by Dade » Fri Oct 04, 2019 3:02 pm

The v2.2 has been released and, now on, the daily/automatic builds will be about v2.3.
Support LuxCoreRender project with salts and bounties

Racleborg
Posts: 472
Joined: Sat Apr 07, 2018 10:31 am
Location: UK

Re: LuxCoreRender daily/automatic builds

Post by Racleborg » Sat Oct 05, 2019 10:45 am

Great. Thank you :)

Martini
Posts: 42
Joined: Fri Nov 23, 2018 11:36 am
Location: Australia

Re: LuxCoreRender daily/automatic builds

Post by Martini » Sun Nov 17, 2019 5:41 am

Is there any issue with the daily builds for Linux right now? I get an error about not being able to find libtbbmalloc.so.2 even though it's in the same directory. :?

Output from Blender:

Code: Select all

Modules Installed (BlendLuxCore) from '/home/martini/Downloads/BlendLuxCore-latest-linux64-opencl (1).zip' into '/home/martini/.config/blender/2.81/scripts/addons'
Traceback (most recent call last):
  File "/home/martini/Downloads/blender-2.81/2.81/scripts/modules/addon_utils.py", line 351, in enable
    mod = __import__(module_name)
  File "/home/martini/.config/blender/2.81/scripts/addons/BlendLuxCore/__init__.py", line 23, in <module>
    raise Exception(msg + "\n\nImportError: %s" % error) from None
Exception: 

Could not import pyluxcore.

ImportError: libtbbmalloc.so.2: cannot open shared object file: No such file or directory
The file is right there:

Code: Select all

~/.config/blender/2.81/scripts/addons/BlendLuxCore/bin$ ll
total 127080
drwxr-xr-x  3 martini martini     4096 Nov 17 16:32 ./
drwxr-xr-x 15 martini martini     4096 Nov 17 16:32 ../
-rwxr-xr-x  1 martini martini   117395 Nov 17 16:32 denoise*
-rw-r--r--  1 martini martini     2565 Nov 17 16:32 get_binaries.py
-rw-r--r--  1 martini martini      107 Nov 17 16:32 .gitignore
-rw-r--r--  1 martini martini        0 Nov 17 16:32 __init__.py
-rw-r--r--  1 martini martini 39181910 Nov 17 16:32 libembree3.so.3
-rw-r--r--  1 martini martini 40778269 Nov 17 16:32 libOpenImageDenoise.so.0
-rw-r--r--  1 martini martini   801899 Nov 17 16:32 libtbbmalloc.so.2
-rw-r--r--  1 martini martini  2153201 Nov 17 16:32 libtbb.so.2
drwxr-xr-x  2 martini martini     4096 Nov 17 16:32 __pycache__/
-rw-r--r--  1 martini martini 47002352 Nov 17 16:32 pyluxcore.so
-rw-r--r--  1 martini martini    58298 Nov 17 16:32 pyluxcoretools.zip
-rw-r--r--  1 martini martini      675 Nov 17 16:32 readme.md
This happened when trying to enable the addon in Blender. I was struggling with the same thing yesterday and somehow got it to work while messing around with the 2.2 release, but can't remember what I did to make it work; now it's not working again.

For context: I was hoping to do another test regarding the issue of Light Tracing being far too bright, and run it in LuxCore UI directly. So I downloaded the standalone LuxCoreRender and unpacked it into the same place as BlendLuxCore, and then everything stopped working again. I am also not able to run LuxCore UI due to the same error.

Here is the output of ldd. The only lib it can't find is the one mentioned above, so I've pasted just the relevant portion

Code: Select all

~/.config/blender/2.81/scripts/addons/BlendLuxCore/bin$ ldd pyluxcore.so | grep libtbbmalloc
	libtbbmalloc.so.2 => not found
	libtbbmalloc.so.2 => /home/martini/.config/blender/2.81/scripts/addons/BlendLuxCore/bin/./libtbbmalloc.so.2 (0x00007f233d981000)
i9 9900K @ 5000MHz | 2x Gigabyte AORUS RTX 2080 Ti Extreme Waterforce WB 11G @ 2010MHz
Z390 Aorus Pro | 32GB Kingston HyperX Predator RGB @ 4300MHz

User avatar
Dade
Developer
Developer
Posts: 3277
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: LuxCoreRender daily/automatic builds

Post by Dade » Sun Nov 17, 2019 10:17 am

Martini wrote:
Sun Nov 17, 2019 5:41 am
So I downloaded the standalone LuxCoreRender and unpacked it into the same place as BlendLuxCore, and then everything stopped working again.
This is not the way the standalone version is intended to be used, just unpack in a different directory. I'm not sure what kind of consequences can have this action, have you tried to delete "~/.config/blender/2.81/scripts/addons/BlendLuxCore" and re-install BlendLuxCore from scratch ?
Support LuxCoreRender project with salts and bounties

Martini
Posts: 42
Joined: Fri Nov 23, 2018 11:36 am
Location: Australia

Re: LuxCoreRender daily/automatic builds

Post by Martini » Sun Nov 17, 2019 11:16 am

Dade wrote:
Sun Nov 17, 2019 10:17 am
Martini wrote:
Sun Nov 17, 2019 5:41 am
So I downloaded the standalone LuxCoreRender and unpacked it into the same place as BlendLuxCore, and then everything stopped working again.
This is not the way the standalone version is intended to be used, just unpack in a different directory. I'm not sure what kind of consequences can have this action, have you tried to delete "~/.config/blender/2.81/scripts/addons/BlendLuxCore" and re-install BlendLuxCore from scratch ?
Yeah, sorry, I came across a post much earlier in this thread and I thought I'd try that procedure.

I forgot to mention I did completely remove the addon, confirm the directory is gone, restart Blender, and reinstall the addon by clicking Install in Blender and then locating the 'latest' version that I downloaded from the releases page on GitHub. I've also unpacked the standalone to its own directory elsewhere and it can't find the shared library in that location either. The output of the ldd command in all cases is the same: it has 2 entries for libtbbmalloc.so.2 - the first is "not found" and the second is the correct location. And it won't allow me to install the addon in Blender, or run the standalone.

Edit: I can install the release version 2.2 of the addon with no problems
Last edited by Martini on Sun Nov 17, 2019 11:22 am, edited 1 time in total.
i9 9900K @ 5000MHz | 2x Gigabyte AORUS RTX 2080 Ti Extreme Waterforce WB 11G @ 2010MHz
Z390 Aorus Pro | 32GB Kingston HyperX Predator RGB @ 4300MHz

Post Reply