LuxCoreRender v2.1beta1 released

News & Announcements regarding releases, features, exporters and project coordination.
Harvester
Posts: 9
Joined: Thu Jan 25, 2018 8:06 pm

Re: LuxCoreRender v2.1beta1 released

Post by Harvester » Wed Oct 31, 2018 8:56 am

Grazie! Thank you!

User avatar
Dade
Developer
Posts: 1458
Joined: Mon Dec 04, 2017 8:36 pm

Re: LuxCoreRender v2.1beta1 released

Post by Dade » Wed Oct 31, 2018 9:00 am

lacilaci wrote:
Wed Oct 31, 2018 7:50 am
So how's the CPU usage for people using windows and beta1 with opencl? I'm still getting only 15-20% on cpu when rendering with opencl(alphav4 goes to 100%)
It is a bug in BlendLuxCore, it is always telling LuxCore to use 0 CPU rendering threads :!:
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Posts: 1730
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCoreRender v2.1beta1 released

Post by B.Y.O.B. » Wed Oct 31, 2018 9:42 am

Support LuxCoreRender project with salts and bounties

tokiop
Posts: 6
Joined: Fri Apr 13, 2018 8:11 pm

Re: LuxCoreRender v2.1beta1 released

Post by tokiop » Wed Oct 31, 2018 10:20 am

Congrats to the devs, testers, documenters, artists, commenters who helped this release !

Not related to this specific release, but the new install/update process is very easy, and being able to switch between versions is great for testing and to lower the risk a breaking an existing project. Huge thanks for that too !

User avatar
Dez!
Posts: 100
Joined: Sun Apr 08, 2018 1:09 am
Location: Ekaterinburg
Contact:

Re: LuxCoreRender v2.1beta1 released

Post by Dez! » Sat Nov 03, 2018 4:28 am

Dade and Byob, You are my superheroes!
Image

how to use it?
Three new textures for accessing the object ID: raw object ID (range 0 to 0xfffffffe), normalized object ID (range 0 to 1), object ID interpreted as color
Linux Gnome | Dell Inspiron 7000 | Wacom
http://dezigner.tilda.ws/

User avatar
FarbigeWelt
Posts: 302
Joined: Sun Jul 01, 2018 12:07 pm
Location: Switzerland
Contact:

openCL with CPU performance

Post by FarbigeWelt » Sat Nov 03, 2018 3:45 pm

lacilaci wrote:
Wed Oct 31, 2018 7:50 am
So how's the CPU usage for people using windows and beta1 with opencl? I'm still getting only 15-20% on cpu when rendering with opencl(alphav4 goes to 100%)
Usually, I disable CPU for openCL. Because you asked for, I joined in and performed these short tests with LuxCoreRender v2.1 beta1.

GPU Devices: 2 Hawaii
Use CPU, auto-detect: CPU usage []
during render ~9%
Samples/s 9.7 M

Only GPUs, CPU usage []
during render ~9%
Samples/s 9.8 M

With denoiser
Use CPU, auto-detect: CPU usage []
during render ~9%
during denoise 99%
Samples/s 9.0 M

Only GPUs, CPU usage []
during render ~9%
during denoise 99%
Samples/s 9.2 M

Minor Issues:
On my system, denoising freezes mouse pointer for short moments,
and denoising cannot be cancelled after running for a few seconds (Esc).


EDIT: CPU usage is already answered.. THX.
Microsoft Windows 10 Professional, intel i7 4770K, 32 GB, AMD R9 290x 4 GB, AMD R9 390x 8 GB
Instagrammer, please join #luxcorerender for your renderings.

User avatar
B.Y.O.B.
Developer
Posts: 1730
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCoreRender v2.1beta1 released

Post by B.Y.O.B. » Sat Nov 03, 2018 4:02 pm

FarbigeWelt wrote:
Sat Nov 03, 2018 3:45 pm
and denoising cannot be cancelled after running for a few seconds (Esc).
The LuxCore API does not allow this as far as I know.
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Posts: 1730
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCoreRender v2.1beta1 released

Post by B.Y.O.B. » Mon Nov 05, 2018 2:56 pm

Dade wrote:
Wed Oct 31, 2018 9:00 am
lacilaci wrote:
Wed Oct 31, 2018 7:50 am
So how's the CPU usage for people using windows and beta1 with opencl? I'm still getting only 15-20% on cpu when rendering with opencl(alphav4 goes to 100%)
It is a bug in BlendLuxCore, it is always telling LuxCore to use 0 CPU rendering threads :!:
I have fixed this bug.
Support LuxCoreRender project with salts and bounties

lacilaci
Posts: 346
Joined: Fri May 04, 2018 5:16 am

Re: LuxCoreRender v2.1beta1 released

Post by lacilaci » Mon Nov 05, 2018 3:25 pm

B.Y.O.B. wrote:
Mon Nov 05, 2018 2:56 pm
Dade wrote:
Wed Oct 31, 2018 9:00 am
lacilaci wrote:
Wed Oct 31, 2018 7:50 am
So how's the CPU usage for people using windows and beta1 with opencl? I'm still getting only 15-20% on cpu when rendering with opencl(alphav4 goes to 100%)
It is a bug in BlendLuxCore, it is always telling LuxCore to use 0 CPU rendering threads :!:
I have fixed this bug.
Thanks, seems to be working fine now.

User avatar
Sharlybg
Supporting Users
Posts: 815
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: LuxCoreRender v2.1beta1 released

Post by Sharlybg » Mon Nov 05, 2018 9:01 pm

Thanks, seems to be working fine now.
How to update ?
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

Post Reply