LuxCoreRender v2.0rc1 released

News & Announcements regarding releases, features, exporters and project coordination.
User avatar
B.Y.O.B.
Developer
Posts: 1825
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCoreRender v2.0rc1 released

Post by B.Y.O.B. » Sun Apr 29, 2018 6:02 am

kintuX wrote:
Sat Apr 28, 2018 11:06 pm
- if Material is created directly by using Node Tree Presets instead of standard procedure (via New and then selecting from presets), material isn't shown in the Render Preview.
It happens without using node tree presets, too.
However, I already fixed this bug (after RC1, so you have to wait for RC2 or the final release to get the fix): https://github.com/LuxCoreRender/BlendL ... issues/142
kintuX wrote:
Sat Apr 28, 2018 11:06 pm
Seems i still got an issue with particles disappearing and duplicating curve Profile (observed in Data-Blocks Mesh menu). Maybe some corner case or old scene issue. Will make new/fresh one and report back.
Ok, I'll check it when I get the test scenes.
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Posts: 1825
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCoreRender v2.0rc1 released

Post by B.Y.O.B. » Sun Apr 29, 2018 7:21 am

kintuX wrote:
Fri Apr 27, 2018 10:45 am
Another strange thing is, i had rendered particles just fine yesterday...
Now: [Duplicator "Start"] Reference to an undefined NamedObject name: 365276232
I fixed this bug.
It was yet another regression caused by my introduction of the node cache. I should not do extensive refactoring a few weeks before release... :oops:
Attachments
untitled.jpg
Support LuxCoreRender project with salts and bounties

kintuX
Posts: 263
Joined: Wed Jan 10, 2018 2:37 am

Re: LuxCoreRender v2.0rc1 released

Post by kintuX » Sun Apr 29, 2018 10:50 am

B.Y.O.B. wrote:
Sun Apr 29, 2018 6:02 am
kintuX wrote:
Sat Apr 28, 2018 11:06 pm
- if Material is created directly by using Node Tree Presets instead of standard procedure (via New and then selecting from presets), material isn't shown in the Render Preview.
It happens without using node tree presets, too.
However, I already fixed this bug (after RC1, so you have to wait for RC2 or the final release to get the fix): https://github.com/LuxCoreRender/BlendL ... issues/142
Was testing latest (fixed) scripts ;) It now works fine, even if starting with presets.
B.Y.O.B. wrote:
Sun Apr 29, 2018 6:02 am
kintuX wrote:
Sat Apr 28, 2018 11:06 pm
Seems i still got an issue with particles disappearing and duplicating curve Profile (observed in Data-Blocks Mesh menu). Maybe some corner case or old scene issue. Will make new/fresh one and report back.
Ok, I'll check it when I get the test scenes.
Ok, so this is only happening with Curve objects: ie. BezierCircle & a Curve for Profile > Creates extra Meshes.
Happens every time when LuxCore2 Render Preview or Render is started and adds to the existing meshes.
Such behavior is not observed, if Cycles is used.

1. Start either Preview (shift+z) or Render (f12).
2. Observe in Outliner: Orphan Data > Meshes
Image
(sorry for the small size preview and closed tree - beginner's mistakes, i hope you can see the issue)
CurveObjectTest.zip
(99.38 KiB) Downloaded 37 times

User avatar
B.Y.O.B.
Developer
Posts: 1825
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: LuxCoreRender v2.0rc1 released

Post by B.Y.O.B. » Sun Apr 29, 2018 11:03 am

Thanks for the report, fixed.
By the way, consider creating a github account so you can directly create github issues, it's much easier to keep track of those than of forum posts.
Support LuxCoreRender project with salts and bounties

kintuX
Posts: 263
Joined: Wed Jan 10, 2018 2:37 am

Re: LuxCoreRender v2.0rc1 released

Post by kintuX » Sun Apr 29, 2018 12:31 pm

B.Y.O.B. wrote:
Sun Apr 29, 2018 11:03 am
Thanks for the report, fixed.
By the way, consider creating a github account so you can directly create github issues, it's much easier to keep track of those than of forum posts.
Fix confirmed.

Post Reply