LuxCoreRender v2.3alpha binaries for MacOS

News & Announcements regarding releases, features, exporters and project coordination.
Post Reply
User avatar
Dade
Developer
Posts: 4380
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

LuxCoreRender v2.3alpha binaries for MacOS

Post by Dade » Sat Dec 07, 2019 10:01 am

u3dreal has compiled and packed together the binaries of v2.3 alpha for MacOS: http://q3de.com/research/luxcorerender-for-osx-10-13
Support LuxCoreRender project with salts and bounties

User avatar
Sharlybg
Donor
Posts: 2073
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: LuxCoreRender v2.3alpha binaries for MacOS

Post by Sharlybg » Sat Dec 07, 2019 1:24 pm

Dade wrote:
Sat Dec 07, 2019 10:01 am
u3dreal has compiled and packed together the binaries of v2.3 alpha for MacOS: http://q3de.com/research/luxcorerender-for-osx-10-13
Wow miracle still happen. Wonderfull job. Very inspiring.
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

epilectrolytics
Donor
Posts: 703
Joined: Thu Oct 04, 2018 6:06 am

Re: LuxCoreRender v2.3alpha binaries for MacOS

Post by epilectrolytics » Sat Dec 07, 2019 4:23 pm

Great stuff, thanks sooo much for this early christmas present!
LuxCoreRender v2.3alpha in Blender 2.81 on MacOS High Sierra, never thought it would happen so fast!

So far everything works fine on my old MacBook, even OpenCL on GT750M works very well, better than in v2.1!
Only issues are with Iris Pro graphics, an old problem with no relevance as the thing is normally disabled by default.

I don't see the need for a 2.2 release either.

User avatar
u3dreal
Developer
Posts: 408
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: LuxCoreRender v2.3alpha binaries for MacOS

Post by u3dreal » Sat Dec 07, 2019 4:39 pm

Yes my Intel Iris also has some issues i think mainly because of missing RAM since it works on small scenes. :D

Good to know it works !! thanks !
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

epilectrolytics
Donor
Posts: 703
Joined: Thu Oct 04, 2018 6:06 am

Re: LuxCoreRender v2.3alpha binaries for MacOS

Post by epilectrolytics » Sun Dec 08, 2019 12:37 pm

Because this is the News section I'm continuing with issue reports here at the general MacOS thread

User avatar
u3dreal
Developer
Posts: 408
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: LuxCoreRender v2.3alpha binaries for MacOS

Post by u3dreal » Thu Dec 19, 2019 7:27 pm

OK automated builds is working .

get the latest MacOS binaries here https://github.com/LuxCoreRender/LuxCore/releases
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

User avatar
u3dreal
Developer
Posts: 408
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: LuxCoreRender v2.3alpha binaries for MacOS

Post by u3dreal » Fri Dec 27, 2019 4:31 pm

BlendLuxCore osx daily build is also working.

https://github.com/LuxCoreRender/BlendL ... tag/latest

make sure to give denoise a chmod 755.
Somehow this get's introduced again in the packing process on azure on linux. We will find out how.
LuxCoreRender latest does not have this issue. So if you have problems get denoise from there and copy it.

Just do chmod 755 /Users/!you!/Library/Application Support/Blender/YOURBLENDERVERSION/scripts/addons/BlendLuxCore/bin/denoise

in the terminal after installation. !you! is your username of course !

I wonder if someone is using lux on mac now ? Let me know if it works for you !

cheers
u3dreal
Last edited by u3dreal on Fri Apr 10, 2020 9:45 am, edited 1 time in total.
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

Spartacus1
Posts: 1
Joined: Sun Mar 29, 2020 1:16 am

Re: LuxCoreRender v2.3alpha binaries for MacOS

Post by Spartacus1 » Sun Mar 29, 2020 1:19 am

u3dreal, in MacOS the command is missing the version.

For version 2.82 it will be:

chmod 755 /Users/your username/Library/Application\ Support/Blender/2.82/scripts/addons/BlendLuxCore/bin/denoise

Best Regards

User avatar
u3dreal
Developer
Posts: 408
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: LuxCoreRender v2.3alpha binaries for MacOS

Post by u3dreal » Fri Apr 10, 2020 9:44 am

Spartacus1 wrote:
Sun Mar 29, 2020 1:19 am
u3dreal, in MacOS the command is missing the version.

For version 2.82 it will be:

chmod 755 /Users/your username/Library/Application\ Support/Blender/2.82/scripts/addons/BlendLuxCore/bin/denoise

Best Regards
OK thanks for pointing it out. But 2.3 should not work with 2.82 .... due to libs not updated
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

Post Reply