BlendLuxCore Development

Discussion related to the LuxCore functionality, implementations and API.
User avatar
B.Y.O.B.
Developer
Posts: 3981
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: BlendLuxCore Development

Post by B.Y.O.B. » Thu Jan 11, 2018 9:10 pm

neo2068 wrote:
Thu Jan 11, 2018 8:43 pm
BTW, there are missing files for the full render blender test
Look in http://cg.tuwien.ac.at/~zsolnai/luxrend ... stscene.7z

@Dade I'll write a detailed post later.

acasta69
Developer
Posts: 381
Joined: Tue Jan 09, 2018 3:45 pm

Re: BlendLuxCore Development

Post by acasta69 » Fri Jan 12, 2018 1:45 pm

Hi,

in Texture Properties panel everything is empty:

Capture.PNG
Capture.PNG (11.29 KiB) Viewed 3162 times
So for example we cannot define a texture to be used with a modifier (or we can do that by temporarily switching to another render engine).
Is this just still to be done, or am i missing something about the new interface? I did not find a way to do that in the nodes editor.
(If this is just a dumb question due to not knowing Blender enough, please accept my apologies... :oops: )
Support LuxCoreRender project with salts and bounties

Windows 10 64 bits, i7-4770 3.4 GHz, RAM 16 GB, GTX 970 4GB v445.87

User avatar
Sharlybg
Donor
Posts: 2574
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: BlendLuxCore Development

Post by Sharlybg » Fri Jan 12, 2018 3:50 pm

acasta69 wrote:
Fri Jan 12, 2018 1:45 pm
Hi,

in Texture Properties panel everything is empty:


Capture.PNG

So for example we cannot define a texture to be used with a modifier (or we can do that by temporarily switching to another render engine).
Is this just still to be done, or am i missing something about the new interface? I did not find a way to do that in the nodes editor.
(If this is just a dumb question due to not knowing Blender enough, please accept my apologies... :oops: )
Maybe it is related to the fact that the new blendluxcore addon will allow only one material system : node tree shader.

A question for you BYOB.
Do you think new fix in blender 2.79a will solve the limitation we had in the past about color ramp implementation for luxcore ?
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
B.Y.O.B.
Developer
Posts: 3981
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: BlendLuxCore Development

Post by B.Y.O.B. » Fri Jan 12, 2018 4:10 pm

acasta69 wrote:
Fri Jan 12, 2018 1:45 pm
in Texture Properties panel everything is empty:
It's something I did not yet get around to, will come eventually.
You can create an issue on BlendLuxCore's github repo so I don't forget about it.
Sharlybg wrote:
Fri Jan 12, 2018 3:50 pm
Do you think new fix in blender 2.79a will solve the limitation we had in the past about color ramp implementation for luxcore ?
I don't think so.
We can now create real links to datablocks, but we still can not create many datablocks in Python. I think color ramps are as far away as before.

User avatar
Dade
Developer
Posts: 4977
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: BlendLuxCore Development

Post by Dade » Fri Jan 12, 2018 6:47 pm

Dade wrote:
Thu Jan 11, 2018 7:55 pm
B.Y.O.B. wrote:
Thu Jan 11, 2018 7:48 pm
Wasted a few more hours on camera motion blur. Super frustrating, still does not work.
What is not working ? I mean, do you get unexpected results out of LuxCore or Blender ?
I noticed today that all motion blur transformations are global2local and not local2global like the instance transformations. This was required for compatibility with old Lux.

I have aligned motion blur with instances and they now work accepting the some type of transformation (NOTE: this breaks the compatibility with the past for motion blur).

Was this the source of some confusion ?
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Posts: 3981
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: BlendLuxCore Development

Post by B.Y.O.B. » Fri Jan 12, 2018 6:53 pm

This means that we no longer have to invert object matrices for the "motion.x.transformation" props, right?

User avatar
Dade
Developer
Posts: 4977
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: BlendLuxCore Development

Post by Dade » Fri Jan 12, 2018 8:58 pm

B.Y.O.B. wrote:
Fri Jan 12, 2018 6:53 pm
This means that we no longer have to invert object matrices for the "motion.x.transformation" props, right?
Yes, exactly.
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Posts: 3981
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: BlendLuxCore Development

Post by B.Y.O.B. » Sat Jan 13, 2018 11:47 pm

Dade wrote:
Thu Jan 11, 2018 7:55 pm
What is not working ? I mean, do you get unexpected results out of LuxCore or Blender ?
I'll start with camera motion blur (only the camera is moving, all objects are stationary).
My plan was to do motion blur like the default Cycles mode for now, which is called "center on frame".
Basically we say that the current frame is time 0.0 and we have the shutter time, e.g. 1.0 second. Then the start time would be -shutter / 2 and the end time would be shutter / 2.

... looking at my own comments ("# TODO why does this not work as expected?", "# TODO: seems like this is not needed - why?" and the like) I realized that I'm doing exactly what I'm warning against here: https://github.com/LuxCoreRender/BlendL ... pi_tips.md
I "deleted" the original camera properties because I set the "scene.camera.motion.*" properties after I define the camera...

Fixing this and then we'll see if I still struggle.
Already got some nice glitch art because of some wrong matrices:
Attachments
untitled.png

User avatar
B.Y.O.B.
Developer
Posts: 3981
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: BlendLuxCore Development

Post by B.Y.O.B. » Sat Jan 13, 2018 11:56 pm

Ok, now it's working a lot better.
I found out that I have to invert the camera matrix.

However, something weird is still going on - do you have an idea what could be wrong?
Only the camera is moving here.
Attachments
no_blur.png
with camera blur
with camera blur
FILESAVER.zip
luxcore scene
(491.77 KiB) Downloaded 117 times
no_blur.jpg
with_blur.jpg
FILESAVER.zip
(491.77 KiB) Downloaded 106 times

User avatar
B.Y.O.B.
Developer
Posts: 3981
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: BlendLuxCore Development

Post by B.Y.O.B. » Sun Jan 14, 2018 12:13 am

Also tested with only positive time values, image looks exactly the same.
I guess if I had a debug build the assertions would already explode in my face, looks like a lot of Nans.

sorry about the double attachments by the way, the forum keeps deleting them when I try to correct it, so I won't touch them anymore.

Post Reply