Discussion related to the Engine functionality, implementations and API.
Posts: 229
Joined: Tue Dec 11, 2018 12:38 pm
Location: Germany

Re: OpenImageDenoise

Post by CodeHD » Tue Mar 03, 2020 10:14 am

How about calling it "Mix (with) Undenoised" in Blender? I would think if a user selects a denoiser, he expects a denoised image by default. Hence name it something that explicitly states how it deviates from pure denoised image.

In LuxCore itself (the parameter Dade mentions) could just be "mix" for simplicity?

User avatar
Posts: 3344
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany

Re: OpenImageDenoise

Post by B.Y.O.B. » Tue Mar 03, 2020 10:22 am

For consistency's sake, I would call the property "amount".
This is how a simple lerp is called in the mix texture, mix material etc.
In Blender, lerps are called "fac" everywhere, which is probably short for "factor".

However we call it, I think (almost) every imagepipeline plugin should have this parameter, to make it easier to control the strength of it.

Posts: 107
Joined: Thu Jan 02, 2020 6:23 pm

Re: OpenImageDenoise

Post by juangea » Tue Mar 03, 2020 10:42 am

Yep, in Blender Fac. is Factor.

And "amount" could be fine if it has consistency with the rest of the UI, as long as the effect of this parameter is properly explained in the documentation there shouldn`t be any problem I think :)

Post Reply