Network Render

Discussion related to the Engine functionality, implementations and API.
acasta69
Developer
Posts: 253
Joined: Tue Jan 09, 2018 3:45 pm

Re: Network Render

Post by acasta69 » Wed Feb 19, 2020 6:13 pm

mib2berlin wrote:
Tue Feb 18, 2020 12:51 am
EDIT: Got not exactly the same errors:

Code: Select all

C:\Users\pepo\Downloads\blender-2.82-windows64\2.82\scripts\addons\BlendLuxCore\bin>python pyluxcoretools.zip netnodeui
ImportError: numpy.core.multiarray failed to import
ImportError: numpy.core.umath failed to import
Traceback (most recent call last):
  File "C:\Users\pepo\AppData\Local\Programs\Python\Python37\lib\runpy.py", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "C:\Users\pepo\AppData\Local\Programs\Python\Python37\lib\runpy.py", line 85, in _run_code
    exec(code, run_globals)
  File "pyluxcoretools.zip\__main__.py", line 71, in <module>
  File "pyluxcoretools.zip\pyluxcoretools\pyluxcorenetnode\ui.py", line 144, in main
  File "pyluxcoretools.zip\pyluxcoretools\pyluxcorenetnode\ui.py", line 135, in ui
  File "pyluxcoretools.zip\pyluxcoretools\pyluxcorenetnode\ui.py", line 46, in __init__
  File "pyluxcoretools.zip\pyluxcoretools\pyluxcorenetnode\mainwindow.py", line 196, in setupUi
AttributeError: 'PySide2.QtWidgets.QAction' object has no attribute 'activated'
The error shown in the last line should be solved in the "latest" release being built right now.

Regarding the numpy errors, have you installed numpy on your system?
You can do that with:

Code: Select all

pip install numpy
Support LuxCoreRender project with salts and bounties

Windows 10 64 bits, i7-4770 3.4 GHz, RAM 16 GB, GTX 970 4GB v382.05

mib2berlin
Posts: 23
Joined: Fri Apr 06, 2018 6:29 pm

Re: Network Render

Post by mib2berlin » Mon Feb 24, 2020 7:20 pm

Hi, had some time to test latest luxcore from git and after install numpy the render node is starting on my second Windows system.
Seams fixed now.

Thank you for the help, mib

Post Reply