Compile on MacOS 10.13

Discussion related to the LuxCore functionality, implementations and API.
User avatar
u3dreal
Developer
Posts: 424
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS 10.13

Post by u3dreal » Sun Dec 08, 2019 5:18 pm

Both .... iwas able to get rid of the error with using jpgv8d now all seems fine

Just uploading a new version build with jpgv8d.
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom RX 5700 - Catalina / High Sierra, Windows 10, Ubuntu 18.04

User avatar
u3dreal
Developer
Posts: 424
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS 10.13

Post by u3dreal » Sun Dec 08, 2019 5:45 pm

check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom RX 5700 - Catalina / High Sierra, Windows 10, Ubuntu 18.04

epilectrolytics
Donor
Posts: 703
Joined: Thu Oct 04, 2018 6:06 am

Re: Compile on MacOS 10.13

Post by epilectrolytics » Sun Dec 08, 2019 6:07 pm

I'm getting an installation error:

Code: Select all

Modules Installed (BlendLuxCore) from '/Users/me/Desktop/BlendLuxCore2.3alpha0_jpgv8_osx.zip' into '/Users/me/Library/Application Support/Blender/2.81/scripts/addons'
Traceback (most recent call last):
  File "/Applications/Renderer/Blender.app/Contents/Resources/2.81/scripts/modules/addon_utils.py", line 351, in enable
    mod = __import__(module_name)
  File "/Users/me/Library/Application Support/Blender/2.81/scripts/addons/BlendLuxCore/__init__.py", line 23, in <module>
    raise Exception(msg + "\n\nImportError: %s" % error) from None
Exception: 

Could not import pyluxcore.

ImportError: dlopen(/Users/me/Library/Application Support/Blender/2.81/scripts/addons/BlendLuxCore/bin/pyluxcore.so, 2): Library not loaded: @loader_path/lib/libtbb.dylib
  Referenced from: /Users/me/Library/Application Support/Blender/2.81/scripts/addons/BlendLuxCore/bin/lib/libembree3.3.dylib
  Reason: image not found

User avatar
u3dreal
Developer
Posts: 424
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS 10.13

Post by u3dreal » Sun Dec 08, 2019 6:39 pm

Oh ... guess i should have checked with the other mac. Looks like @loader_path does not work with subdirs .... fixed ... one sec i'll reupload.

LuxCoreui should work fine. Does it ?

OK fixed .. same link
Last edited by u3dreal on Sun Dec 08, 2019 6:54 pm, edited 1 time in total.
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom RX 5700 - Catalina / High Sierra, Windows 10, Ubuntu 18.04

epilectrolytics
Donor
Posts: 703
Joined: Thu Oct 04, 2018 6:06 am

Re: Compile on MacOS 10.13

Post by epilectrolytics » Sun Dec 08, 2019 6:46 pm

yep, LuxCore.app works 8-)

User avatar
u3dreal
Developer
Posts: 424
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS 10.13

Post by u3dreal » Sun Dec 08, 2019 6:54 pm

Last edited by u3dreal on Sun Dec 15, 2019 4:58 pm, edited 1 time in total.
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom RX 5700 - Catalina / High Sierra, Windows 10, Ubuntu 18.04

epilectrolytics
Donor
Posts: 703
Joined: Thu Oct 04, 2018 6:06 am

Re: Compile on MacOS 10.13

Post by epilectrolytics » Sun Dec 08, 2019 7:10 pm

Great job mate!

Benchmark scene (PathCPU) opens and renders in Blender!
Danish mood was crashing, will test further.

Thanks again for making this possible!

User avatar
u3dreal
Developer
Posts: 424
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS 10.13

Post by u3dreal » Sun Dec 08, 2019 7:12 pm

danish mood crahses here as well with ocl CPU enabled

Code: Select all

[LuxCore][621.028] [PathOCLBaseRenderThread::0] Compiling AdvancePaths_MK_DL_ILLUMINATE Kernel
[LuxCore][621.028] [PathOCLBaseRenderThread::0] Compiling AdvancePaths_MK_DL_SAMPLE_BSDF Kernel
[LuxCore][621.028] [PathOCLBaseRenderThread::0] Compiling AdvancePaths_MK_GENERATE_NEXT_VERTEX_RAY Kernel
[LuxCore][621.028] [PathOCLBaseRenderThread::0] Compiling AdvancePaths_MK_SPLAT_SAMPLE Kernel
[LuxCore][621.028] [PathOCLBaseRenderThread::0] Compiling AdvancePaths_MK_NEXT_SAMPLE Kernel
[LuxCore][621.028] [PathOCLBaseRenderThread::0] Compiling AdvancePaths_MK_GENERATE_CAMERA_RAY Kernel
[LuxCore][621.028] [PathOCLBaseRenderThread::0] Kernels compilation time: 36ms
[LuxCore][621.040] Starting 8 native render threads
Assertion failed: (!bsdfSample.IsNaN() && !bsdfSample.IsInf() && !bsdfSample.IsNeg()), function RenderEyePath, file /Users/drquader/Documents/GitHub/LuxCore/src/slg/engines/pathtracer.cpp, line 554.
Abort trap: 6
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom RX 5700 - Catalina / High Sierra, Windows 10, Ubuntu 18.04

epilectrolytics
Donor
Posts: 703
Joined: Thu Oct 04, 2018 6:06 am

Re: Compile on MacOS 10.13

Post by epilectrolytics » Sun Dec 08, 2019 7:23 pm

Lol I was just zipping the crashlog but you beat me to it :lol:
Benchmark scene renders fine with GT750M OCL.
Also this beauty here works well.

User avatar
u3dreal
Developer
Posts: 424
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS 10.13

Post by u3dreal » Sun Dec 08, 2019 9:08 pm

Does it work with opencl GPU enabled ???

OK now it works on the pool scene ... strange.
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MB Pro i7 2.3Ghz, IrisPro 1.5GB, GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom RX 5700 - Catalina / High Sierra, Windows 10, Ubuntu 18.04

Post Reply