Compile on MacOS 10.13

Discussion related to the Engine functionality, implementations and API.
User avatar
u3dreal
Developer
Posts: 164
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS 10.13

Post by u3dreal » Sat Dec 07, 2019 2:04 pm

Yeah that makes sense. The alpha is pretty stable anyway.

I wonder if it would be possible just to use libs installed with brew now that we figured out that static linking :)
or does Lux need exact lib versions to work ?

Oh and on the LuCore 2.1 test scene i get an error of jpg beeing too new. version 90 expected 80 . Could this be an old
jpg version in the macoscompile git ? v9b i guess ... that should not be too old ... well 2 years .. should i update to v9c ?

Does anyone know how to fix the permissions issue with the denoise executable ?
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MacBook Pro 2013 i7 2.3Ghz, Intel IrisPro 1.5GB, Nvidia GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

User avatar
Dade
Developer
Posts: 3570
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Compile on MacOS 10.13

Post by Dade » Sat Dec 07, 2019 3:51 pm

u3dreal wrote:
Sat Dec 07, 2019 2:04 pm
I wonder if it would be possible just to use libs installed with brew now that we figured out that static linking :)
or does Lux need exact lib versions to work ?
Most of the times, yes, you need the exact version otherwise you can experience a lot of subtle and unknown problems compared to the other 2 platforms (Linux+Windows).
u3dreal wrote:
Sat Dec 07, 2019 2:04 pm
Does anyone know how to fix the permissions issue with the denoise executable ?
If you use tar instead of zip, it will save file "read/write/execute bits.
Support LuxCoreRender project with salts and bounties

User avatar
u3dreal
Developer
Posts: 164
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS 10.13

Post by u3dreal » Sat Dec 07, 2019 4:43 pm

If you use tar instead of zip, it will save file "read/write/execute bits.
good to know i'll try

So all the dependnecies in MacOsCompile repo are up-to-date now ??

And yes should i commit the changes made ? Review someone :)
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MacBook Pro 2013 i7 2.3Ghz, Intel IrisPro 1.5GB, Nvidia GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

User avatar
Dade
Developer
Posts: 3570
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Compile on MacOS 10.13

Post by Dade » Sat Dec 07, 2019 6:17 pm

u3dreal wrote:
Sat Dec 07, 2019 4:43 pm
So all the dependnecies in MacOsCompile repo are up-to-date now ??
I have no idea :mrgreen:
u3dreal wrote:
Sat Dec 07, 2019 4:43 pm
And yes should i commit the changes made ? Review someone :)
You can use GitHub pull request process to submit any change to the repository :idea:
Support LuxCoreRender project with salts and bounties

User avatar
u3dreal
Developer
Posts: 164
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS 10.13

Post by u3dreal » Sat Dec 07, 2019 6:55 pm

Sorry i don't get it. I have cloned the lux repo and now i would like to push not pull .. :D maybe got that wrong

guess not anyone can push to the repo :)

Never done that. I would like to commit these changes.

or will i have to make a new branch ??
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MacBook Pro 2013 i7 2.3Ghz, Intel IrisPro 1.5GB, Nvidia GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

User avatar
Dade
Developer
Posts: 3570
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Compile on MacOS 10.13

Post by Dade » Sat Dec 07, 2019 9:40 pm

It is explained here: https://help.github.com/en/github/colla ... l-requests

You clone the repository on GitHub so you have your own copy, you create a branch with all your patches and submit a "pull request".

It is a method so anyone can submit patches to an "official" repository.
Support LuxCoreRender project with salts and bounties

User avatar
u3dreal
Developer
Posts: 164
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS 10.13

Post by u3dreal » Sat Dec 07, 2019 9:50 pm

OK lets see --... i'll check the build_deps script once more and then i'll push Macosdeps repo first
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MacBook Pro 2013 i7 2.3Ghz, Intel IrisPro 1.5GB, Nvidia GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

User avatar
u3dreal
Developer
Posts: 164
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS 10.13

Post by u3dreal » Sun Dec 08, 2019 12:49 am

OK now there should be a pull request for MacOSCompileDeps
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MacBook Pro 2013 i7 2.3Ghz, Intel IrisPro 1.5GB, Nvidia GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

User avatar
u3dreal
Developer
Posts: 164
Joined: Tue Dec 03, 2019 3:23 pm
Location: Ulm
Contact:

Re: Compile on MacOS 10.13

Post by u3dreal » Sun Dec 08, 2019 3:48 pm

I'm still investigating the jpg error.

Code: Select all

Error opening image file : /var/folders/zh/g9zxh0gs09v2j_tfw8by4v0r0000gn/T/tmp78a0ujo3.jpg (error = JPEG error: Wrong JPEG library version: library is 90, caller expects 80 ("/var/folders/zh/g9zxh0gs09v2j_tfw8by4v0r0000gn/T/tmp78a0ujo3.jpg"))
could it be the lib is tooo new ??? v9b was is the mac repo v3c bringst the same error and in the linux repo i can find version v6?

Strange....
check out my newest stuff http://q3de.com/research/
portfolio http://q3de.com/


MacBook Pro 2013 i7 2.3Ghz, Intel IrisPro 1.5GB, Nvidia GTX750m 2GB - High Sierra
Xeon X5650@4Ghz, 2x GTX 770 Phantom - High Sierra, Windows 10, Ubuntu 18.04

User avatar
Dade
Developer
Posts: 3570
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: Compile on MacOS 10.13

Post by Dade » Sun Dec 08, 2019 5:13 pm

Are you having this problem inside Blender and/or with LuxCoreUI ?
Support LuxCoreRender project with salts and bounties

Post Reply