A baking test scene

Discussion related to the LuxCore functionality, implementations and API.
User avatar
Dade
Developer
Posts: 4717
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: A baking test scene

Post by Dade » Sun Dec 15, 2019 2:39 pm

The very first scene baked and exported in glTF format from LuxCoreRender: https://skfb.ly/6PvFR

This stuff is damn cool :!:
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Posts: 3799
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: A baking test scene

Post by B.Y.O.B. » Sun Dec 15, 2019 2:43 pm

Neat!
The blue cube seems to have some self-shadowing issue, is that a problem in the baked map or is it a bug in the viewer?
Attachments
Capture.PNG

User avatar
Dade
Developer
Posts: 4717
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: A baking test scene

Post by Dade » Sun Dec 15, 2019 5:21 pm

B.Y.O.B. wrote:
Sun Dec 15, 2019 2:43 pm
Neat!
The blue cube seems to have some self-shadowing issue, is that a problem in the baked map or is it a bug in the viewer?
It is just a wrong UV map, I fixed only the white cube (there is only one "-fixed" .ply file at https://github.com/LuxCoreRender/LuxCor ... cenes/bake).
Support LuxCoreRender project with salts and bounties

User avatar
Dade
Developer
Posts: 4717
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: A baking test scene

Post by Dade » Mon Dec 16, 2019 9:57 am

Dade wrote:
Sun Dec 15, 2019 5:21 pm
B.Y.O.B. wrote:
Sun Dec 15, 2019 2:43 pm
Neat!
The blue cube seems to have some self-shadowing issue, is that a problem in the baked map or is it a bug in the viewer?
It is just a wrong UV map, I fixed only the white cube (there is only one "-fixed" .ply file at https://github.com/LuxCoreRender/LuxCor ... cenes/bake).
Fixed/updated the UV maps: https://skfb.ly/6PvFR

A comparison between the original rendering in LuxCore and the baked and exported result in SketchFab:

bake.jpg
Support LuxCoreRender project with salts and bounties

Racleborg
Posts: 611
Joined: Sat Apr 07, 2018 10:31 am
Location: UK

Re: A baking test scene

Post by Racleborg » Mon Dec 16, 2019 11:22 am

8-)

Racleborg
Posts: 611
Joined: Sat Apr 07, 2018 10:31 am
Location: UK

Re: A baking test scene

Post by Racleborg » Mon Dec 16, 2019 2:45 pm

by epilectrolytics » Fri Dec 13, 2019 2:30 pm
You could put a glass vase on the mantel and test if it already catches caustics!
So I’m working on baking caustics but even though I can get some quite dramatic one in the preview the're not rendering. Could you please tell me what I'm doing wrong? Thank you

Attached are images and link to file:


https://1drv.ms/u/s!AhdwgLaw01tLpwY7HHh ... 0?e=GljwMU
Attachments
caustics in preview.jpg
not in render.jpg

User avatar
Dade
Developer
Posts: 4717
Joined: Mon Dec 04, 2017 8:36 pm
Location: Italy

Re: A baking test scene

Post by Dade » Mon Dec 16, 2019 3:59 pm

Racleborg wrote:
Mon Dec 16, 2019 2:45 pm
So I’m working on baking caustics but even though I can get some quite dramatic one in the preview the're not rendering. Could you please tell me what I'm doing wrong? Thank you
I haven't yet added the support for light tracing to BAKECPU :!:
Support LuxCoreRender project with salts and bounties

epilectrolytics
Donor
Posts: 703
Joined: Thu Oct 04, 2018 6:06 am

Re: A baking test scene

Post by epilectrolytics » Mon Dec 16, 2019 4:01 pm

Would it work with BiDir or PathCPU metro?

Racleborg
Posts: 611
Joined: Sat Apr 07, 2018 10:31 am
Location: UK

Re: A baking test scene

Post by Racleborg » Mon Dec 16, 2019 4:05 pm

by Dade » Mon Dec 16, 2019 3:59 pm
Racleborg wrote: ↑
Mon Dec 16, 2019 2:45 pm
So I’m working on baking caustics but even though I can get some quite dramatic one in the preview the're not rendering. Could you please tell me what I'm doing wrong? Thank you
I haven't yet added the support for light tracing to BAKECPU
Ok, but this was before attempting the bake process. This is just the preview in Blender (showing caustics) then an attempt to render it (NOT showing caustics). In fact it appears to show the caustics intermittently in the preview as well, even though I'm not aware of making any changes. :?

Does my setup look correct to acheive caustics? Here: https://1drv.ms/u/s!AhdwgLaw01tLpwY7HHh ... 0?e=GljwMU

Thanks

epilectrolytics
Donor
Posts: 703
Joined: Thu Oct 04, 2018 6:06 am

Re: A baking test scene

Post by epilectrolytics » Mon Dec 16, 2019 4:09 pm

Racleborg wrote:
Mon Dec 16, 2019 2:45 pm
So I’m working on baking caustics but even though I can get some quite dramatic one in the preview the're not rendering. Could you please tell me what I'm doing wrong? Thank you
I have not yet looked into baking via LuxCoreUI, if caustics are not yet implemented it will not work.
While the second image looks like correct caustics the first one shows apparently the light trace brightness issue that I have reported repeatedly in the respective thread.

This is really very interesting stuff, thanks for your relentless testing!

Post Reply