Disney BRDF material

Discussion related to the Engine functionality, implementations and API.
User avatar
Sharlybg
Donor
Donor
Posts: 1325
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Disney BRDF material

Post by Sharlybg » Mon Jun 10, 2019 1:21 pm

B.Y.O.B. wrote:
Fri Jun 07, 2019 3:03 pm
Yup, you need the 2.79 branch:
https://github.com/LuxCoreRender/BlendL ... aintenance
I've downloaded this file (by clicking on on download or clone) then unzip file on my addon folder. and i've downloaded https://github.com/LuxCoreRender/LuxCor ... tag/latest opencl 64.


And then copy all file in lastest luxcore in the bin folder of "BlendLuxCore-2.79_maintenance" in my blender addon folder. but nothing appear in the blender preference addon so i can enable or not.

Can someone with a windows Sys send me it own blendluxcore (with lastest source) folder zipped ?
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
B.Y.O.B.
Developer
Developer
Posts: 2648
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Disney BRDF material

Post by B.Y.O.B. » Mon Jun 10, 2019 1:33 pm

Weird, your procedure sounds correct.
Did you restart Blender before you opened the user preferences?

Did you put it in the same addon folder as your existing BlendLuxCore folder?
Should be in %appdata%/local/roaming/blender foundation/2.79/scripts/addons (or so)
Support LuxCoreRender project with salts and bounties

User avatar
Sharlybg
Donor
Donor
Posts: 1325
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Disney BRDF material

Post by Sharlybg » Mon Jun 10, 2019 1:39 pm

B.Y.O.B. wrote:
Mon Jun 10, 2019 1:33 pm
Weird, your procedure sounds correct.
Did you restart Blender before you opened the user preferences?

Did you put it in the same addon folder as your existing BlendLuxCore folder?
Should be in %appdata%/local/roaming/blender foundation/2.79/scripts/addons (or so)
YES but this is it :
folder.jpg
Addon.jpg
And strangely the same procedure with blendluxcore- master (not maintenance) work as expected.
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
B.Y.O.B.
Developer
Developer
Posts: 2648
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Disney BRDF material

Post by B.Y.O.B. » Mon Jun 10, 2019 2:01 pm

Try to rename the folder to something like "BlendLuxCore279", without special characters, maybe Blender doesn't like that.
Support LuxCoreRender project with salts and bounties

User avatar
Sharlybg
Donor
Donor
Posts: 1325
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: Disney BRDF material

Post by Sharlybg » Mon Jun 10, 2019 2:05 pm

B.Y.O.B. wrote:
Mon Jun 10, 2019 2:01 pm
Try to rename the folder to something like "BlendLuxCore279", without special characters, maybe Blender doesn't like that.
You know what ?

you save me again ;)
luxc.jpg
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
epilectrolytics
Donor
Donor
Posts: 371
Joined: Thu Oct 04, 2018 6:06 am

Disney shader problem

Post by epilectrolytics » Mon Jun 10, 2019 2:37 pm

After successfully implementing the new Disney shader into several old projects, today it failed for the first time.
In the old classroom scene from the Lux master repo the Disney shader doesn't work with the chrome material for the metal parts.
Some parts appear normal, some have wrong roughness, some are black with some specularity and the rest is totally black.
When I switch back to the metal node everything renders correctly.
All other materials (except translucent lampshades) also have been ported to Disney but work fine.
:?:
Screenshot.jpg
SLGclassroomLuxCoreAnimD.blend.7z
(2.98 MiB) Downloaded 4 times
MBPro 15" 16GB i7-4850HQ GT750M, MacOS 10.13.6 & Win10Pro PC 16GB Ryzen 2700X, RTX 2070, GTX 1060

User avatar
Dade
Developer
Developer
Posts: 2488
Joined: Mon Dec 04, 2017 8:36 pm

Re: Disney BRDF material

Post by Dade » Mon Jun 10, 2019 3:25 pm

B.Y.O.B. wrote:
Sat Jun 08, 2019 1:27 pm
Dade wrote:
Sat Jun 08, 2019 1:15 pm
I don't remember how it is supposed to work but it is likely to be a bug however try also to check another implementation like the Cycles one to see if the behavior matches or not.
In Cycles it looks the same on front and back faces.
Disney material is now double side.
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Developer
Posts: 2648
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Disney BRDF material

Post by B.Y.O.B. » Mon Jun 10, 2019 3:44 pm

epilectrolytics wrote:
Mon Jun 10, 2019 2:37 pm
After successfully implementing the new Disney shader into several old projects, today it failed for the first time.
In the old classroom scene from the Lux master repo the Disney shader doesn't work with the chrome material for the metal parts.
Some parts appear normal, some have wrong roughness, some are black with some specularity and the rest is totally black.
When I switch back to the metal node everything renders correctly.
Can you test again when the latest commit by Dade is built?
The black parts were caused by the single-sidedness of the shader (they have inverted normals).
Support LuxCoreRender project with salts and bounties

User avatar
epilectrolytics
Donor
Donor
Posts: 371
Joined: Thu Oct 04, 2018 6:06 am

Re: Disney BRDF material

Post by epilectrolytics » Mon Jun 10, 2019 3:52 pm

Thanks for looking into it!
I just reloaded the scene and flipped the normals of the mesh but still renders black :?:

The latest commit is currently built on Azure and I will test when it is available.
MBPro 15" 16GB i7-4850HQ GT750M, MacOS 10.13.6 & Win10Pro PC 16GB Ryzen 2700X, RTX 2070, GTX 1060

User avatar
epilectrolytics
Donor
Donor
Posts: 371
Joined: Thu Oct 04, 2018 6:06 am

Re: Disney BRDF material

Post by epilectrolytics » Mon Jun 10, 2019 6:39 pm

Dade wrote:
Mon Jun 10, 2019 3:25 pm
Disney material is now double side.
B.Y.O.B. wrote:
Mon Jun 10, 2019 3:44 pm
Can you test again when the latest commit by Dade is built?
Yep, it works (again)!

Thanks for the quick fix!

👍
MBPro 15" 16GB i7-4850HQ GT750M, MacOS 10.13.6 & Win10Pro PC 16GB Ryzen 2700X, RTX 2070, GTX 1060

Post Reply