Ply ASCII

Use this forum for general user support and related questions.
User avatar
nigec
Posts: 140
Joined: Mon Mar 11, 2019 8:50 am

Re: Ply ASCII

Post by nigec » Tue Mar 19, 2019 3:35 pm

The camera part of the LXS seems to be totally ignored if I run it in luxcoreui, everything else seems fine, the scene has models and texture
I thought it was maybe FOV but that appears right, rendering the camera is lower and very close

I was going to have a play tonight and see why this is happening

User avatar
Dade
Developer
Developer
Posts: 2770
Joined: Mon Dec 04, 2017 8:36 pm

Re: Ply ASCII

Post by Dade » Tue Mar 19, 2019 4:00 pm

nigec wrote:
Tue Mar 19, 2019 3:35 pm
The camera part of the LXS seems to be totally ignored if I run it in luxcoreui, everything else seems fine, the scene has models and texture
I thought it was maybe FOV but that appears right, rendering the camera is lower and very close
The code to parser the LXS is there: https://github.com/LuxCoreRender/LuxCor ... rse.y#L891

So it is probably something related to the way the script export the camera, if you post an example, I can extend the parsing code to support the format used by the script.
Support LuxCoreRender project with salts and bounties

User avatar
nigec
Posts: 140
Joined: Mon Mar 11, 2019 8:50 am

Re: Ply ASCII

Post by nigec » Tue Mar 19, 2019 5:06 pm

The plugin is doing a lot of strange things, its actually the models moving
Sketchup puts the axis at the corner of the model and both models are moving to line up on the corner edge. I tried to set the axis and now I'm not getting materials (its not exporting them)
The plugin is very temptamental, I think it needs re working to export scn and cfg files
I'm going to try a few more things, if I have no luck I might ask some of the Sketchup guys if they can help

User avatar
nigec
Posts: 140
Joined: Mon Mar 11, 2019 8:50 am

Re: Ply ASCII

Post by nigec » Tue Mar 19, 2019 5:20 pm

here's the file, I've set the axis at the bottom center of both meshes, there is no textures but Sketchup exports textures that aren't applied and lists them is the lxm
It renders fine in Luxrender
Attachments
luxtest.zip
(9.38 KiB) Downloaded 15 times

User avatar
nigec
Posts: 140
Joined: Mon Mar 11, 2019 8:50 am

Re: Ply ASCII

Post by nigec » Tue Mar 19, 2019 5:48 pm

if I ungroup the objects it then works, that's not a practical solution that's going to cause some really horrible geometry
Attachments
luxtest_works.zip
(14 KiB) Downloaded 15 times
yeah.jpg

User avatar
Dade
Developer
Developer
Posts: 2770
Joined: Mon Dec 04, 2017 8:36 pm

Re: Ply ASCII

Post by Dade » Wed Mar 20, 2019 10:28 am

nigec wrote:
Tue Mar 19, 2019 5:48 pm
if I ungroup the objects it then works, that's not a practical solution that's going to cause some really horrible geometry
I need a test scene showing the problem and an explanation/screenshot of how it should render instead. I have downloaded the latest scene you posted but it renders fine, the previous one, it is just black. How should it looks ? Is it the camera problem or the object problem you were talking about ?
Support LuxCoreRender project with salts and bounties

User avatar
nigec
Posts: 140
Joined: Mon Mar 11, 2019 8:50 am

Re: Ply ASCII

Post by nigec » Wed Mar 20, 2019 10:43 am

This example you can see the model, I think the first example the camera was inside the mesh
As you can see the top cube has moved to the edge of bottom one, also the camera will start off at the edge of the bottom mesh
The picture I've moved the camera so its more obvious
In this example the meshes are grouped with the axis were Sketchup puts them
Attachments
luxtest2.zip
(18.93 KiB) Downloaded 14 times
Untitled.jpg

User avatar
Dade
Developer
Developer
Posts: 2770
Joined: Mon Dec 04, 2017 8:36 pm

Re: Ply ASCII

Post by Dade » Thu Mar 21, 2019 5:38 pm

I have added the support of old LXS way to define instances and now the scene you posted seems to work fine:

lxs.jpg
Support LuxCoreRender project with salts and bounties

User avatar
nigec
Posts: 140
Joined: Mon Mar 11, 2019 8:50 am

Re: Ply ASCII

Post by nigec » Fri Mar 22, 2019 7:27 am

Awesome Thanks :)

I'm just doing a scene I hope will test it.. loads of groups lol

Post Reply