Network Render time out

Use this forum for general user support and related questions.
Post Reply
lighting_freak
Posts: 109
Joined: Thu Jan 18, 2018 6:02 pm

Network Render time out

Post by lighting_freak » Sun Nov 25, 2018 12:50 pm

Hi,

I'm continuing testing network rendering.

After running console and single node on a single machine this message appears in console:

Code: Select all

LuxCore 2.1beta2
NetBeaconReceiver thread started.
Discovered new node: 192.168.188.23:18018
Discovered new node: 192.168.188.25:18018
Creating single image render farm job: C:/Users/Martin/Desktop/Job/material_test__LuxCore/00001.bcf
New render farm job: C:/Users/Martin/Desktop/Job/material_test__LuxCore/00001.bcf
Job file md5: 5900a89effc82fa1661aeaba3e16e766
-------------------------------------------------------
Job started: C:/Users/Martin/Desktop/Job/material_test__LuxCore/00001.bcf
-------------------------------------------------------
Node thread started
Node thread started
Film merge thread started
Remote node has the same pyluxcore verison
Sending file: C:/Users/Martin/Desktop/Job/material_test__LuxCore/00001.bcf
Transfered 70.66 Mbytes in 00:00:00 (160.59 Mbytes/sec)
Sending seed: 2
Waiting for node rendering start
timed out
Traceback (most recent call last):
  File "C:\Users\Martin\AppData\Local\Temp\_MEI69922\pyluxcoretools.zip\pyluxcoretools\renderfarm\renderfarmjobsingleimage.py", line 393, in NodeThread
    nodeSocket.connect((self.renderFarmNode.address, self.renderFarmNode.port))
socket.timeout: timed out
Node thread done
At the same time this in node window:

Code: Select all

LuxCore 2.1beta2
Waiting for configuration...
Started
NetBeaconSender thread started.
Waiting for a new connection
Received connection from: ('192.168.188.25', 49923)
Remote pyluxcore version: 2.1beta2
Local pyluxcore version: 2.1beta2
Receiving RenderConfig serialized file: renderfarmnode-e285a2ce-8c6d-48c5-ac31-9b0fb12e3924.bcf
Receiving file: renderfarmnode-e285a2ce-8c6d-48c5-ac31-9b0fb12e3924.bcf
Transfered 70.66 Mbytes in 00:00:00 (160.59 Mbytes/sec)
Receiving RenderConfig serialized MD5: 5900a89effc82fa1661aeaba3e16e766
Received seed: 2
Reading RenderConfig serialized file: renderfarmnode-e285a2ce-8c6d-48c5-ac31-9b0fb12e3924.bcf
[SDL][101.728] Loading serialized mesh: Mesh-Mesh_Glass_Outer_236511528000
[SDL][101.728] Loading serialized mesh: Mesh-Mesh_Glass_Trans_236513016000
[SDL][101.791] Loading serialized mesh: Mesh-Mesh_Glass_Inner_236510040000
[SDL][101.994] Loading serialized mesh: Mesh-Mesh_Screw_236533848000
[SDL][101.994] Loading serialized mesh: Mesh-Mesh_Tube__top_298642776000
[SDL][102.009] Loading serialized mesh: Mesh-Curve_Post__1_236530872000
[SDL][102.009] Loading serialized mesh: Mesh-Curve_Post__2_236532360000
[SDL][102.009] Loading serialized mesh: Mesh-Curve_Support__1_236535336000
[SDL][102.009] Loading serialized mesh: Mesh-Curve_Support__2_298639800000
[SDL][102.009] Loading serialized mesh: Mesh-Mesh_Filament_236508552000
[SDL][102.009] Loading serialized mesh: Mesh-Mesh_Top__tube_298641288000
[SDL][102.009] Loading serialized mesh: Mesh-Mesh_Outer__tube_236523432000
[SDL][102.009] Loading serialized mesh: Mesh-Curve_Wire__1_298644264000
[SDL][102.009] Loading serialized mesh: Mesh-Mesh_Inner__tube_236520456000
[SDL][102.009] Loading serialized mesh: Mesh-Curve_Wire__2_298645752000
[SDL][102.009] Loading serialized mesh: Mesh-Mesh_Glue_236514504000
[SDL][102.009] Loading serialized mesh: Mesh-Mesh_Isolator_236521944000
[SDL][102.009] Loading serialized mesh: Mesh-Mesh_Bottom__Contact_236578536000
[SDL][102.009] Loading serialized mesh: Mesh-Mesh_Cylinder_236507064000
[SDL][102.009] Loading serialized mesh: Mesh-Mesh_Cube__001_236505576000
[SDL][102.009] Loading serialized mesh: Mesh-Mesh_Cube_236584488000
[SDL][102.025] Loading serialized mesh: Mesh-Mesh_Icosphere__002_236518968000
[SDL][102.025] Loading serialized mesh: Mesh-Mesh_Icosphere__001_236517480000
[SDL][102.040] Loading serialized mesh: Mesh-Mesh_Icosphere_236515992000
[SDL][102.040] Loading serialized mesh: Mesh-Mesh_Plane__003_236529384000
[SDL][102.040] Loading serialized mesh: Mesh-Mesh_Plane__002_236527896000
[SDL][102.040] Loading serialized mesh: Mesh-Mesh_Plane__001_236526408000
[SDL][102.040] Loading serialized mesh: Mesh-Mesh_Plane_236524920000
From that point no step forward happens anymore.

BR
OS - Windows 7 X64
CPU - Intel CORE i7
GPU1 - Variants of notebook card from nVidia
GPU2 - Variants of notebook onboard card from Intel
Lux - Latest possible relaease

BiOzZ
Posts: 6
Joined: Wed Nov 14, 2018 10:27 pm

Re: Network Render Exporterror

Post by BiOzZ » Sun Nov 25, 2018 6:48 pm

I too have a similar problem, i'm using an offsite render box, ports are forwarded, and console is running on the external machine

on the console on windows i get (i redacted the IP, its the hosts public IP)

Code: Select all

LuxCore 2.0
NetBeaconReceiver thread started.
Discovered new node: [Host Public IP]:18018
Creating single image render farm job: C:/Users/Alyx/Desktop/LuxBench/1_LuxCore/00056.bcf
New render farm job: C:/Users/Alyx/Desktop/LuxBench/1_LuxCore/00056.bcf
Job file md5: f3e256ca026a9bde54b399a5bb331192
-------------------------------------------------------
Job started: C:/Users/Alyx/Desktop/LuxBench/1_LuxCore/00056.bcf
-------------------------------------------------------
Node thread started
Film merge thread started
timed out
Traceback (most recent call last):
  File "C:\Users\ALYX\AppData\Local\Temp\_MEI82922\pyluxcoretools.zip\pyluxcoretools\renderfarm\renderfarmjobsingleimage.py", line 393, in NodeThread
    nodeSocket.connect((self.renderFarmNode.address, self.renderFarmNode.port))
socket.timeout: timed out
Node thread done
The node output on the server running on linux

Code: Select all

LuxCore 2.0
Waiting for configuration...
Started
NetBeaconSender thread started.
Waiting for a new connection
That output is more or less mirrored in the console
the netnode tool is also asking me to input an IP address, putting my (client) IP address does nothing to solve it, putting loopback ip does nothing, putting its own public ip does nothing, putting it or my local IPs do nothing.

User avatar
Dade
Developer
Posts: 1528
Joined: Mon Dec 04, 2017 8:36 pm

Re: Network Render time out

Post by Dade » Mon Nov 26, 2018 8:31 am

This is a problem I was told it was gone some time ago. It happens only when Windows is involved. As far as I know, it works fine with Linux. I guess I will have gain to look into it.
Support LuxCoreRender project with salts and bounties

User avatar
Dade
Developer
Posts: 1528
Joined: Mon Dec 04, 2017 8:36 pm

Re: Network Render time out

Post by Dade » Mon Nov 26, 2018 9:07 am

Dade wrote:
Mon Nov 26, 2018 8:31 am
This is a problem I was told it was gone some time ago. It happens only when Windows is involved. As far as I know, it works fine with Linux. I guess I will have gain to look into it.
On a second thought, the error is a time out and it is thrown when try to establish the connection (i.e. the original problem was a dead-lock). 99% of times, this is the result of some firewall/anti-virus related problem. For instance, on my Linux box I have to disable the FW even when running both the console and the node on the local machine because FW rules are applied to localhost interface too.
Support LuxCoreRender project with salts and bounties

BiOzZ
Posts: 6
Joined: Wed Nov 14, 2018 10:27 pm

Re: Network Render time out

Post by BiOzZ » Mon Nov 26, 2018 4:30 pm

Disabling software firewall on windows (antivirus and defender) along with the hardware firewall (both of these i manually implemented exceptions for this previously) did not solve the problem.
the linux server has no third party firewall in software and no hardware firewall so i have my doubts its rejecting this traffic based on any odd linux default rules.

Post Reply