Transparent Backgrounds under standalone render.

Use this forum for general user support and related questions.
Post Reply
BiOzZ
Posts: 6
Joined: Wed Nov 14, 2018 10:27 pm

Transparent Backgrounds under standalone render.

Post by BiOzZ » Sat Nov 24, 2018 10:25 pm

I'm having issues with the transparent backgrounds not rendering correctly (just rendering and saving black) when i export my scene as a file and render it via luxcoreui under linux. Is there something under the config file that was simply missing? or is this simply not implemented yet? i notice

Code: Select all

path.forceblackbackground.enable
is set to zero and yes "transparent film" is enabled in blender before exporting.
Im using luxcoreui over SSH with X forwarding because im still trying to get network rendering to work (but thats a post for another time) and i need light group control for this but this should not really cause any issue.

User avatar
B.Y.O.B.
Developer
Posts: 1816
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: Transparent Backgrounds under standalone render.

Post by B.Y.O.B. » Sat Nov 24, 2018 11:04 pm

transparent film is disabled when exporting a luxcore scene.
to be honest I don't remember why I implemented it this way, I'll look into it.

For now, you could enable the alpha AOV and composite this alpha channel into the image by hand (you might want to enable forceblackbackground in this case, i.e. set it to 1).
Or you could change the RGB_IMAGEPIPELINE into an RGBA_IMAGEPIPELINE, might be a bit more complicated.
Support LuxCoreRender project with salts and bounties

BiOzZ
Posts: 6
Joined: Wed Nov 14, 2018 10:27 pm

Re: Transparent Backgrounds under standalone render.

Post by BiOzZ » Sun Nov 25, 2018 8:34 am

My current solution is just to do X11 forwarding of blender from the offsite server
its clunky and very slow but this seemed like the optimal solution to preserve the scenes

Post Reply