low cpu and gpu usage

Use this forum for general user support and related questions.
kintuX
Posts: 248
Joined: Wed Jan 10, 2018 2:37 am

Re: low cpu and gpu usage

Post by kintuX » Sun Oct 28, 2018 4:23 pm

Dade wrote:
Sun Oct 28, 2018 2:41 pm
kintuX wrote:
Sun Oct 28, 2018 12:42 pm
I am observing same behavior, as if no CPU cores are used with Open CL (or something alike). Also with Standalone.
It's only happening with the 'Azure' latest build.
Are you sure ? I did this test:

1) download https://github.com/LuxCoreRender/LuxCor ... opencl.zip and unzip;

2) run luxcoreui

3) load scenes/cornell/cornell.cfg

4) press "1" (to use PATHOCL)

5) it uses 12 threads on my 6 cores+hyper-threading with a 100% CPU load.

Can you post the output log in the luxcoreui console ?
More tests done. LuxCore engine works fine. :D
I think (but am not sure anymore) the issue lies in the addon.

1. NOT WORKING - Export with addon from 25.10.2018 fails in using CPU OCL (even, if i set it (1) in 'render.cfg').
2. WORKING - Export with addon from 03.10.2018 works fine.
Logs + 'broken' export attached.
LuxCore-logs.zip
(16.99 KiB) Downloaded 2 times
LuxCORE2Tester_LuxCore.zip
(272.55 KiB) Downloaded 1 time
& Investigating further...

User avatar
Sharlybg
Supporting Users
Posts: 815
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: low cpu and gpu usage

Post by Sharlybg » Thu Nov 01, 2018 4:42 pm

I've the same problem here ( have to render 2K interior with only poor R9 390 can't use the power of the i7 80700k ). So what do we do to solve it ?

is there any recent build that fix the low CPU usage ?
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

User avatar
Dade
Developer
Posts: 1458
Joined: Mon Dec 04, 2017 8:36 pm

Re: low cpu and gpu usage

Post by Dade » Thu Nov 01, 2018 7:37 pm

Sharlybg wrote:
Thu Nov 01, 2018 4:42 pm
I've the same problem here ( have to render 2K interior with only poor R9 390 can't use the power of the i7 80700k ). So what do we do to solve it ?

is there any recent build that fix the low CPU usage ?
It is a BlendLuxCore problem so it can not be solved with a new binary. As a work around, you can export (in text format) the scene and render using luxcoreui (for high-res, you can use image view mode). Before to run the rendering, you will have to edit the render.cfg file and delete the line including the string "native.threads.count = 0" (or set the number to the right number of threads).
Support LuxCoreRender project with salts and bounties

User avatar
B.Y.O.B.
Developer
Posts: 1730
Joined: Mon Dec 04, 2017 10:08 pm
Location: Germany
Contact:

Re: low cpu and gpu usage

Post by B.Y.O.B. » Thu Nov 01, 2018 7:42 pm

It's a bug recently introduced in the addon. But I didn't have time to fix it yet.
Support LuxCoreRender project with salts and bounties

User avatar
Sharlybg
Supporting Users
Posts: 815
Joined: Mon Dec 04, 2017 10:11 pm
Location: Ivory Coast

Re: low cpu and gpu usage

Post by Sharlybg » Fri Nov 02, 2018 9:14 am

B.Y.O.B. wrote:
Thu Nov 01, 2018 7:42 pm
It's a bug recently introduced in the addon. But I didn't have time to fix it yet.
Ok not a big problem recently find that bidir + metropolis win over gpu path in my interior scene !
Support LuxCoreRender project with salts and bounties

Portfolio : https://www.behance.net/DRAVIA

Post Reply