Page 1 of 1

Can't install Luxcore 2.1 alpha (solved!)

Posted: Tue Oct 02, 2018 12:19 pm
by xxtioo
Hi,

I tried to install BlendLuxCore-v2.1alpha4-win64.zip on Blender 2.79b (official) and got this message:
Foto-alpha-4.jpg
For alpha0 I got this message:
Foto-alpha-0.jpg
Here is what I have installed on my system:
Foto-02.jpg
What I have already tried:

- Reinstallation of Blender (including: AppData cleared)
- viewtopic.php?f=4&t=216
- Installed: ww_icl_redist_intel64_2018.3.210
- Installed Luxcore 2.0 -> working fine
- several tips I read in this forum
- https://wiki.luxcorerender.org/BlendLuxCore_FAQ

Is anyone able to help me?

Greetings

Ralf

Re: Can't install Luxcore 2.1 alpha

Posted: Tue Oct 02, 2018 3:40 pm
by Dade
xxtioo wrote:
Tue Oct 02, 2018 12:19 pm
- Installed Luxcore 2.0 -> working fine
Does the OpenCL version of LuxCoreRender v2.0 work fine too ? Have you tried to install the alpha4 OpenCL-less version ? Do you have a NVIDIA GPU ? There has been some problem with some old NVIDIA OpenCL drivers. The latest driver version seems to work fine.

The other most obvious explanation is the lack of ww_icl_redist_intel64_2018.3.210 but you say to have installed the package so it should be ruled out.

Re: Can't install Luxcore 2.1 alpha

Posted: Tue Oct 02, 2018 3:54 pm
by xxtioo
As described i had installed "BlendLuxCore-v2.1alpha4-win64.zip" so it is the NO-OpenCL version.

Unfortunately i have no NVIDA-GPU. Just an old ON-Board HD-Intel graphics

Re: Can't install Luxcore 2.1 alpha

Posted: Tue Oct 02, 2018 3:59 pm
by xxtioo
If I try to install "BlendLuxCore-v2.0-win64-opencl" this happend:
Foto-20-openCL.jpg

Re: Can't install Luxcore 2.1 alpha

Posted: Tue Oct 02, 2018 4:28 pm
by Dade
Try to download the stand alone version: https://github.com/LuxCoreRender/LuxCor ... -win64.zip

I assume, if you try to run luxcoreui.exe, you will still get an error. You can than use a tool like http://www.dependencywalker.com (open luxcoreui.exe file with dependencywalker) to check what DLL luxcoreui.exe is missing. You should get something like:
miss.jpg
Don't worry about the "API-MS-WIN-blabla.DLL", but it should show a problem with some of the other main DLL.

Re: Can't install Luxcore 2.1 alpha

Posted: Tue Oct 02, 2018 4:45 pm
by xxtioo
Done! The Result:

after starting "luxcoreui" if got this:
Error-01.jpg
after checking "luxcoreui" with dependencywalker I got this:
Error-02.jpg

Re: Can't install Luxcore 2.1 alpha

Posted: Tue Oct 02, 2018 6:06 pm
by Dade
xxtioo wrote:
Tue Oct 02, 2018 4:45 pm
Done! The Result:

after starting "luxcoreui" if got this:

Error-01.jpg

after checking "luxcoreui" with dependencywalker I got this:

Error-02.jpg
You seem to miss "vcomp140.dll". It should be part of VisualStudio C++ 2017 redistribute: https://support.microsoft.com/it-it/hel ... -downloads (https://aka.ms/vs/15/release/vc_redist.x64.exe). It was listed in alpha0 message: viewtopic.php?f=9&t=335

But I guess it is better to repeat the message for people who haven't installed alpha0.

Re: Can't install Luxcore 2.1 alpha

Posted: Tue Oct 02, 2018 6:30 pm
by xxtioo
I installed " VisualStudio C++ 2017" -> Result:

IT WORKED!!!!!!!!!!!!

Thank you so much :-))))))))))))))))))))

Re: Can't install Luxcore 2.1 alpha (solved!)

Posted: Tue Oct 02, 2018 7:59 pm
by B.Y.O.B.
Dade wrote:
Tue Oct 02, 2018 6:06 pm
But I guess it is better to repeat the message for people who haven't installed alpha0.
Yes, it should be part of the announcements in the news section.
I also added this information to the relevant wiki pages and FAQ for BlendLuxCore (e.g. installation instructions), as well as the BlendLuxCore github release description of alpha4.